E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados. [RESOLVIDO]

1. E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados. [RESOLVIDO]

Darlisson Mesquita Batista
Darlisson

(usa Outra)

Enviado em 20/08/2020 - 20:21h

Olá.
Tentei instalar a versão mais recente do R (4.0.2) no Linux Mint 20. Para isso adicionei o seguinte repositório "deb https://cloud.r-project.org/bin/linux/ubuntu bionic-cran40/"

Fiz isso dessa maneira:
sudo add-apt-repository 'deb https://cloud.r-project.org/bin/linux/ubuntu bionic-cran40/'
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E298A3A825C0D65DFD57CBB651716619E084DAB9
sudo apt-get update

Porém quando executei o comando de instalação (sudo apt-get install r-base), deu o seguinte erro:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
r-base : Depende: r-base-core (>= 4.0.2-1.1804.0) mas não será instalado
Depende: r-recommended (= 4.0.2-1.1804.0) mas não será instalado
Recomenda: r-base-html mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Alguém teria ideia do que estaria levando a esse erro?
desde já agradeço!!


  


2. MELHOR RESPOSTA

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 21/08/2020 - 07:50h

Install new version of R (4.0)
https://rtask.thinkr.fr/installation-of-r-4-0-on-ubuntu-20-04-lts-and-tips-for-spatial-packages/



3. Re: E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados. [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 20/08/2020 - 20:47h


Uma dúvida.. o Mint 20 não é baseado no Ubuntu 20.04? Se for, você adicionou o repositório referente ao Ubuntu Bionic (acho que é o 18.04). tenta editar o repositório


4. Re: E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados. [RESOLVIDO]

Darlisson Mesquita Batista
Darlisson

(usa Outra)

Enviado em 20/08/2020 - 22:27h

Pebis escreveu:


Uma dúvida.. o Mint 20 não é baseado no Ubuntu 20.04? Se for, você adicionou o repositório referente ao Ubuntu Bionic (acho que é o 18.04). tenta editar o repositório


Olá, você está correto, realmente o Linux Mint 20 é baseado no Ubuntu 20.04. Entrei no site ("https://nbcgib.uesc.br/mirrors/cran/"), para ver se realmente o erro poderia está no repositório, mas via que não. Lá é recomendado o uso dos repositórios (logo abaixo) para a instalação do R 4.0.2 no Ubuntu 20.04.

deb https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/
deb https://cloud.r-project.org/bin/linux/ubuntu bionic-cran40/
deb https://cloud.r-project.org/bin/linux/ubuntu xenial-cran40/

OBS: Posso ter entendido errado, não sou especialista em Linux.
Obrigado por responder!!


5. Re: E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados. [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 21/08/2020 - 07:48h

-remova as fontes que não sejam do ubuntu-20.04-focal-fossa p/ não ter problemas c/ linuxmint-20




6. Re: E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados. [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 21/08/2020 - 09:01h


Darlisson escreveu:

Pebis escreveu:


Uma dúvida.. o Mint 20 não é baseado no Ubuntu 20.04? Se for, você adicionou o repositório referente ao Ubuntu Bionic (acho que é o 18.04). tenta editar o repositório


Olá, você está correto, realmente o Linux Mint 20 é baseado no Ubuntu 20.04. Entrei no site ("https://nbcgib.uesc.br/mirrors/cran/"), para ver se realmente o erro poderia está no repositório, mas via que não. Lá é recomendado o uso dos repositórios (logo abaixo) para a instalação do R 4.0.2 no Ubuntu 20.04.

deb https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/
deb https://cloud.r-project.org/bin/linux/ubuntu bionic-cran40/
deb https://cloud.r-project.org/bin/linux/ubuntu xenial-cran40/

OBS: Posso ter entendido errado, não sou especialista em Linux.
Obrigado por responder!!


Mas se tem a opção do Ubuntu 20 que é o focal, tenta com esse:

deb https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/




7. Re: E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados. [RESOLVIDO]

Darlisson Mesquita Batista
Darlisson

(usa Outra)

Enviado em 21/08/2020 - 09:31h



Olá.
Realmente o problema estava no repositório, removi o bionic-cran40/ e substitui pelo focal-cran40/. Segui este artigo de instalação.

Obrigado... problema resolvido!!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts