Dúvidas com pacotes descontinuados

1. Dúvidas com pacotes descontinuados

Guilherme Patriarcha Faria
gurermus

(usa Debian)

Enviado em 16/06/2024 - 12:25h


Bom dia, boa tarde, boa noite.
Então gostaria de saber a princípio como instalar o PyQt4 e PyQt5 no Debian 12 Bookworm, ao que parece os desenvolvedores descontinuaram por questões de segurança. E se isso não for algo possível.
Gostaria de saber como fazer um downgrade na versão do linux, porque não consigo encontrar a instalação de uma distro "OLDOLDSTABLE" no qual roda esses dois bichinhos aí de cima.
O porque disso tudo? Eu não consigo encontrar substitutos para eles, e então não consigo instalar a minha impressora, ela só instala se tiver isso, já fiz de tudo no HPLIP e no CUPS não tem jeito, já baixei tudo quanto foi atualização de plugin na "https://sourceforge.net/projects/hplip/", já testei cabos USB, portas USB, e a própria impressora imprime em outro computador (com o mesmo cabo inclusive).
Obs.: Impressora é uma "HP Laserjet M1132 MFP".

Então já que o quebra cabeça aqui é muito grande, pensei que seria uma solução instalar uma versão antiga do Debian tipo "Jessie" ou "Buster" em uma máquina virtual nessa mesma máquina e instalar a impressora lá, depois eu me viro com o caminho para imprimir, será que alguém pode me ajudar com isso? Só preciso de um lugar aonde baixar essa distribuição do linux. Porque no próprio servidor as pastas encontram-se vazias.


  


2. Re: Dúvidas com pacotes descontinuados

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 16/06/2024 - 12:42h

Considerações

*** Vc está certo do nome do pacote ... não seria python3-pyqt5 ??? se for, a versão atual do bookworm é python3-pyqt6
*** V aí se ajuda


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Re: Dúvidas com pacotes descontinuados

Lucas Mior
lucasmior

(usa Arch Linux)

Enviado em 17/06/2024 - 13:15h

Como você tentou instalar os pacotes? Qual a mensagem de erro ao tentar instalar pyqt4 e pyqt5 no debian?


4. Re: Dúvidas com pacotes descontinuados

Guilherme Patriarcha Faria
gurermus

(usa Debian)

Enviado em 17/06/2024 - 20:41h


Mauriciodez escreveu:

Considerações

*** Vc está certo do nome do pacote ... não seria python3-pyqt5 ??? se for, a versão atual do bookworm é python3-pyqt6
*** V aí se ajuda


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




Sim esse nome mesmo coloquei só uma parte do nome kkkkk achei que seria o suficiente para identificá-lo. Mas em todo caso parece que o pacote "python3-pyqt6" não serve o HPLIP não faz a instalação da Impressora sem aquelas extensões.



5. Re: Dúvidas com pacotes descontinuados

Guilherme Patriarcha Faria
gurermus

(usa Debian)

Enviado em 17/06/2024 - 20:45h


lucasmior escreveu:

Como você tentou instalar os pacotes? Qual a mensagem de erro ao tentar instalar pyqt4 e pyqt5 no debian?


Amigo estou tentando já faz um tempo por todos os meios possíveis, mas o erro é o mesmo no terminal.

>>>>>>
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
python3-pyqt4 : Depende: python3 (< 3.8) mas 3.11.2-1+b1 está para ser instalado
Depende: libqt4-dbus (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-declarative (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-designer (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-help (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-network (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-script (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-scripttools (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-svg (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-test (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-xml (>= 4:4.8.0-1~) mas não será instalado
Depende: libqt4-xmlpatterns (>= 4:4.8.0-1~) mas não será instalado
Depende: libqtassistantclient4 (>= 4.6.3) mas não será instalado
Depende: libqtcore4 (>= 4:4.8.0-1~) mas não será instalado
Depende: libqtgui4 (>= 4:4.8.0-1~) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.



6. Re: Dúvidas com pacotes descontinuados

Guilherme Patriarcha Faria
gurermus

(usa Debian)

Enviado em 17/06/2024 - 20:52h

Aqui foi quando eu erroneamente fiz upgrade no sistema, se soubesse que ia dar m.... talvez não tivesse feito.

https://www.vivaolinux.com.br/topico/Novo-no-Linux/Debian-11-Instalacao-de-HP-M1132-MFP.

Desde então sigo estudando traduzindo fóruns de outros países, mas nada solucionou meu problema, meu sistema já deve estar cheio de porcarias inúteis, mas preciso resolver a impressora antes de limpar a máquina.

>>>>>>>
Sobre os Erros: Esse quando tento instalar a impressora, ele não faz o download automático da HP.
>>>>>>>
HP Linux Imaging and Printing System (ver. 3.22.10)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QSocketNotifier: Can only be used with threads started with QThread
Searching... (bus=usb, search=(None), desc=0)

HP Linux Imaging and Printing System (ver. 3.22.10)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 3.22.10)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QSocketNotifier: Can only be used with threads started with QThread
Checking for network connection...
Traceback (most recent call last):
File "/usr/share/hplip/ui5/plugindialog.py", line 237, in NextButton_clicked
ok = utils.check_network_connection()
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File "/usr/share/hplip/base/utils.py", line 2294, in check_network_connection
status = download_via_curl(url, head=True)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File "/usr/share/hplip/base/utils.py", line 2273, in download_via_curl
log.debug("curl returned: %d" % status)
~~~~~~~~~~~~~~~~~~~~^~~~~~~~
TypeError: %d format: a real number is required, not NoneType
Aborted
error: The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins. Please run 'hp-plugin' as normal user to install plug-ins. Visit http://hplipopensource.com for more infomation.

Done.

>>>>>>>>>>
E esse quando tento fazer manualmente. a instalação do plugin
>>>>>>>>>

HP Linux Imaging and Printing System (ver. 3.22.10)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 3.22.10)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QSocketNotifier: Can only be used with threads started with QThread

Done.



7. Re: Dúvidas com pacotes descontinuados

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 17/06/2024 - 21:21h


jovem ... vc tem que aprender a dar as informações completas pq a bola de cristal da galera é meio tabajara ... veja bem:
*** Se só parte do nome servisse, não teria fundamento nenhum os kras estenderem o nome concorda ???
*** Te pediram para postar o saída de um comando e vc só postou o final ... se alguém te mandasse esse mesmo final, vc saberia do que se trata, não é ?!?!?!? então quando alguém te pedir a saída de um comando vc poste desde o comando dado até o último caractere de retorno ... mande de novo pois parece que vc está tentando instalar uma versão antiga de qualquer coisa ( não da para saber o que pq vc omitiu ) !!!

abçs

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




8. Re: Dúvidas com pacotes descontinuados

Guilherme Patriarcha Faria
gurermus

(usa Debian)

Enviado em 17/06/2024 - 21:24h


Mauriciodez escreveu:


jovem ... vc tem que aprender a dar as informações completas pq a bola de cristal da galera é meio tabajara ... veja bem:
*** Se só parte do nome servisse, não teria fundamento nenhum os kras estenderem o nome concorda ???
*** Te pediram para postar o saída de um comando e vc só postou o final ... se alguém te mandasse esse mesmo final, vc saberia do que se trata, não é ?!?!?!? então quando alguém te pedir a saída de um comando vc poste desde o comando dado até o último caractere de retorno ... mande de novo pois parece que vc está tentando instalar uma versão antiga de qualquer coisa ( não da para saber o que pq vc omitiu ) !!!

abçs

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



Tá Certo, mas olha se puder dar uma lida no post anterior eu editei e coloquei algumas informações.


9. Re: Dúvidas com pacotes descontinuados

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 17/06/2024 - 21:31h


gurermus escreveu:
Tá Certo, mas olha se puder dar uma lida no post anterior eu editei e coloquei algumas informações.


olha só ... acabei de te falar que vc estava tentando instalar uma versão antiga de qualquer coisa ... era de se esperar que pelo menos vc fosse lá no site para conferir a versão do HPLIP

vc está tentando a versão 3.22 ... no site a versão é a 3.24 ... então baixe e tente instalar a versão atualizada do HPLIP !!!

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




10. Re: Dúvidas com pacotes descontinuados

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 17/06/2024 - 23:06h

Por que usar um programa obsoleto e sem suporte?






11. Re: Dúvidas com pacotes descontinuados

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 17/06/2024 - 23:21h


clodoaldops escreveu:
Por que usar um programa obsoleto e sem suporte?


essa versão antiga do hplip é a disponível no repositório do debian, o problema é que não sei o que ele tentou fazer pq ele não postou entendeu ???
mauricio@phantom ~/Desktop $ apt list hplip
Listing... Pronto
hplip/stable 3.22.10+dfsg0-2 amd64


É de se esperar que a versão do repositório não de problema mas sem saber o que foi executado fica meio embaçado de ajudar corretamente !!!


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




12. Re: Dúvidas com pacotes descontinuados

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 18/06/2024 - 00:12h

gurermus escreveu:
Então gostaria de saber a princípio como instalar o PyQt4 e PyQt5 no Debian 12 Bookworm, ....


campeão olha só ... fiz uns testes aqui com debian 9,10,12 e em nenhum deles o python3-pyqt é dependência do 'hplip' então se vc quer instalar ele vai ter que ser isoladamente
sudo apt install python3-pyqt6 


NOTA: acho meio estranho uma impressora HP precisar de um pacote que não é dependência do HPLIP porém entretanto todavia !!!

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------





01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts