NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

1. NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Jéssica Mazoni Moura
jessicamazoni

(usa Ubuntu)

Enviado em 25/07/2017 - 16:40h

Ajudinha aqui,

Fui instalar o git e ocorreu o seguinte erro:

~ sudo apt-get install git-all
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
git-all is already the newest version (1:2.7.4-0ubuntu1.1).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 7 não atualizados.
2 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Configurando runit (2.1.2-3ubuntu1) ...
start: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada
dpkg: erro ao processar o pacote runit (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas com dependências impedem a configuração de git-daemon-run:
git-daemon-run depende de runit; porém:
Pacote runit não está configurado ainda.

dpkg: erro ao processar o pacote git-daemon-run (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
Erros foram encontrados durante o processamento de:
runit
git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)


ENCONTREI O MESMO ERRO E LÁ A SOLUÇÃO ERA:
Abra O Synaptic e vá até o menu staus.
Vai ter uma seção com o nome "pacotes quebrados", selecione todos os pacotes que for listados nesta seção e clique em remover completamente.

Repita esse procedimento para a sessão 'instalado [autoremovível]'.

Depois feche o synaptic, vá até o terminal e digite:
sudo -i
apt autoremove
apt clean
apt autoclean
apt update
apt upgrade

PORÉM EU NÃO TENHO A OPÇÃO pacotes quebrados E NEM A instalado [autoremovível].

Alguém me ajuda!


  


2. Re: NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 25/07/2017 - 17:13h

-atualize seu ubuntu-16,04
sudo apt-get update
sudo apt-get upgrade

-reporte mensagens de erro se houver


************
Meu Blog
https://dicaslinuxmint.blogspot.com.br/


3. Re: NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Usuario
USUARIO21

(usa Debian)

Enviado em 25/07/2017 - 17:17h

Só acrescentando o Clodo, tenta
apt-get -f install 



4. Re: NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Jéssica Mazoni Moura
jessicamazoni

(usa Ubuntu)

Enviado em 25/07/2017 - 17:26h

clodoaldops escreveu:

-atualize seu ubuntu-16,04
sudo apt-get update
sudo apt-get upgrade

-reporte mensagens de erro se houver


************
Meu Blog
https://dicaslinuxmint.blogspot.com.br/


➜ ~ sudo apt-get update
Atingido:1 http://archive.canonical.com/ubuntu xenial InRelease
Atingido:2 http://archive.ubuntu.com/ubuntu xenial InRelease
Atingido:3 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease
Obter:4 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Obter:5 https://dl.winehq.org/wine-builds/ubuntu xenial InRelease [4.701 B]
Obter:6 https://dl.winehq.org/wine-builds/ubuntu xenial/main amd64 Packages [13,7 kB]
Obter:7 https://dl.winehq.org/wine-builds/ubuntu xenial/main i386 Packages [13,6 kB]
Obter:8 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Obter:9 http://archive.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Baixados 338 kB em 2s (150 kB/s)
Lendo listas de pacotes... Pronto
➜ ~ sudo apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
linux-generic linux-headers-generic linux-image-generic linux-signed-generic
linux-signed-image-generic
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.
2 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Configurando runit (2.1.2-3ubuntu1) ...
start: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada
dpkg: erro ao processar o pacote runit (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas com dependências impedem a configuração de git-daemon-run:
git-daemon-run depende de runit; porém:
Pacote runit não está configurado ainda.

dpkg: erro ao processar o pacote git-daemon-run (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
Erros foram encontrados durante o processamento de:
runit
git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)


5. Re: NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Jéssica Mazoni Moura
jessicamazoni

(usa Ubuntu)

Enviado em 25/07/2017 - 17:27h

USUARIO21 escreveu:

Só acrescentando o Clodo, tenta
apt-get -f install 


Depois que fiz o que Clodo falou e em seguida fiz o que você falou, apareceu:

~ apt-get -f install
E: Não foi possível abrir arquivo de trava /var/lib/dpkg/lock - open (13: Permissão negada)
E: Não foi possível criar acesso exclusivo ao directório de administração (/var/lib/dpkg/), é root?
➜ ~



6. Re: NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Usuario
USUARIO21

(usa Debian)

Enviado em 25/07/2017 - 17:31h

Tem que ser com o sudo o comando, mals ae.


7. Re: NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Jéssica Mazoni Moura
jessicamazoni

(usa Ubuntu)

Enviado em 25/07/2017 - 17:33h

USUARIO21 escreveu:

Tem que ser com o sudo o comando, mals ae.


Persiste

➜ ~ sudo apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.
2 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Configurando runit (2.1.2-3ubuntu1) ...
start: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada
dpkg: erro ao processar o pacote runit (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas com dependências impedem a configuração de git-daemon-run:
git-daemon-run depende de runit; porém:
Pacote runit não está configurado ainda.

dpkg: erro ao processar o pacote git-daemon-run (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
Erros foram encontrados durante o processamento de:
runit
git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)





8. Re: NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Perfil removido
removido

(usa Nenhuma)

Enviado em 25/07/2017 - 17:52h

Uma pergunta: você realmente usa o runit?


9. Re: NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Jéssica Mazoni Moura
jessicamazoni

(usa Ubuntu)

Enviado em 25/07/2017 - 17:53h

clodoaldops escreveu:

-atualize seu ubuntu-16,04
sudo apt-get update
sudo apt-get upgrade

-reporte mensagens de erro se houver


************
Meu Blog
https://dicaslinuxmint.blogspot.com.br/


Clodo, ao pesquisar vários tópicos com erros semelhantes, vi que você sugeria colocar os comandos
sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo apt-get update
sudo apt-get upgrade
todos funcionam, porém quando coloco o ultimo, ele da:

sudo apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
linux-generic linux-headers-generic linux-image-generic linux-signed-generic
linux-signed-image-generic
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.
2 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Configurando runit (2.1.2-3ubuntu1) ...
start: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada
dpkg: erro ao processar o pacote runit (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas com dependências impedem a configuração de git-daemon-run:
git-daemon-run depende de runit; porém:
Pacote runit não está configurado ainda.

dpkg: erro ao processar o pacote git-daemon-run (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
Erros foram encontrados durante o processamento de:
runit
git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)




10. Re: NÃO QUER DESINSTALAR E NEM PERMITE QUE EU INSTALE OUTRAS COISAS - UBUNTU 16.04 LTS

Jéssica Mazoni Moura
jessicamazoni

(usa Ubuntu)

Enviado em 25/07/2017 - 17:54h

uruk escreveu:

Uma pergunta: você realmente usa o runit?


No caso eu não uso, estou tentando usar rs.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts