Sinistro !!! Mouse usb funciona no terminal, mas não no KDE [RESOLVIDO]

1. Sinistro !!! Mouse usb funciona no terminal, mas não no KDE [RESOLVIDO]

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 10/09/2019 - 21:04h

A princípio parece uma coisa bem simples, o mouse usb funciona no terminal, mas ao entrar no X, não funciona mais... não é só isso!
Olhando o log (message), o mouse fica em reboot infinito:


Sep 10 20:53:31 slackdev kernel: usb 1-1.2: USB disconnect, device number 17
Sep 10 20:53:32 slackdev kernel: usb 1-1.2: new low-speed USB device number 18 using ehci-pci
Sep 10 20:53:32 slackdev kernel: usb 1-1.2: New USB device found, idVendor=1c4f, idProduct=0034
Sep 10 20:53:32 slackdev kernel: usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Sep 10 20:53:32 slackdev kernel: usb 1-1.2: Product: Usb Mouse
Sep 10 20:53:32 slackdev kernel: usb 1-1.2: Manufacturer: SIGMACHIP
Sep 10 20:53:32 slackdev kernel: input: SIGMACHIP Usb Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/0003:1C4F:0034.0086/input/input146
Sep 10 20:53:32 slackdev kernel: hid-generic 0003:1C4F:0034.0086: input,hidraw0: USB HID v1.10 Mouse [SIGMACHIP Usb Mouse] on usb-0000:00:1a.0-1.2/input0
Sep 10 20:53:32 slackdev mtp-probe: checking bus 1, device 18: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2"
Sep 10 20:53:32 slackdev mtp-probe: bus: 1, device: 18 was not an MTP device


É muito doido !!!! Esse MTP... Estranho né! kkkkk

Já tentei com outros mouses, é do mesmo jeito. REPITO: O mouse está funcionando NORMALMENTE no terminal (fora do X). Qualquer porta USB dá o mesmo resultado.

O touchpad funciona tranquilo no X.

Não estou usando xorg.conf

Minha distro é Slackware64 14.2


  


2. Re: Sinistro !!! Mouse usb funciona no terminal, mas não no KDE [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 11/09/2019 - 17:04h

é mouse sem fio? estou estranhando porque está pedindo suporte MTP, e lógico, não tem.

Seria conveniente tentar usar Xorg.conf só pro mouse, veja por exemplo aqui

https://www.linuxquestions.org/questions/slackware-14/mouse-wheel-not-working-in-kde-351252-print/

¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


3. RESOLVIDO

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 11/09/2019 - 19:26h

Então Albfneto,
Realmente muito doido aparecer MTP pro mouse.

Conforme você orientou, também não deu certo. Mas foi a luz que faltava, pois me lembrei de olhar no log (Xorg.0.log) e acabei encontrando um "...cannot open shared object file: No such file or directory"
Ou seja, por algum motivo obscuro da natureza a lib foi retirada (o Slack tem disso as vezes, você instala ou atualiza e quando menos se espera... lá se foi alguém).
Foi só instalar e pronto.

Eu poderia citar aqui qual foi, mas depois dela instalei várias outras coisas e acabei me esquecendo qual era.

De qualquer forma, fica a dica: PROBLEMAS NO X ? OLHEM NO Xorg.0.log (em /var/log/), procure por EE que indica erros. É fácil de entender.

Obrigado Albfneto.

____________________________
PLANTEC Soluções Sustentáveis


4. Re: Sinistro !!! Mouse usb funciona no terminal, mas não no KDE [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 11/09/2019 - 19:32h


é isso.... problemas no Xorg, a primeira coisa é olhar o Log do xorg, pq ele mostra os erros.
em alguns casos, mesmo a distro sendo sem xorg.conf, melhora se criar um. Ou variantes, arquivos no etc/X11/xorg.conf.d
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts