Problema da placa de audio

1. Problema da placa de audio

Fernando Lemos
Ferneik

(usa Ubuntu)

Enviado em 11/10/2008 - 13:05h

Olá amigos do VOL. Essa é minha primeira participação na comunidade.
No meu notebook HP Pavilion DV2000 usando Ubuntu 8.04, o som e totem-xine não funcionam, mesmo com o volumes do som não consegue aumentar. Já verifiquei o meu dispositivo de audio aparece no comando lspci | grep "Audio": Audio Device: nVidia Corporation MCP51 High Definition Audio, então a minha placa foi reconhecida. Tentei fazer os comandos que aparece uns erros, veja o seguinte:
bash: alsaconf: command not found.
alsamixer: function snd ctl_open failed for default: no such file or directory.
alsactl store: save_state:1251: no soundcards found...

Alguém teria alguma dica de como resolver esse problema?


  


2. Problema da placa de audio

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 11/10/2008 - 17:40h

Tenho uma dica sim.
Note que sua placa de som é moderníssima do tipo HD- High definition.
Vou sugerir uma solução que implementei num note book Acer, mas acho que a nvidia tem um driver para sua placa. Procure no VOL pois já li sobre isso.


AGORA, vai a minha solução: (por sua conta e risco)
HD significa High Definition que é suportado pelo kernel linux-rt que está no repositório so Unbuntu. Esse kernel além de ser para máquinas menos velhas ele tem o intervalo de espera de 1 mili-segundo (um segundo dividido por 1000). O kernel padrão, o generic tem intervalo de 4 mili-segundos, ou um segundo dividido por 250.

Isso não aumenta a velocidade, mas diminui a lentidão.
Para trocar o kernel use o synaptic procure "linux" e precisa instalar sempre a mesma versão do kernel:
2.6.24-19-rt
Precisa instalar
kernel image
kernel-modules
kernel-headers
kernel-source
todos exatamente da mesma versão. Se miusturar vai dar salada legal.
Tem um monte de módules e headers eu instale todos, sempre exatamente da mesma versão.

Depois precisa verificar que o /boot/grub/menu.lst foi atualizado, se não foi precisa atualizar, senão ele fica dando boot com o kernel velho- o generic.

Deois que der boot precisa reinstalar os programas que compilaram kernel module, porque os módulos são compilados para a exata versão do kernel. Isso significa que tem que reisntar tudo que não foi instalado via apt ou syunaptic.
O que foi instalado pelo apt ou synaptic os pacotes de modules já dão conta.

Fiz isso. O multimedia fica legal inclusive o rosegarden, um programa sofisticado de edição de audio.
Boa sorte.
Não lamente, o windows Vista só consegue 10 ms de resolução, uma pobreza, e o driver é uma gambiarra braba para fazer as placas HD funcionarem.


3. Re: Problema da placa de audio

Sérgio Abrantes Junior
pelo

(usa Debian)

Enviado em 12/10/2008 - 00:31h

Bom dia,

Tente fazer o que eu disse na dica abaixo:

http://www.vivaolinux.com.br/dica/Configurar-som-no-Linux-atraves-do-ALSA/

Sérgio Abrantes
[]'s


4. Re: Problema da placa de audio

Fernando Lemos
ferneik

(usa Ubuntu)

Enviado em 12/10/2008 - 19:47h

Pelo, já baxei o pacote de alsa-driver-1.0.18rc3.tar.bz2 no site de AlsaProject.
Fiz seguir as instruções lá no http://www.vivaolinux.com.br/dica/Instalando-o-ALSA-atualizado-(rapido)/
e descompatei o arquivo no diretório /usr/src. Então tentei fazer comando ./configure que apereceu um erro, porque está faltado diretório /usr/src/linux. E agora o que eu faço?

Veja o seguinte:
[email protected]:/usr/src/alsa-driver-1.0.18rc3# ./configure
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /usr/src/alsa-driver-1.0.18rc3
checking cross compile...
checking for directory with kernel source... ./configure: line 4734: cd: /usr/src/linux: No such file or directory
/usr/src/linux
checking for directory with kernel build...
checking for kernel linux/version.h... no
The file /include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).


5. Problema da placa de audio

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 14/10/2008 - 20:11h

Instale o pacote linux kernel source que tem no repositório do Ubuntu.
Você está tentando compilar módulo sem o source do kernel, não vai funcionar nunca.
O instalador de driver tem que compilar módulo.O linux a rigor não tem driver tem kerenl module.
É isso, deve funcionar.
Problema da placa de audioInstale o linux kernel source e repita o comando configure.
Estou curioso para ver se isso funciona. Em tese o alsa tem driver para nvidia que é um dos fabricantes que mais suporta o linux.


6. Re: Problema da placa de audio

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 14/10/2008 - 20:31h

Tá ter faltando um modulo de Kernel.
No meu Sabayon, funfa bem a High definition, no notebook, mas é kernel 26.
Siga a dica do nIcolo, depois vc atualiza o ALSA.
Outra opção. trocar o Ubuntu pelo Ubuntu mais novo, ele tem reconhecimento de hardware mais moderno e outro kernel


7. RESOLVIDO!

Fernando Lemos
ferneik

(usa Ubuntu)

Enviado em 09/11/2008 - 17:49h

Primeiro peço desculpa pela demora para resolver com o problema.
Nicolo e albfneto estavam certo que eu não tinha instalando o pacote linux kernel source, então resolvi instalar nova versão do kernel source para poder fazer um comando "MAKE" e "MAKE INSTALL".
Já testei o som funciona perfeitamente, mas acabei de dar um comando MAKE INSTALL apareceu um aviso:

WARNING!!! The mixer channels for the ALSA driver are muted by default!!!
**************************************************************************
You would use some ALSA or OSS mixer to set the appropriate volume.

Não faço ideia porque deu um aviso como acima, o que vocês sugerem isso?


Muito obrigado por vocês têm muito apoio.




8. Re: Problema da placa de audio

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 09/11/2008 - 17:58h

olá essas mensagens normalmente aparecem no boot: tente coloacr em modo verbose seu boot, e as vezes aparecem
e no make pra vc apareceu.
não se preucupe,geralmente indicam que o sistema aida está com o ALSA "desligado" no boot ou na compilação,
não se preucupe, a não seu que o som esteja com problema....
Gosto de ALSA,o ALSA é um "Pé de Boi"... resolve problemas de som de muitas e muitas placas!

Nicolo, isso quando acha o driver para HD áudio! no meu vista 64, foi um sufoco.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts