MEU MICROFONE NÃO FUNCIONA, MAS SOMENTE NOS NAVEGADORES (LINUX MINT) AJUDA POR FAVOR!

1. MEU MICROFONE NÃO FUNCIONA, MAS SOMENTE NOS NAVEGADORES (LINUX MINT) AJUDA POR FAVOR!

João Vitor Vasconcelos Silveira
joaolinuxmint1

(usa Linux Mint)

Enviado em 01/08/2021 - 12:49h

Galera, por favor, uso o linux mint a anos e nunca tive um problema exatamente assim. O meu microfone simplesmente não funciona, no começo achei que era driver, ou que ele estava quebrado, mas ele funciona nos demais programas como OBS studio e o Audacity, mas se recusa a funcionar no Firefox ou Chrome. Eu fiz um teste de microfone online, no teste ele me deu duas opções mas é um notebook, só tem um microfone. Ele funcionou no teste com uma das opções e no chrome tem nas configurações um lugar pra mudar o mic principal, mudei para o nome que funcionava no áudio e mesmo assim, nada e no firefox que é meu navedor principal nem tem essa opção. Alguém sabe como resolver sem tentar uma reinstalação ou troca de distro eu fiz muitas modificações de temas e tal e não queria recomeçar do zero. Alguém?


  


2. Re: MEU MICROFONE NÃO FUNCIONA, MAS SOMENTE NOS NAVEGADORES (LINUX MINT) AJUDA POR FAVOR!

Buckminster
Buckminster

(usa Debian)

Enviado em 01/08/2021 - 17:45h

Várias sugestões.
1 - Verifique se o pulseaudio está instalado:
sudo pulseaudio
Caso não estiver, instale:
sudo apt-get install pulseaudio
Configure os mics nos navegadores e teste.

Caso já estiver instalado, faça:
sudo killall pulseaudio
rm -r ~/.config/pulse/*
rm -r ~/.pulse*
Reinicie o note, verifique as configurações e caso for preciso configure os mics nos navegadores de novo e teste.
Mas veja bem, primeiro tenha a certeza de que os mics estão setados corretamente nos navegadores e verifique se o problema não é no site o qual tu está tentando usar o mic.

2 - sudo apt-get install pavucontrol
sudo pavucontrol
Selecione o menu "Reprodução" e verifique se você o definiu para Mostrar aplicativos. Agora, comece a reproduzir algo do Google Chrome. Ele aparecerá lá e mostrará qual dispositivo de saída está sendo usado para o Google Chrome. Verifique se ele está definido no dispositivo de saída que você está tentando usar.
Deverá funcionar tanto para Chrome como para Firefox.

3 - No Firefox tente:
Clique nos três risquinhos acima à direita > Configurações > na aba Geral role a página e procure "Desempenho" e desmarque a caixinha, abrirá "Usar aceleração de hardware quando disponível, desmarque-a também, reinicie o Firefox e teste o microfone.
Mas antes tenha certeza de que o problema é no navegador e não no site que você está acessando e tentando usar o microfone.
No Chrome também tem, fuce e encontre.
Esta é a última opção, mas não se preocupe, caso desabilitar a aceleração de hardware não der certo tu pode desfazer.

Também pode tentar:
sudo apt-get install flashplugin-installer
Ou vá nas configurações dos navegadores e veja se precisa habilitar algum plug-in relativo ao mic.

Também tu pode desinstalar completamente cada navegador e instalá-lo de novo e veja se resolve.
Caso não resolver, poste aqui a marca e o modelo do teu note.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts