Instalação Debian Lenny ERRO

1. Instalação Debian Lenny ERRO

Nadson Cerqueira
nadsoncs

(usa Debian)

Enviado em 30/05/2009 - 23:10h

Olá pessoal,

Estou com problemas para instalar o mysql no debian.
Andei pesquisando e vi que esse erro é recorente, porém não encontrei solução, se alguem puder ajudar.
Desde já agradeço.

Segue o erro:

nadsonpc:/home# aptitude install mysql-server
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Escrevendo informações estendidas de estado... Pronto
Lendo descrições de tarefas... Pronto
Os NOVOS pacotes a seguir serão instalados:
mysql-client-5.0{a} mysql-server mysql-server-5.0{a}
0 pacotes atualizados, 3 novos instalados, 0 a serem removidos e 5 não atualizados.
É preciso obter 0B/34,5MB de arquivos. Depois do desempacotamento, 102MB serão usados.
Você deseja continuar? [Y/n/?] y
Escrevendo informações estendidas de estado... Pronto
Pré-configurando pacotes ...
Selecionando pacote previamente não selecionado mysql-client-5.0.
(Lendo banco de dados ... 140800 arquivos e diretórios atualmente instalados).
Desempacotando mysql-client-5.0 (de .../mysql-client-5.0_5.0.51a-24+lenny1_i386.deb) ...
Selecionando pacote previamente não selecionado mysql-server-5.0.
Desempacotando mysql-server-5.0 (de .../mysql-server-5.0_5.0.51a-24+lenny1_i386.deb) ...
Selecionando pacote previamente não selecionado mysql-server.
Desempacotando mysql-server (de .../mysql-server_5.0.51a-24+lenny1_all.deb) ...
Stopping MySQL database server: mysqld.
Processando gatilhos para man-db ...
Configurando mysql-client-5.0 (5.0.51a-24+lenny1) ...
Configurando mysql-server-5.0 (5.0.51a-24+lenny1) ...
Stopping MySQL database server: mysqld.
090530 21:52:40 [ERROR] /usr/sbin/mysqld: unknown option '--skip-federated'

Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: erro processando mysql-server-5.0 (--configure):
sub-processo post-installation script retornou estado de saída de erro 1
dpkg: problemas de dependência impedem a configuração de mysql-server:
mysql-server depende de mysql-server-5.0; porém:
Pacote mysql-server-5.0 não está configurado ainda.
dpkg: erro processando mysql-server (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
mysql-server-5.0
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
A instalação de um pacote falhou. Tentando recuperar:
Configurando mysql-server-5.0 (5.0.51a-24+lenny1) ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: erro processando mysql-server-5.0 (--configure):
sub-processo post-installation script retornou estado de saída de erro 1
dpkg: problemas de dependência impedem a configuração de mysql-server:
mysql-server depende de mysql-server-5.0; porém:
Pacote mysql-server-5.0 não está configurado ainda.
dpkg: erro processando mysql-server (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
mysql-server-5.0
mysql-server
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Escrevendo informações estendidas de estado... Pronto
Lendo descrições de tarefas... Pronto

nadsonpc:/home#


  


2. erro persiste

Nadson Cerqueira
nadsoncs

(usa Debian)

Enviado em 31/05/2009 - 14:39h

Olá amigo, tentei instalar o mysql-server manualmente, foi solicitado que instalasse o mysql-client primeiro.
Baixei e instalei via dpkg -i
http://packages.debian.org/lenny/i386/mysql-client-5.0/download
depois tentei instalar o mysql-server, também via dpkg com o link q vc passou
segue log abaixo.

nadsonpc:/home/nadson/Desktop# dpkg -i mysql-server-5.0_5.0.51a-24+lenny1_i386.deb
(Lendo banco de dados ... 143182 arquivos e diretórios atualmente instalados).
Preparando para substituir mysql-server-5.0 5.0.51a-24+lenny1 (usando mysql-server-5.0_5.0.51a-24+lenny1_i386.deb) ...
Stopping MySQL database server: mysqld.
Desempacotando substituto mysql-server-5.0 ...
Configurando mysql-server-5.0 (5.0.51a-24+lenny1) ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: erro processando mysql-server-5.0 (--install):
sub-processo post-installation script retornou estado de saída de erro 1
Processando gatilhos para man-db ...
Erros foram encontrados durante o processamento de:
mysql-server-5.0



3. Re: Instalação Debian Lenny ERRO

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 31/05/2009 - 15:24h

Olha, como o erro persiste, por que não atualizar o debian antes?
pode ser que vc tenha dependencias que são antigas, ou versões antigas depacotes, que o ultimo mysql não consegue usar.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts