Adobe flash-plugin / SElinux [RESOLVIDO]

1. Adobe flash-plugin / SElinux [RESOLVIDO]

Edson Harder
Harder

(usa Deepin)

Enviado em 07/10/2011 - 15:58h

Prezados Colegas,
Boa Tarde.

Fiz atualização p/ nova versão Adobe Flash Plugin 11.0.1.152

Nas versões anteriores não tive error ou bloqueio. SO fedora, firefox.

SElinux Alert Browser, tem (03) três mensagens de bloqueio ou error:

Plugin: allow_execmod
Voce Quer Que plugin de permitir-config tenha Acesso execmod não libflashplayer.so
fileSeVocê Quer Que plugin de permitir-config tenha Acesso execmod nenhum arquivo libflashplayer.so
Você precisa mudar o rótulo de '/ usr / lib / flash-plugin / libflashplayer.so'
# Semanage fcontext-a-t textrel_shlib_t '/ usr / lib / flash-plugin / libflashplayer.so'
# Restorecon-v "/ usr / lib / flash-plugin / libflashplayer.so


Você deve dizer sobre este SELinux, permitindo que o 'allow_execmod' boolean.
setsebool-P allow_execmod 1
SELinux está impedindo / usr / lib nspluginwrapper / / plugin-config de acesso execmod no ARQUIVO / usr / lib / flash-plugin / libflashplayer.so.


Plugin: catchall
Voce Quer Que plugin de permitir-config tenha Acesso execmod não libflashplayer.so
fileSeyou acreditam que o plugin-config deve ser permitido o acesso execmod sobre o arquivo libflashplayer.so por padrão.
Você deve relatar isso como um bug.
Você pode gerar um módulo de política local para permitir esse acesso.
Permitir esse acesso agora, executando:
# Grep plugin-config / var / log / audit / audit.log | audit2allow-M mypol
# Semodule-i mypol.p


Segue config da Administração do SElinux

Status
Modo reforçado padrão do sistema: reforçado
Modo reforçado atual: reforçado
Tipo de política padrão do sistema: targeted


Atenciosamente.
Harder.


  


2. Re: Adobe flash-plugin / SElinux [RESOLVIDO]

Diego Cabral
diegocabral484

(usa Arch Linux)

Enviado em 07/10/2011 - 20:47h

Aqui no fedora nunca deu esse problema,com o flash mais novo..


3. SELinux modo Enforcing

Edson Harder
Harder

(usa Deepin)

Enviado em 10/10/2011 - 15:44h

Prezados,

Fiz alterações no SELinux modo Enforcing ( regras aplicadas ) p/ a configuração "Permissivo" ( log das operações bloqueadas, usar o comando "dmesg" ).

O SELinux, ativar módulos e utilizar recursos específicos relacionados a servidores. Algo que eu não sei.

Pude resolver, e o que eu creio é que nas próximas versões do flash-pligun não haverá conflito, etc.


Att,
Harder.