yiso c893 no Ubuntu

1. yiso c893 no Ubuntu

Durvalino Cerqueira
durvalino

(usa Ubuntu)

Enviado em 10/09/2007 - 00:49h

Linux ubuntu-desktop 2.6.15-29-386 #1 PREEMPT Wed Aug 29 13:20:33 UTC 2007 i686 GNU/Linux

Caros,
Estou com problemas ao tentar conectar com o modem yiso c893 usado pela vivo segui o tutorial do site do fabricante 'Luxicom' mas ainda estou com problemas alguem pode me ajudar nesta questão, segue o erro ao tentar me conectar pelo kppp:
=================================================
[email protected]:~$ sudo kppp
X Error: BadDevice, invalid or uninitialized input device 171
Major opcode: 149
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 171
Major opcode: 149
Minor opcode: 3
Resource id: 0x0
Failed to open device
Link points to "/tmp/ksocket-root"
Link points to "/tmp/kde-root"
X Error: BadDevice, invalid or uninitialized input device 171
Major opcode: 149
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 171
Major opcode: 149
Minor opcode: 3
Resource id: 0x0
Failed to open device
Session management error: Authentication Rejected, reason : None of the authenti cation protocols specified are supported and host-based authentication failed
kbuildsycoca running...
ScimInputContextPlugin()
Opener: received OpenLock

Opener: received OpenDevice
Opener: received RemoveLock
X Error: BadDevice, invalid or uninitialized input device 171
Major opcode: 149
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 171
Major opcode: 149
Minor opcode: 3
Resource id: 0x0
Failed to open device
Session management error: Authentication Rejected, reason : None of the authenti cation protocols specified are supported and host-based authentication failed
Opener: received SetSecret
Opener: received SetSecret
Opener: received OpenLock

Opener: received OpenDevice
Falha de segmentação
[email protected]:~$ ICE default IO error handler doing an exit(), pid = 5958, errno = 0



  


2. Re: yiso c893 no Ubuntu

Francisco Ambrozio
fco

(usa Slackware)

Enviado em 10/09/2007 - 00:56h

Você está usando o Ubuntu (i.e., ambiente desktop Gnome)? - se sim, instale o GnomePPP.

O problema é com o modem ou com o KPPP?


3. Tente isto...

Alexandre Trindade
radamento

(usa Kurumin)

Enviado em 12/09/2007 - 19:07h

Eu uso o Kurumin 7 com KDE.
Para usar o VivoZap faça o seguinte:
1)Na pasta /etc/ppp/peers, crie um arquivo chamado "1xevdo", e coloque o seguinte dentro dele:

ttyUSB0
modem
debug
noauth
defaultroute
usepeerdns
user [NUMPLACA]@vivozap.com.br
password [SENHA]
crtscts
lock
connect '/usr/sbin/chat -v -t15 -f /etc/ppp/peers/1xevdo_chat

2) Ainda na pasta /etc/ppp/peers, crie um arquivo chamado "1xevdo_chat", e coloque o seguinte dentro dele:

'' 'AT'
'OK' 'ATDT#777'
'CONNECT' ''

3) Na área de trabalho, clique com o botão direito do mouse e escolha "Link para Aplicativo", e na aba "Aplicativo" coloque:
Descrição: Acesso a C893
Comentário: Acesso a Internet
Comando: sudo rmmod usbserial; sudo insmod /lib/modules/'uname -r'/kernel/drivers/usb/serial/usbserial.ko vendor=0x0eab product=0xc893; sudo cd /etc/rc.d; sudo mkdir /dev/usb; sudo cd; sudo ln -s /dev/ttyUSB0 /dev/usb/ttyUSB0; sudo ln -s /dev/ttyUSB1 /dev/usb/ttyUSB1; sudo pppd call 1xevdo

Obs.: onde está 'uname -r', coloque qual o seu kernel (para saber, digite 'uname -r' no prompt)

Clique em "OK"

Pronto! Agora conecte a placa, e clique no atalho que você criou para ativar a placa.
O único inconveniente é que se por qualquer motivo desconectar, você deve reiniciar o micro para acessar novamente a placa...
Espero ter ajudado,
Alexandre





4. Faço assim

Bruno Araujo
bjaraujo

(usa Ubuntu)

Enviado em 12/09/2007 - 21:33h

Uso Ubuntu Feisty.

Eis alguns problemas que enfrentei: o modem pára de responder (ppp0 de pé mas não acessa Internet), simplesmente desconecta (é recessário desconectar e reconectar o plug usb ou reiniciar o pc). A solução é usada para o modem usb, pode ser útil também à pcmcia, e segue. Pode servir para vc também radamento.


Coloque três arquivos em algum lugar. Eu criei e pus em /etc/scripts os arquivos conectar, reparar e monitor_net
conectar: faz juz ao nome
reparar: usado por monitor se a net não estiver acessível serve para o que nome diz
monitor_net: ídem a conectar, verifica se a net está ativa

Crie os aquivos como root, dê permissão de execução. Você também deve por o conectar para executar na inicialização do sistema. Não lembro agora como mas você pode pedir ajuda aos colegas.

E por favor responda se solucionou o seu problema. Se você aperfeiçoou de alguma maneira envie para aqui. Grato.


Segue os aquivo:


: conectar

#! /bin/bash
# script criado por Bruno Araújo
# conectar-se automaticamente à VIVO.

echo 'Iniciando a conexão com a Internet'

# ativa o modem
insmod /lib/modules/`uname -r`/kernel/drivers/usb/serial/usbserial.ko vendor=0x0eab product=0xc893

# conecta
sleep 1

# "rede" é o nome do perfil criado com o "pppconfig"
pppd call rede &

sleep 3

# define a rota padrão para a internet
route del default
route add default ppp0

echo 'Ativando monitor'

/etc/scripts/./monitor_net &


: monitor_net
#! /bin/bash

# se quiser remova os 'echo'

while ! [ ]
do
echo 'Testando interface ppp0'
if ! ifconfig | grep ppp0 > /dev/null ; then
{ # comandos que devem ser executados caso haja erro de conexao

echo 'Reparando a conexão'
/etc/scripts/./reparar


}
fi
echo 'Testando interface ppp0 - finalizado'

echo 'Testando acesso à Internet pela uol'
if ! ping -c 4 www.uol.com.br &> /dev/null ; then
{
echo 'Testando acesso à Internet pelo Google'
if ! ping -c 4 www.google.com.br &> /dev/null ; then
{
echo 'Reparando a conexão'
/etc/scripts/./reparar
}
else {
echo 'Tá tudo redondinho!'
}
fi
}
else
echo 'Tá tudo redondinho!'
fi
echo 'Testando acesso à Internet - finalizado'


sleep 2m

done

: reparar

#! /bin/bash

echo 'Desativando dispositivos usb'

modprobe -r ehci_hcd
modprobe -r uhci_hcd
rmmod usbserial
sleep 3

echo 'Ativando dispositivos usb novamente'

modprobe uhci_hcd
modprobe ehci_hcd

insmod /lib/modules/`uname -r`/kernel/drivers/usb/serial/usbserial.ko vendor=0x0eab product=0xc893

sleep 7
echo 'Conectanto à internet...'
pppd call rede &





5. Yiso C893 no Debian Etch

Fábio Alves de Souza
souzasouz

(usa Debian)

Enviado em 03/10/2007 - 20:35h

Senhores, também tenho o mesmo problema, porém no Debian Etch. Fiz conforme instruções da Luxicom: insmod /lib/modules/'uname -r'/kernel/drivers/usb/serial/usbserial.ko vendor=0x0eab product=0xc893; sudo cd /etc/rc.d; sudo mkdir /dev/usb; sudo cd; sudo ln -s /dev/ttyUSB0 /dev/usb/ttyUSB0; sudo ln -s /dev/ttyUSB1 /dev/usb/ttyUSB1. Porém, no Debian Etch não existe a pasta /etc/rc.d (tem rc0.d, rc1.d...). O que posso fazer para configurar o modem?


6. Modem Yiso c893 / S893v

Durvalino Cerqueira
durvalino

(usa Ubuntu)

Enviado em 05/10/2007 - 14:44h

Souza e demais colegas,
Eu consegui resolver o problema de configuração do Modem c893 / S893v da Luxicom, no meu caso, talvez sirva de ajuda para alguém, o problema era simplesmente o fato de que o meu modem PCI estava espetado, ainda, na placa mãe e causando conflito com o novo Modem foi só eu retirar o modem PCI da placa mãe que o problema se resoveu, falando agora parece até que foi fácil mais apanhei bastante antes de descobrir este detalhe, que só amadores como eu não se ligam em observar.
até...


7. Yiso C893 no Debian Etch

Fábio Alves de Souza
souzasouz

(usa Debian)

Enviado em 05/10/2007 - 21:25h

Preciso da ajuda de vocês para resolver este problema, pois fiz conforme as instruções abaixo:
insmod /lib/modules/'uname -r'/kernel/drivers/usb/serial/usbserial.ko vendor=0x0eab product=0xc893. Com isso, pude listar /dev/ttyUSB0 e /dev/ttyUSB1, através de: ls /dev/ttyUSB* e o LED do modem pisca. Aparentemente configurei certo o Gppp, porém a mensagem de modem não conectado sempre volta. Agora o que faço???


8. C893 no vivozap Fedora 8

Joase Menezes
jmenenzes5

(usa Fedora)

Enviado em 19/12/2007 - 08:47h

Bom dia

Tenho a placa do VivoZAP C893 instalada e funcinando perfeitamente no Fedora 6, ontem consegui fazer e estou usando agora no Fedora 8, o procedimento que permite funcionar é o seguinte:

como root vá:
1)diretório /etc/ppp/peers e usando um editor copie o arquivo abaixo e salve, eu salvai como vivozap

ttyUSB0 460800 crtscts
noauth
defaultroute
usepeerdns
local
ipcp-accept-local
ipcp-accept-remote
lcp-echo-failure 0
lcp-echo-interval 0
login
user [email protected] # mude para seu numero da vivo
password vivo
multilink
novj
novjccomp
noccp
persist
passive
connect '/usr/sbin/chat -v -f /etc/ppp/chat-vivozap'

2) ainda como root após salvar o anterior crie um novo arquivo ou copie e cole no editor de arquivo o que segue:

BORT "NO CARRIER"
ABORT "NO DIALTONE"
ABORT "ERROR"
ABORT "NO ANSWER"
ABORT "BUSY"
ABORT "Username/Password Incorrect"
SAY "VIVO Zap inicializando...\n"
"" "ATZ"
OK "AT&C0+CRM=1"
OK "ATDT#777"

e salve como chat_vivozap

3) execute como root no terminal:

pppd call vivozap &

4) acione kppp e clique em conectar.

5) feche a tela do terminal.

Acredito que funcione em qualquer Linux. Falta apenas fazer que o funcionamento no Fedora 8 seja automático como era no Fedora 6, não havia necessidade de primeiro chamar o vivozap o próprio kppp realizava a operação mas no momento se faço isso a máquina trava e chamando antes no terminal funciona.

Boa sorte
Luciano Menezes

PS: a configuração do kppp é a mesma do manual da YISo em www.luxicom.com.br/c893/manual_linux.pdf


9. Re: yiso c893 no Ubuntu

F Kneipp
knei00

(usa Outra)

Enviado em 03/01/2008 - 21:54h

Olá pessoal, tenho o mesmo problema. Sou novo no linux e não consegui acompanhar todos os passos. Consegui instalar o gnome-ppp mas aparentemente o modem deu errado. Uso ubuntu 7.10 com gnome. Segue o erro que aparece:

/home/fabricio/.wvdial.conf<Warn>: Ignoring malformed input line: ";Do NOT edit this file by hand!"
WvDial<*1>: WvDial: Internet dialer version 1.56
WvModem<*1>: Cannot set information for serial port.
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial<*1>: Sending: ATQ0
WvDial<*1>: Re-Sending: ATZ
WvDial<Err>: Modem not responding.


10. Re: yiso c893 no Ubuntu

F Kneipp
knei00

(usa Outra)

Enviado em 07/01/2008 - 22:21h

Esse link resolveu o meu problema:
http://mult.isx.com.br/2006/11/16/vivo-zap-no-linux/

Passos adicionais:
http://ubuntuforum-br.org/index.php/topic,30014.0.html


11. yiso s893v

André Padotzke
paratykiko

(usa Ubuntu)

Enviado em 22/01/2008 - 18:24h

Sou estreante em linux por isso não sei onde digitar esses comandos todos para ativar o s893v no linux one mandriva 2008,está instalado a pouco atraves de imagen iso descarregada do site.Tentei instalar com driver da vivo para xp+ndiswrapper em conexão wireless mas não funcionou.