Hotspot, Session Timeout juntamente com Limit Uptime [RESOLVIDO]

1. Hotspot, Session Timeout juntamente com Limit Uptime [RESOLVIDO]

Guilherme Moura de Souza
Sir.Guil

(usa CentOS)

Enviado em 22/03/2016 - 12:57h

Boa tarde, utilizo o mikrotik RouterOS 5.26 dentro da empresa onde trabalho (não somos provedores de internet).
E estou tendo dificuldades em implementar o Limit uptime junto com o Session Timeout que funcionava anteriormente.
Como fazer os 2 agirem sobre a mesma conta?
deixo abaixo o exemplo da configuração
/ip hotspot user
name="guilherme" password="****" profile=Escritorio limit-uptime=1d1h uptime=13m25s bytes-in=3299095 bytes-out=17320716 packets-in=21338 packets-out=19737

/ip hotspot user profile
name="Escritorio" session-timeout=1h idle-timeout=none keepalive-timeout=2m status-autorefresh=1m shared-users=1 rate-limit="154K/512K 615K/2M 308K/1M 64/64 8 62K/205K" transparent-proxy=no


Obrigado pela atenção


  


2. Re: Hotspot, Session Timeout juntamente com Limit Uptime [RESOLVIDO]

Guilherme Moura de Souza
Sir.Guil

(usa CentOS)

Enviado em 30/03/2016 - 18:32h

não é possível implementar os dois controles juntos, quando descobri isso fiz o seguinte ("não vou ficar de muita explicação, leia e tire suas conclusões")

/ip hotspot user
name="guilherme" password="****" profile=Escritorio limit-uptime=1d1h uptime=17h18m57s bytes-in=49322552 bytes-out=221357462 packets-in=211603 packets-out=254030

/ip hotspot user profile
name="Escritorio" idle-timeout=none keepalive-timeout=2m status-autorefresh=1m shared-users=1 rate-limit="154k/512k 615k/2M 308k/1M 64/64 8 62k/205k" transparent-proxy=no

/system script
name="Controle_session_timeout_hotspot" owner="guilherme" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api last-started=mar/30/2016 18:20:00 run-count=398 source=
:foreach i in=[/ip hotspot active find] do={:if ([/ip hotspot active get $i uptime]>02:00:00) do={[/ip hotspot active remove $i]}}
:foreach i in=[/ip hotspot active find] do={:if ([/ip hotspot active get $i uptime]>01:00:00) do={:if ([/ip hotspot active get $i idle-time]>00:01:00) do={[/ip hotspot active remove $i]}}}

/system scheduler
name="Controle_session_timeout_hotspot" start-date=mar/28/2016 start-time=00:00:00 interval=10m on-event=Controle_session_timeout_hotspot owner="guilherme" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api run-count=398 next-run=18:30:00


essa foi a solução do problema, esta testada e funcionando, adequem a suas necessidades.
ate a próxima.