problemas em habilitar o modo de rede

1. problemas em habilitar o modo de rede

milena mendes jesus
milenamj

(usa Debian)

Enviado em 29/04/2015 - 22:30h

Eu não consigo habilitar o modo rede bridge na virtual box, já baixei drivers da própria VM, mas ainda assim não consigo.
A configuração do meu computador é boa é um i7 com 6gb de memória.
Se alguém souber como solucionar esse problema...

agradeço desde já


  


2. Re: problemas em habilitar o modo de rede

Wagner Souza
wagnerfs

(usa Fedora)

Enviado em 29/04/2015 - 23:24h

Já instalou os recursos adicionais do virtualbox? http://download.virtualbox.org/virtualbox/4.3.26/Oracle_VM_VirtualBox_Extension_Pack-4.3.26-98988.vb...

Quantas placas de rede você tem configurado na sua máquina? É apresentada alguma mensagem de erro? A instalação foi feita via ppa do próprio virtualbox ou arquivo baixado do site?

Tente atualizar o seu sistema. Em alguns casos resolve por conta de alterações no kernel.

_________________________
Wagner F. de Souza
Graduado em Redes de Computadores
"GNU/Linux for human beings."
LPI ID: LPI000297782



3. Re: problemas em habilitar o modo de rede

Gildásio Júnior
gjuniioor

(usa Arch Linux)

Enviado em 30/04/2015 - 01:38h

Qual o sistema host do VirtualBox??

O VirtualBox depende do pacote net-tools para rodar bridge. Caso seu sistema não tenha o ifconfig mas sim o ip (que é uma atualização), você deve instalar esse pacote.

Também deve rodar os seguinte módulos, caso não tenha funcionado logo após instalar:

# modprobe vboxnetadp
# modprobe vboxnetflt


"A ignorância não se dá apenas pela falta de conhecimento, mas também pelo desgosto em obtê-lo" - @gjuniioor


4. Re: problemas em habilitar o modo de rede

milena mendes jesus
milenamj

(usa Debian)

Enviado em 30/04/2015 - 01:58h


Oii,
Então eu reinstalei a VirtualBox, instalei essa extensão e nada...
Eu tenho configurada duas placas de rede, a Wireless e a para rede cabeada ou Ethernet, aparece uma mensagem de erro com as seguintes frases:"NtCreatefile(\Device\VBoxDrvStub) failed 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries) ", a instalação foi feita via ppa do próprio VirtualBox;

(seria legal se eu conseguisse anexar a foto com o erro...)




5. Re: problemas em habilitar o modo de rede

Gildásio Júnior
gjuniioor

(usa Arch Linux)

Enviado em 30/04/2015 - 02:11h

milenamj escreveu:

Oii,
Então eu reinstalei a VirtualBox, instalei essa extensão e nada...
Eu tenho configurada duas placas de rede, a Wireless e a para rede cabeada ou Ethernet, aparece uma mensagem de erro com as seguintes frases:"NtCreatefile(\Device\VBoxDrvStub) failed 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries) ", a instalação foi feita via ppa do próprio VirtualBox;

(seria legal se eu conseguisse anexar a foto com o erro...)



Milena, você seguiu minha resposta acima?

Pois bem, vejamos...

Qual o kernel de sua máquina? Provavelmente, comum, não LTS, então, instale o pacote virtualbox-host-modules. Depois disso, rode o módulo:

# modprobe vboxdrv 


E teste novamente...

Faça os passos dessa resposta e da minha anterior e veja se resolve.

"A ignorância não se dá apenas pela falta de conhecimento, mas também pelo desgosto em obtê-lo" - @gjuniioor