Problema de Rede no Virtual BOX

1. Problema de Rede no Virtual BOX

Guilherme Carvalho
Gui Carvalho

(usa Debian)

Enviado em 10/04/2014 - 13:16h

Prezados,

Possuo duas VMs, uma com o Debian 7 e outra com o CentOS 6.5. Ambas estão com o 1º adaptador de rede configurado como NAT e o 2º como Rede Interna (intnet).

Ao configurar ip na interface de Rede Interna (no meu caso a eth1) através do ifconfig, o IP chega a ser atribuído e por alguns segundos estabelece a comunicação entre as duas VMs (o ping não apresenta perdas de pacote).

Porém, após cerca de um minuto, a interface perde o IP que setei com o ifconfig, voltando a ficar zerada. Tanto no CentOS quando no Debian.

Será que há alguma configuração no VirtualBOX que está desativando essas interfaces virtuais após um período de inatividade?



  


2. Re: Problema de Rede no Virtual BOX

Marcio
ZeroTrinta1

(usa Red Hat)

Enviado em 10/04/2014 - 13:59h

A quanto tempo instalou o Vbox ?
Já reiniciou a maquina ?
#iptables -n -L -v
$sestatus


3. Re: Problema de Rede no Virtual BOX

Guilherme Carvalho
Gui Carvalho

(usa Debian)

Enviado em 10/04/2014 - 14:32h

Instalei há cerca de um mês, é a penultima versão do VBOX.

Já reiniciei também, validei as configurações do adaptador no Virtual Box, mas sem sucesso. Ele configura o IP, mas depois de alguns segundos perde a configuração.

A noite posto qual a versão correta e a saída do comando... Valeu!


4. Re: Problema de Rede no Virtual BOX

Guilherme Carvalho
gui carvalho

(usa Debian)

Enviado em 10/04/2014 - 19:45h

Versão do VirtualBox: 4.3.8


Retorno do Comando iptables:

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination


Filtro por "eth1" no arquivo messages:

Apr 9 18:18:52 debian kernel: [ 1.735763] e1000 0000:00:08.0: eth1: (PCI:33MHz:32-bit) 08:00:27:66:d9:1b
Apr 9 18:18:52 debian kernel: [ 1.735769] e1000 0000:00:08.0: eth1: Intel(R) PRO/1000 Network Connection
Apr 9 18:18:56 debian kernel: [ 21.179514] e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Apr 9 18:18:56 debian kernel: [ 21.182596] ADDRCONF(NETDEV_UP): eth1: link is not ready
Apr 9 18:18:56 debian kernel: [ 21.182596] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Apr 9 21:22:00 debian kernel: [ 1.855461] e1000 0000:00:08.0: eth1: (PCI:33MHz:32-bit) 08:00:27:66:d9:1b
Apr 9 21:22:00 debian kernel: [ 1.855467] e1000 0000:00:08.0: eth1: Intel(R) PRO/1000 Network Connection
Apr 9 21:22:09 debian kernel: [ 54.218762] ADDRCONF(NETDEV_UP): eth1: link is not ready
Apr 9 21:22:09 debian kernel: [ 54.221051] e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Apr 9 21:22:09 debian kernel: [ 54.221595] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Apr 9 21:48:19 debian kernel: [ 1.737028] e1000 0000:00:08.0: eth1: (PCI:33MHz:32-bit) 08:00:27:66:d9:1b
Apr 9 21:48:19 debian kernel: [ 1.737035] e1000 0000:00:08.0: eth1: Intel(R) PRO/1000 Network Connection
Apr 9 21:48:21 debian kernel: [ 19.241632] e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Apr 9 22:25:33 debian kernel: [ 1.820140] e1000 0000:00:08.0: eth1: (PCI:33MHz:32-bit) 08:00:27:66:d9:1b
Apr 9 22:25:33 debian kernel: [ 1.820145] e1000 0000:00:08.0: eth1: Intel(R) PRO/1000 Network Connection
Apr 9 22:28:01 debian kernel: [ 1.747490] e1000 0000:00:08.0: eth1: (PCI:33MHz:32-bit) 08:00:27:66:d9:1b
Apr 9 22:28:01 debian kernel: [ 1.747506] e1000 0000:00:08.0: eth1: Intel(R) PRO/1000 Network Connection
Apr 9 22:28:04 debian kernel: [ 18.904233] ADDRCONF(NETDEV_UP): eth1: link is not ready
Apr 9 22:28:04 debian kernel: [ 18.907079] e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Apr 9 22:28:04 debian kernel: [ 18.907906] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Apr 10 19:03:04 debian kernel: [ 1.689936] e1000 0000:00:08.0: eth1: (PCI:33MHz:32-bit) 08:00:27:66:d9:1b
Apr 10 19:03:04 debian kernel: [ 1.689941] e1000 0000:00:08.0: eth1: Intel(R) PRO/1000 Network Connection
Apr 10 19:03:07 debian kernel: [ 21.957518] e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Apr 10 19:03:07 debian kernel: [ 21.958967] ADDRCONF(NETDEV_UP): eth1: link is not ready
Apr 10 19:03:07 debian kernel: [ 21.959044] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready


5. Re: Problema de Rede no Virtual BOX

Marcio
ZeroTrinta1

(usa Red Hat)

Enviado em 10/04/2014 - 20:08h

Caramba man, a interface está com problemas , tente configurar uma nova interface para ver se realmente funciona:
#ifconfig eth0 down; ifconfig eth0:2 10.1.1.10 netmask 255.255.240
E coloque as configurações no Virtual box para usar a nova interface


6. Re: Problema de Rede no Virtual BOX

Guilherme Carvalho
gui carvalho

(usa Debian)

Enviado em 11/04/2014 - 22:12h

Setei as configurações de Rede direto no arquivo /etc/network/interface e o não tive mais o problema.

Porém a dúvida do porque não fixava o IP pelo ifconfig (só "segurava" por uns 5 minutos no máximo) permanece =Z

Obrigado pelo auxilio aee


7. Re: Problema de Rede no Virtual BOX

Marcio
ZeroTrinta1

(usa Red Hat)

Enviado em 03/06/2014 - 08:00h

Marquei resolvido !?