Pacman do MANJARO sempre FALHA ao instalar ou atualizar

1. Pacman do MANJARO sempre FALHA ao instalar ou atualizar

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/11/2017 - 10:24h

Sempre que vou atualizar o sistema ou instalar grandes pacotes, faz-se várias perguntas sobre conflitos e sempre respondo com a resposta sugerida/padrão(1), mas sempre no fim diz-se algo como:
erro: falhou ao submeter a transação (erro inesperado)
Ocorreram alguns erros, portanto, nenhum pacote foi actualizado.

Alguém sabe como resolver isto, por favor? Que ando a proceder mal?

Penso que não é o repositório, pois já o arranjei no site do Arch Linux com o gerador de Mirrorlist. E não houve problemas na sincronização.

Cptos a todos.


  


2. Re: Pacman do MANJARO sempre FALHA ao instalar ou atualizar

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/11/2017 - 10:33h

Tenta postar a saida do: pacman -S (qualquer pacote), depois: cat /var/log/pacman.log.
Assim saberemos que aplicações estam quebrando seu sistema.


Meu github:
#===============================#
# https://github.com/Python-Library-Work #
#===============================#
O universo e um infinito de possibilidades!!!



3. Re: Pacman do MANJARO sempre FALHA ao instalar ou atualizar

Perfil removido
removido

(usa Nenhuma)

Enviado em 10/11/2017 - 11:05h

AndrewUser escreveu:

Tenta postar a saida do: pacman -S (qualquer pacote), depois: cat /var/log/pacman.log.
Assim saberemos que aplicações estam quebrando seu sistema.


Olá, Andrew.
Executei o seguinte comando: pacman -Syyu para sincronizar e atualizar:
=======================================================================================
:: A iniciar a actualização do sistema...
atenção: filesystem: local (2017.06-4.3) é mais recente que core (2017.03-2)
atenção: gtk-engine-murrine: local (0.98.2-2.2) é mais recente que community (0.98.2-2)
atenção: gtk-xfce-engine: local (2.10.1-1.1) é mais recente que extra (2.10.1-1)
atenção: qpdfview: local (0.4.17beta1-4.1) é mais recente que community (0.4.17beta1-4)
:: Substituir rfkill por core/util-linux? [S/n]


Resolvi dizer Sim, pois antes havia dito não e o pacman encerrou a atualização, mas mesmo assim no fim deu nisto:

(102/102) a verificar chaves no chaveiro...
(102/102) a verificar integridade dos pacotes...
(102/102) a carregar ficheiros dos pacotes...
(102/102) a verificar conflitos em ficheiros...
erro: falhou ao submeter a transação (ficheiros em conflito)...
firefox: /usr/lib/firefox/distribution/distribution.ini existe no sistema de ficheiros...
lsb-release: /etc/lsb-release existe no sistema de ficheiros...
lsb-release: /etc/lsb-release existe no sistema de ficheiros
Ocorreram alguns erros, portanto, nenhum pacote foi actualizado.

=======================================================================================

Também olhei o pacman.log como recomendado, mas só havia isto:

[2017-11-10 12:48] [PACMAN] Running 'pacman -Syyu'
[2017-11-10 12:48] [PACMAN] synchronizing package lists
[2017-11-10 12:48] [PACMAN] starting full system upgrade


Cê teria alguma ideia do que seja?

Cptos




"...sede inofensivos como os pombos, mas perspicazes como as serpentes". Mateus 10:16.


4. Re: Pacman do MANJARO sempre FALHA ao instalar ou atualizar

carlos reis
slblxs

(usa Funtoo)

Enviado em 10/11/2017 - 12:51h

webcoders.pt escreveu:

AndrewUser escreveu:

Tenta postar a saida do: pacman -S (qualquer pacote), depois: cat /var/log/pacman.log.
Assim saberemos que aplicações estam quebrando seu sistema.


Olá, Andrew.
Executei o seguinte comando: pacman -Syyu para sincronizar e atualizar:
=======================================================================================
:: A iniciar a actualização do sistema...
atenção: filesystem: local (2017.06-4.3) é mais recente que core (2017.03-2)
atenção: gtk-engine-murrine: local (0.98.2-2.2) é mais recente que community (0.98.2-2)
atenção: gtk-xfce-engine: local (2.10.1-1.1) é mais recente que extra (2.10.1-1)
atenção: qpdfview: local (0.4.17beta1-4.1) é mais recente que community (0.4.17beta1-4)
:: Substituir rfkill por core/util-linux? [S/n]


Resolvi dizer Sim, pois antes havia dito não e o pacman encerrou a atualização, mas mesmo assim no fim deu nisto:

(102/102) a verificar chaves no chaveiro...
(102/102) a verificar integridade dos pacotes...
(102/102) a carregar ficheiros dos pacotes...
(102/102) a verificar conflitos em ficheiros...
erro: falhou ao submeter a transação (ficheiros em conflito)...
firefox: /usr/lib/firefox/distribution/distribution.ini existe no sistema de ficheiros...
lsb-release: /etc/lsb-release existe no sistema de ficheiros...
lsb-release: /etc/lsb-release existe no sistema de ficheiros
Ocorreram alguns erros, portanto, nenhum pacote foi actualizado.

=======================================================================================

Também olhei o pacman.log como recomendado, mas só havia isto:

[2017-11-10 12:48] [PACMAN] Running 'pacman -Syyu'
[2017-11-10 12:48] [PACMAN] synchronizing package lists
[2017-11-10 12:48] [PACMAN] starting full system upgrade


Cê teria alguma ideia do que seja?

Cptos




"...sede inofensivos como os pombos, mas perspicazes como as serpentes". Mateus 10:16.



Tenta seguir os passos que vou deixar em baixo, a ver se resulta:


- sudo pacman-mirrors -g && sudo pacman -Syy
ou
- sudo pacman-mirrors -f10 && sudo pacman -Syy


O segundo comando, é para escolher os 10 repositórios mais rápidos e mais perto.


5. Re: Pacman do MANJARO sempre FALHA ao instalar ou atualizar

Perfil removido
removido

(usa Nenhuma)

Enviado em 10/11/2017 - 13:48h

Olá, faça esses comandos:

pacman-mirrors -g
pacman -Sy
pacman -Syu
yaourt -Syu


Parece que você usa o manjaro, mais os repositorios do arch linux não são compativeis. Use o do manjaro. Isso causa um problema de dependencias, uma vez que tem grupos diferentes de distro a distro.



Meu github:
#===============================#
# https://github.com/Python-Library-Work #
#===============================#
O universo e um infinito de possibilidades!!!



6. Re: Pacman do MANJARO sempre FALHA ao instalar ou atualizar

Perfil removido
removido

(usa Nenhuma)

Enviado em 14/11/2017 - 22:43h

Senhores, muitíssimo obrigado pela ajuda, mas desinstalei o Manjaro e instalei o Parrot OS. Continuo com um Quad Boot mas sem o Manjaro, infelizmente. Porém anotei as vossas dicas para se calhar numa próxima oportunidade com o Manjaro, pois tenho um ficheiro chamado HOWTO que é onde guardo todas as soluções dos problemas com os quais me defrontei.
Obrigado a todos.

"...sede inofensivos como os pombos, mas perspicazes como as serpentes". Mateus 10:16.