Manjaro Linux com problema com placas hibridas(NVIDIA-INTEL)

1. Manjaro Linux com problema com placas hibridas(NVIDIA-INTEL)

Gabriel
GaelSilraza

(usa Manjaro Linux)

Enviado em 04/12/2021 - 13:38h

Boa tarde, pessoa.
Gostaria de solicitar uma ajuda com uma situação um pouco chata que está acontecendo comigo, onde ao tentar iniciar algum programa utilizando a placa de video da NVIDIA o programa simplesmente crasha e aparece uma imagem do xorg que está um monte de caracteres estranhos. Porém, se inicio o mesmo programa usando a placa de video integrada(INTEL) o problema não acontece. Ademais, ao tentar realizar a reinstalação do drive eu recebo a seguinte mensagem de erro que se encontra no print abaixo.
____________________________________
Além disso, ao tentar reinstalar o drive (já testei o prime, 470xx-prime e bumblebee) em uma certa parte acontece um erro referente a um pacote que não é encontrado:


Waiting for user input...
Starting
> Installing video-hybrid-intel-nvidia-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
core downloading...
extra downloading...
community downloading...
multilib downloading...
error: target not found: linux516-nvidia
Error: pacman failed!
Error: script failed!


Feito ...
____________________________________
E quando tentamos a instalação por meio do pacman:
sudo pacman -Syu linux516-nvidia  1 ✘  4m 36s 
[sudo] senha para gabriel:
:: Sincronizando a base de dados de pacotes...
core está atualizado
extra está atualizado
community está atualizado
multilib está atualizado
erro: alvo não encontrado: linux516-nvidia
   ~ 
____________________________________

Segue uma imagem abaixo ao procurar sobre ele no pamac

____________________________________

Ao tentar baixar o unico pacote de nome semelhante:

Preparando...
Sincronizando banco de dados de pacotes...
Aviso: linux515-headers-5.15.2-2 está atualizado -- reinstalando
Resolvendo dependências...
Verificando conflito entre pacotes...
Aviso: dependência cíclica detectada:
Aviso: eglexternalplatform será instalado antes de sua dependência nvidia-470xx-utils
Download de linux515 (5.15.2-2) começou
Download de linux515-nvidia-470xx (470.86-3) começou
Download de linux515-nvidia-470xx (470.86-3) terminou
Download de linux515-rt-headers (5.15.2_rt19-1) começou
Download de linux515-rt-headers (5.15.2_rt19-1) terminou
Download de linux515-rt (5.15.2_rt19-1) começou
Download de linux515 (5.15.2-2) terminou
Download de linux515-headers (5.15.2-2) começou
Download de linux515-headers (5.15.2-2) terminou
Download de linux515-rt (5.15.2_rt19-1) terminou
Verificando chaveiro...
Verificando a integridade dos pacotes...
Carregando arquivos de pacotes...
Verificando conflito entre arquivos...
Falha ao confirmar transação:
arquivos conflitantes:
- /usr/lib/modules/extramodules-5.15-MANJARO/nvidia-drm.ko.gz existe tanto em linux516-nvidia-470xx como em linux515-nvidia-470xx
- /usr/lib/modules/extramodules-5.15-MANJARO/nvidia-modeset.ko.gz existe tanto em linux516-nvidia-470xx como em linux515-nvidia-470xx
- /usr/lib/modules/extramodules-5.15-MANJARO/nvidia-uvm.ko.gz existe tanto em linux516-nvidia-470xx como em linux515-nvidia-470xx
- /usr/lib/modules/extramodules-5.15-MANJARO/nvidia.ko.gz existe tanto em linux516-nvidia-470xx como em linux515-nvidia-470xx
____________________________________

Logo em seguinda sobe uma pop up:
arquivos conflitantes:
- /usr/lib/modules/extramodules-5.15-MANJARO/nvidia-drm.ko.gz existe tanto em linux516-nvidia-470xx como em linux515-nvidia-470xx
- /usr/lib/modules/extramodules-5.15-MANJARO/nvidia-modeset.ko.gz existe tanto em linux516-nvidia-470xx como em linux515-nvidia-470xx
- /usr/lib/modules/extramodules-5.15-MANJARO/nvidia-uvm.ko.gz existe tanto em linux516-nvidia-470xx como em linux515-nvidia-470xx
- /usr/lib/modules/extramodules-5.15-MANJARO/nvidia.ko.gz existe tanto em linux516-nvidia-470xx como em linux515-nvidia-470xx

____________________________________
Sobretudo, a localização informada que está conflitante aparentemente não existe...
cd /usr/lib/modules/  1 ✘  4s 
   /usr/lib/modules  .ls  ✔
zsh: correct '.ls' to 'ls' [nyae]? n
zsh: command not found: .ls
   /usr/lib/modules  ls  127 ✘
5.10.73-1-rt54-MANJARO 5.13.19-2-MANJARO 5.16.0-1-MANJARO extramodules-5.10-rt-MANJARO
5.10.79-1-MANJARO 5.14.18-1-MANJARO extramodules-5.10-MANJARO extramodules-5.16-MANJARO
   /usr/lib/modules 
____________________________________
Sistema operacional: Manjaro Linux
Versão do KDE Plasma: 5.23.3
Versão do KDE Frameworks: 5.88.0
Versão da Qt: 5.15.2
Versão do kernel: 5.16.0-1-MANJARO (64-bit)
Plataforma de gráficos: X11
Processadores: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memória: 19,3 GiB de RAM
Processador gráfico: Mesa Intel® UHD Graphics 620






  






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts