Erro ao tentar atualizar Manjaro KDE

1. Erro ao tentar atualizar Manjaro KDE

Thiago Ferreira de Sousa
thiago.fsousa

(usa Ubuntu)

Enviado em 26/03/2017 - 19:26h

Acabei de instalar o Manjaro 64 bits versão KDE
Porém quando vou tentar atualizar o SO ocorre o seguinte erro:

:: Continuar a instalação? [S/n] s
(269/269) verificando chaves no chaveiro [############################################################] 100%
(269/269) verificando integridade do pacote [############################################################] 100%
(269/269) carregando arquivos do pacote [############################################################] 100%
(269/269) verificando conflitos de arquivo [############################################################] 100%
erro: falha em submeter a transação (arquivos conflitantes)
libglvnd: /usr/lib/libEGL.so existe no sistema de arquivos
libglvnd: /usr/lib/libEGL.so.1 existe no sistema de arquivos
libglvnd: /usr/lib/libEGL.so.1.0.0 existe no sistema de arquivos
libglvnd: /usr/lib/libGL.so existe no sistema de arquivos
libglvnd: /usr/lib/libGL.so.1 existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv1_CM.so existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv1_CM.so.1 existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv2.so existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv2.so.2 existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv2.so.2.0.0 existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libEGL.so existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libEGL.so.1 existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libEGL.so.1.0.0 existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libGL.so existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libGL.so.1 existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libGLESv1_CM.so existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libGLESv1_CM.so.1 existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libGLESv2.so existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libGLESv2.so.2 existe no sistema de arquivos
lib32-libglvnd: /usr/lib32/libGLESv2.so.2.0.0 existe no sistema de arquivos
lsb-release: /etc/lsb-release existe no sistema de arquivos
Ocorreram erros e, portanto, nenhum pacote foi atualizado.

Pressione qualquer tecla para continuar...


Alguém poderia me ajudar ?


  


2. Re: Erro ao tentar atualizar Manjaro KDE

Izaias
izaias

(usa Manjaro Linux)

Enviado em 26/03/2017 - 20:18h

thiago.fsousa escreveu:

Acabei de instalar o Manjaro 64 bits versão KDE
Porém quando vou tentar atualizar o SO ocorre o seguinte erro:

:: Continuar a instalação? [S/n] s
....
Pressione qualquer tecla para continuar...

Alguém poderia me ajudar ?


O que tentou instalar?
Foi pelo pacman ou AUR?
E como fez?

*******************************************************
* https://www.linuxcounter.net/cert/620448.png *
*******************************************************


3. Re: Erro ao tentar atualizar Manjaro KDE

Thiago Ferreira de Sousa
thiago.fsousa

(usa Ubuntu)

Enviado em 26/03/2017 - 20:27h

Sim estava usando o pacman
E eu estava tentando atualizar os pacotes do sistema.
Eu acabei de instalar o sistema
Sou iniciante nele
Eu apertei no fantasminha vermelho que fica no painel
E executei as atualizações em modo terminal


4. Re: Erro ao tentar atualizar Manjaro KDE

Guilherme Machado
ochapeudepalha

(usa Arch Linux)

Enviado em 26/03/2017 - 20:30h

Não passei por isso ainda, mesmo assim tente executar a solução abaixo;
https://wiki.archlinux.org/index.php/Pacman#.22Failed_to_commit_transaction_.28conflicting_files.29....





colorado@arch-linux
OS: Arch Linux
Kernel: x86_64 Linux 4.4.52-1-lts
Packages: 696
Shell: zsh 5.3.1
DE: XFCE4
WM: Xfwm4



5. Re: Erro ao tentar atualizar Manjaro KDE

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 26/03/2017 - 20:57h

de onde baixou a imagem que usou para instalação? se não me engano, estes pacotes são referentes a nvidia, tem placa de video da nvidia no pc? se sim, como fez a instalação dos drives proprietários?


6. Re: Erro ao tentar atualizar Manjaro KDE

Thiago Ferreira de Sousa
thiago.fsousa

(usa Ubuntu)

Enviado em 26/03/2017 - 21:01h

Minha placa de vídeo é onborad dá Intel
E eu baixei a imagem ISO do próprio site do manjaro


7. Re: Erro ao tentar atualizar o SO

Izaias
izaias

(usa Manjaro Linux)

Enviado em 26/03/2017 - 21:05h

thiago.fsousa escreveu:

Sim estava usando o pacman
E eu estava tentando atualizar os pacotes do sistema.
Eu acabei de instalar o sistema
Sou iniciante nele
Eu apertei no fantasminha vermelho que fica no painel
E executei as atualizações em modo terminal


Se o pamac estava em vermelho, bastava permitir a atualização por ele.
Se lembrar qual o comando usado, pode identificar como corrompeu a atualização.

Tente isso: http://manjaro-linux.com.br/forum/instalacao/falha-na-atualizacao-dependencias-pacman-init-t3926-10....

*******************************************************
* https://www.linuxcounter.net/cert/620448.png *
*******************************************************


8. Comigo resolveu uma dica encontrada aqui

Cleberson Carlos
clebinho10

(usa Manjaro Linux)

Enviado em 19/04/2017 - 21:57h

ochapeudepalha escreveu:

Não passei por isso ainda, mesmo assim tente executar a solução abaixo;
https://wiki.archlinux.org/index.php/Pacman#.22Failed_to_commit_transaction_.28conflicting_files.29....


Meu pc tem configuração parecida com o seu, e apresentou o mesmo erro hoje, tinha desinstalado o manjaro e voltado a usar os Debian-like por outros motivos e sinceramente não sei se já resolveu teu problema. Enfim, entrei no link que nosso saudoso pirata indicou e encontrei o seguinte comando:
pacman -S --force $package

Só fiz trocar por:
# pacman -S --force libglvnd

Quando ele buscou o pacote em conflito, desinstalou e pude usar o:
# pacman -Syuu
.

Acho que você possa conseguir assim como eu.


9. Re: Erro ao tentar atualizar Manjaro KDE

10. Re: Erro ao tentar atualizar Manjaro KDE

Carlos Filho
carlosfilho

(usa openSUSE)

Enviado em 21/04/2017 - 08:03h

Tente a sequência abaixo no terminal:

Remover o db.lck
sudo rm -f /var/lib/pacman/db.lck

Otimizar os mirrors
sudo pacman-mirrors -g

Otimizar a base de dados
sudo pacman-optimize

Atualizar o sistema
sudo pacman -Syyu

Carlos Filho

http://opensusebr.blogspot.com.br/







Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts