Openflow: SNAC

1. Openflow: SNAC

Jordan Rodrigues
Norkk

(usa Ubuntu)

Enviado em 01/06/2012 - 06:25h

Bom dia,

Estou com difilcudade em instalar o SNAC na minha máquina. O GUI que estou seguindo é o seguinte: http://www.openflow.org/wp/snac/

SO: Ubuntu 11.04
NoxController está Instalado na máquina.

Apresentando os seguintes erros:
Primeiro:

sudo apt-get install openssl libboost-test1.34.1 libboost-filesystem1.34.1 \
> libboost-serialization1.34.1 libxerces-c28 python2.5 python-twisted \
> python-simplejson python-mako python-openssl tmpreaper \
> python-sphinx libldap2-dev
[sudo] password for openflow1:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package python2.5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libboost-filesystem1.34.1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libboost-serialization1.34.1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libboost-test1.34.1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libboost-test1.34.1' has no installation candidate
E: Package 'libboost-filesystem1.34.1' has no installation candidate
E: Package 'libboost-serialization1.34.1' has no installation candidate
E: Package 'python2.5' has no installation candidate




Segundo Erro:

sudo dpkg -i *.deb
(Reading database ... 176153 files and directories currently installed.)
Preparing to replace noxcore 0.4.0~beta (using noxcore_0.4.0~beta_i386.deb) ...
Unpacking replacement noxcore ...
Preparing to replace nox-dbg 0.4.0~beta (using nox-dbg_0.4.0~beta_i386.deb) ...
Unpacking replacement nox-dbg ...
Preparing to replace noxext 0.4.0~beta (using noxext_0.4.0~beta_i386.deb) ...
Unpacking replacement noxext ...
Preparing to replace nox-monitor 0.4.0~beta (using nox-monitor_0.4.0~beta_i386.deb) ...
Unpacking replacement nox-monitor ...
Preparing to replace openflow-common 0.8.9-rev4 (using openflow-common_0.8.9-rev4_i386.deb) ...
Unpacking replacement openflow-common ...
Preparing to replace openflow-pki 0.8.9-rev4 (using openflow-pki_0.8.9-rev4_all.deb) ...
Unpacking replacement openflow-pki ...
Preparing to replace snacdocs 0.4.0~beta (using snacdocs_0.4.0~beta_i386.deb) ...
Unpacking replacement snacdocs ...
dpkg: dependency problems prevent configuration of noxcore:
noxcore depends on libboost-filesystem1.34.1 (>= 1.34.1-8); however:
Package libboost-filesystem1.34.1 is not installed.
noxcore depends on libboost-serialization1.34.1 (>= 1.34.1-8); however:
Package libboost-serialization1.34.1 is not installed.
noxcore depends on libboost-test1.34.1 (>= 1.34.1-8); however:
Package libboost-test1.34.1 is not installed.
noxcore depends on libpython2.6 (>= 2.6); however:
Package libpython2.6 is not installed.
noxcore depends on libxerces-c28; however:
Package libxerces-c28 is not installed.
noxcore depends on python2.5; however:
Package python2.5 is not installed.
dpkg: error processing noxcore (--install):
dependency problems - leaving unconfigured
Setting up nox-dbg (0.4.0~beta) ...
dpkg: dependency problems prevent configuration of noxext:
noxext depends on noxcore (= 0.4.0~beta); however:
Package noxcore is not configured yet.
noxext depends on tmpreaper; however:
Package tmpreaper is not installed.
dpkg: error processing noxext (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nox-monitor:
nox-monitor depends on noxcore; however:
Package noxcore is not configured yet.
dpkg: error processing nox-monitor (--install):
dependency problems - leaving unconfigured
Setting up openflow-common (0.8.9-rev4) ...
dpkg: dependency problems prevent configuration of snacdocs:
snacdocs depends on noxext (= 0.4.0~beta); however:
Package noxext is not configured yet.
dpkg: error processing snacdocs (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Setting up openflow-pki (0.8.9-rev4) ...
Processing triggers for ureadahead ...
Errors were encountered while processing:
noxcore
noxext
nox-monitor
snacdocs

Aguardo Resposta,
Obrigado!