Metasploit no Crunchbang! Ajudem-me?

1. Metasploit no Crunchbang! Ajudem-me?

Rafael Lunelli
rafalunelli

(usa Debian)

Enviado em 18/11/2012 - 19:27h

Olá a todos!
Bem, eu usava o Backtrack em pen tests. Depois, migrei para o Crunchbang e resolvi instalar o metasploit. No início, estava funcioando tudo beleza, porém, quando iniciava-o(o metasploit), o terminar retornava um erro em um arquivo(que não me recordo o nome) e dizia que eu deveria iniciar o metasploit como root(pois realmente, não o tinha feito). Depois decidi dar o seguinte comando:"msfupdate". Esperei a atualização finalizar e com isso, quando iniciei o metasploit pela primeira vez, ele não mais funcionava! Veja o retorno:
" /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- metasploit_data_models (LoadError)
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit-4.4.0/msf3/lib/msf/core/db_manager.rb:11:in `<top (required)>'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit-4.4.0/msf3/lib/msf/core/framework.rb:69:in `<class:Framework>'
from /opt/metasploit-4.4.0/msf3/lib/msf/core/framework.rb:13:in `<module:Msf>'
from /opt/metasploit-4.4.0/msf3/lib/msf/core/framework.rb:5:in `<top (required)>'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit-4.4.0/msf3/lib/msf/core.rb:34:in `<top (required)>'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit-4.4.0/msf3/lib/msf/ui/console/driver.rb:2:in `<top (required)>'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit-4.4.0/msf3/lib/msf/ui/console.rb:11:in `<top (required)>'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit-4.4.0/msf3/lib/msf/ui.rb:11:in `<top (required)>'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/ruby/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /opt/metasploit-4.4.0/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit-4.4.0/msf3/msfconsole:131:in `<main>' "

Como posso resolver meu problema? Há como?
agradeço a todos, de antemão, e espero que meu problema seja solucionado.

Muito obrigado!


  






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts