Erro na instalação da biblioteca ncurses5-compat-libs (Manjaro Linux) [RESOLVIDO]

1. Erro na instalação da biblioteca ncurses5-compat-libs (Manjaro Linux) [RESOLVIDO]

Arthur Gonsales da Silva
gonsalesarthur

(usa Ubuntu)

Enviado em 04/05/2017 - 13:41h

Olá, pessoal
Instalei o Matlab no Manjaro Linux para uso no laboratório onde trabalho e não consegui inicializar o mesmo normalmente pelo terminal, através do bash.

Quando tento iniciar o programa, no terminal me é retornado o seguinte:
"bash: matlab: Arquivo ou diretório não encontrado"

Como informação adicional, instalei o Matlab no diretório "/home/meupc/Programas/Matlab", pois estava tendo problema na instalação na pasta padrão "usr".
Em uma breve pesuisa pelo forum do Arch Linux e do próprio Manjaro, encontrei uma possível solução, na qual eu deveria instalar a biblioteca "ncurses5-compat-libs", direto do AUR, porém, quando eu tento instalar a biblioteca, o seguinte erro ocorre após o uso do comando "sudo yaourt -S ncurses5-compat-libs" no terminal:
"==> ERRO: Executar makepkg como root não é permitido, pois isso pode causar danos catastróficos e permanentes ao seu sistema.
==> ERRO: An unknown error has occurred. Exiting...
Não foi possível ler o PKGBUILD
"
Por conta disso não consigo iniciar o Matlab normalmente.
OBS: Lembrando que eu nego a edição do PKGBUILD durante a instalação.
Grato desde já pela atenção!





  


2. MELHOR RESPOSTA

Carlos A. P. Cunha
Carlos_Cunha

(usa Deepin)

Enviado em 04/05/2017 - 23:14h

gonsales escreveu:

Olá, pessoal
Instalei o Matlab no Manjaro Linux para uso no laboratório onde trabalho e não consegui inicializar o mesmo normalmente pelo terminal, através do bash.

Quando tento iniciar o programa, no terminal me é retornado o seguinte:
"bash: matlab: Arquivo ou diretório não encontrado"

Como informação adicional, instalei o Matlab no diretório "/home/meupc/Programas/Matlab", pois estava tendo problema na instalação na pasta padrão "usr".
Em uma breve pesuisa pelo forum do Arch Linux e do próprio Manjaro, encontrei uma possível solução, na qual eu deveria instalar a biblioteca "ncurses5-compat-libs", direto do AUR, porém, quando eu tento instalar a biblioteca, o seguinte erro ocorre após o uso do comando "sudo yaourt -S ncurses5-compat-libs" no terminal:
"==> ERRO: Executar makepkg como root não é permitido, pois isso pode causar danos catastróficos e permanentes ao seu sistema.
==> ERRO: An unknown error has occurred. Exiting...
Não foi possível ler o PKGBUILD
"
Por conta disso não consigo iniciar o Matlab normalmente.
OBS: Lembrando que eu nego a edição do PKGBUILD durante a instalação.
Grato desde já pela atenção!




o YAROUT numca deve ser executado como root(sudo) por isso ele além de lhe informar isso , cancela o processo.
Execute o processo sem o sudo(depois ele ira pedir).

yaourt -S ncurses5-compat-libs



Abraço
#-------------------------------------------------------------------------------------#
Administrador de Redes Mistas Linux/Windows
LPI 101-102
LPI 201
Para consultas particulares acesse:
www.cunhatec.com.br

"Falar é fácil, me mostre o código." - Linus Torvalds