17 erros ao rodar qualquer sudo [RESOLVIDO]

1. 17 erros ao rodar qualquer sudo [RESOLVIDO]

Pernalonga Capitalista
PernalongaC

(usa Outra)

Enviado em 04/04/2021 - 19:58h

Boa noite.
Sempre que tento usar um sudo apt upgrade, sudo apt update, sudo apt install, ou qualquer variação de sudo, aparecem esses erros:

Erros foram encontrados durante o processamento de:
python3
python3-distupgrade
python3-six
python3-chardet
python3-debian
python3-gi
ubuntu-release-upgrader-core
update-manager-core
python3-update-manager
lsb-release
python3-distro-info
python3-pkg-resources
python3-dbus
python3-apt
update-notifier-common
python3-debconf
ttf-mscorefonts-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

E agr?


  


2. Re: 17 erros ao rodar qualquer sudo [RESOLVIDO]

johncorreia02
johncorreia02

(usa Arch Linux)

Enviado em 04/04/2021 - 20:11h

Roda o su


3. Re: 17 erros ao rodar qualquer sudo [RESOLVIDO]

Pernalonga Capitalista
PernalongaC

(usa Outra)

Enviado em 04/04/2021 - 22:15h


johncorreia02 escreveu:

Roda o su


como assim? Su root?


4. Re: 17 erros ao rodar qualquer sudo

Pernalonga Capitalista
PernalongaC

(usa Outra)

Enviado em 04/04/2021 - 22:18h

johncorreia02 escreveu:

Roda o su


Tentei rodar um sudo apt upgrade depois de digitar su e deu o mesmo erro


5. Re: 17 erros ao rodar qualquer sudo [RESOLVIDO]

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 05/04/2021 - 19:45h

O problema não é no SUDO, é no APT.

Tente resolver com esses comandos:
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt update && sudo apt upgrade


Se ainda aparecer erros, tente isso:
for pkg in python3 python3-distupgrade python3-six python3-chardet python3-debian python3-gi ubuntu-release-upgrader-core update-manager-core python3-update-manager lsb-release python3-distro-info python3-pkg-resources python3-dbus python3-apt update-notifier-common python3-debconf ttf-mscorefonts-installer ; do sudo rm -fv /var/lib/dpkg/info/${pkg}.* ; done

sudo apt update && sudo apt upgrade




6. Re: 17 erros ao rodar qualquer sudo

Pernalonga Capitalista
PernalongaC

(usa Outra)

Enviado em 06/04/2021 - 13:31h

Ryuk escreveu:

O problema não é no SUDO, é no APT.

Tente resolver com esses comandos:
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt update && sudo apt upgrade


Se ainda aparecer erros, tente isso:
for pkg in python3 python3-distupgrade python3-six python3-chardet python3-debian python3-gi ubuntu-release-upgrader-core update-manager-core python3-update-manager lsb-release python3-distro-info python3-pkg-resources python3-dbus python3-apt update-notifier-common python3-debconf ttf-mscorefonts-installer ; do sudo rm -fv /var/lib/dpkg/info/${pkg}.* ; done



sudo apt update && sudo apt upgrade


Eu testei os primeiros códigos e deu erro, daí eu fui colocar esse outro aí e ele pediu pra eu digitar se queria a versão nova ou atual, eu digitei pra saber as diferenças, mas daí apareceu uma tela q eu n conseguia sair e eu acabei fechando o terminal, mas agr quando eu digito um sudo apt upgrade aparece:

Waiting for cache lock: Could not get lock /var/lib/dpkg/lock-frontend. It is he
ld by process 19746

E fica dando isso eternamente

Edit: VLW ae, rodei um sudo dpkg --configure -a e resolveu esse erro, vlw ae de vdd