Error ao compilar mesa-10.6.6

1. Error ao compilar mesa-10.6.6

Perfil removido
removido

(usa Nenhuma)

Enviado em 23/10/2015 - 08:14h

Ola galera estou com um error ao compilar o pacote mesa entre outros pacotes no Beyond Linux From Scratch.
Gostaria da ajuda de vocês, segue o erro:

configure: error: Package requirements (x11 xext xdamage xfixes x11-xcb xcb xcb-glx >= 1.8.1 xcb-dri2 >= 1.8 xcb-dri3 xcb-present xcb-sync xshmfence >= 1.1) were not met:

No package 'x11' found
No package 'xext' found
No package 'xdamage' found
No package 'xfixes' found
No package 'x11-xcb' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DRIGL_CFLAGS
and DRIGL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


  


2. Re: Error ao compilar mesa-10.6.6

Daniel Hilst Selli
danielhilst

(usa Arch Linux)

Enviado em 23/10/2015 - 09:21h

Você vai precisar satisfazer essa dependencias, instalar os pacotes que tão faltando, depois rodar o configure de novo :)


3. Re: Error ao compilar mesa-10.6.6

Daniel Hilst Selli
danielhilst

(usa Arch Linux)

Enviado em 23/10/2015 - 11:38h

Cara relacionado ao LFS eu nunca mechi com ele, mas basicamente o que acontece é o seguinte. O que você está tentando compilar depende de outros softwares bibliotecas. O que o script configure faz é checar por essas dependencias, é isso que você está vendo. Se não fosse por essa checagem você ia ter erros de compilação (durante o make).

O que você tem que fazer é baixar o fonte desses pacotes e instalar eles da mesma maneira que está fazendo com o mesa,

Att,


4. Re: Error ao compilar mesa-10.6.6

Perfil removido
removido

(usa Nenhuma)

Enviado em 23/10/2015 - 13:38h

danielhilst escreveu:

Cara relacionado ao LFS eu nunca mechi com ele, mas basicamente o que acontece é o seguinte. O que você está tentando compilar depende de outros softwares bibliotecas. O que o script configure faz é checar por essas dependencias, é isso que você está vendo. Se não fosse por essa checagem você ia ter erros de compilação (durante o make).

O que você tem que fazer é baixar o fonte desses pacotes e instalar eles da mesma maneira que está fazendo com o mesa,

Att,



Obrigado pela ajuda danielhilst, mas ja tentei varias formas e nada, reiniciei o cd agr e estou recompilando o xorg, se der certo eu posto aqui, obrigado pela ajuda.



5. Re: Error ao compilar mesa-10.6.6

Luiz Santos
luiztux

(usa Gentoo)

Enviado em 23/10/2015 - 16:53h

kleisongeek escreveu:

Ola galera estou com um error ao compilar o pacote mesa entre outros pacotes no Beyond Linux From Scratch.
Gostaria da ajuda de vocês, segue o erro:

configure: error: Package requirements (x11 xext xdamage xfixes x11-xcb xcb xcb-glx >= 1.8.1 xcb-dri2 >= 1.8 xcb-dri3 xcb-present xcb-sync xshmfence >= 1.1) were not met:

No package 'x11' found
No package 'xext' found
No package 'xdamage' found
No package 'xfixes' found
No package 'x11-xcb' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DRIGL_CFLAGS
and DRIGL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Só complementando, os pacotes devem ser >= (maior ou igual) às versões listadas.




6. Re: Error ao compilar mesa-10.6.6

Perfil removido
removido

(usa Nenhuma)

Enviado em 23/10/2015 - 22:28h

luiztux escreveu:

kleisongeek escreveu:

Ola galera estou com um error ao compilar o pacote mesa entre outros pacotes no Beyond Linux From Scratch.
Gostaria da ajuda de vocês, segue o erro:

configure: error: Package requirements (x11 xext xdamage xfixes x11-xcb xcb xcb-glx >= 1.8.1 xcb-dri2 >= 1.8 xcb-dri3 xcb-present xcb-sync xshmfence >= 1.1) were not met:

No package 'x11' found
No package 'xext' found
No package 'xdamage' found
No package 'xfixes' found
No package 'x11-xcb' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DRIGL_CFLAGS
and DRIGL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Só complementando, os pacotes devem ser >= (maior ou igual) às versões listadas.




consegui corrigir alguns problemas com o comando abaixo:

apt install libx11-dev libxext-dev libxdamage-dev libxfixes-dev libx11-xcb-dev

mas ainda a este problema:
checking for XWUD... configure: error: Package requirements (x11 xproto >= 7.0.17) were not met:

No package 'x11' found

alguem ai sabe como resolver? qual pacote instalar etc.. Estou utilizando um live-cd do ubuntu 14.04


7. Re: Error ao compilar mesa-10.6.6

Daniel Hilst Selli
danielhilst

(usa Arch Linux)

Enviado em 24/10/2015 - 09:02h

Cara no começo achei que vc fazendo um Linux From Scrach, mas agora que rodou o apt-get surgiu a duvida.

Pq ta tentando compilar o mesa na mão?

Att,


8. Re: Error ao compilar mesa-10.6.6

Perfil removido
removido

(usa Nenhuma)

Enviado em 24/10/2015 - 12:45h

danielhilst escreveu:

Cara no começo achei que vc fazendo um Linux From Scrach, mas agora que rodou o apt-get surgiu a duvida.

Pq ta tentando compilar o mesa na mão?

Att,




Por que o linux from scratch é todo compilado a mão. Estou no Beyound linux from scratch (BLFS).

http://www.linuxfromscratch.org/blfs/view/stable/x/mesalib.html

O live-cd é quem presiza contornar as dependencias. Basicamente estou utilizando um Live-CD do Ubuntu pra criar o BLFS pois o LFS eu ja criei com o mesmo Live-CD, o BLFS é a continuação do LFS.

O mesmo erro ocorre quando utilizo um Live-CD do manjaro:
http://i.imgur.com/OuTzfjY.png


9. Re: Error ao compilar mesa-10.6.6

Luiz Santos
luiztux

(usa Gentoo)

Enviado em 24/10/2015 - 13:05h

kleisongeek escreveu:

luiztux escreveu:

kleisongeek escreveu:

Ola galera estou com um error ao compilar o pacote mesa entre outros pacotes no Beyond Linux From Scratch.
Gostaria da ajuda de vocês, segue o erro:

configure: error: Package requirements (x11 xext xdamage xfixes x11-xcb xcb xcb-glx >= 1.8.1 xcb-dri2 >= 1.8 xcb-dri3 xcb-present xcb-sync xshmfence >= 1.1) were not met:

No package 'x11' found
No package 'xext' found
No package 'xdamage' found
No package 'xfixes' found
No package 'x11-xcb' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DRIGL_CFLAGS
and DRIGL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Só complementando, os pacotes devem ser >= (maior ou igual) às versões listadas.




consegui corrigir alguns problemas com o comando abaixo:

apt install libx11-dev libxext-dev libxdamage-dev libxfixes-dev libx11-xcb-dev

mas ainda a este problema:
checking for XWUD... configure: error: Package requirements (x11 xproto >= 7.0.17) were not met:

No package 'x11' found

alguem ai sabe como resolver? qual pacote instalar etc.. Estou utilizando um live-cd do ubuntu 14.04


Voce tem que ter o pacote de protocolo do Xorg maior ou igual à versao 7.0.17. É uma biblioteca necessária pro X funcionar. Baixe-o deste link: http://ftp.x.org/pub/individual/proto/


10. Re: Error ao compilar mesa-10.6.6

Perfil removido
removido

(usa Nenhuma)

Enviado em 24/10/2015 - 13:14h

luiztux escreveu:

kleisongeek escreveu:

luiztux escreveu:

kleisongeek escreveu:

Ola galera estou com um error ao compilar o pacote mesa entre outros pacotes no Beyond Linux From Scratch.
Gostaria da ajuda de vocês, segue o erro:

configure: error: Package requirements (x11 xext xdamage xfixes x11-xcb xcb xcb-glx >= 1.8.1 xcb-dri2 >= 1.8 xcb-dri3 xcb-present xcb-sync xshmfence >= 1.1) were not met:

No package 'x11' found
No package 'xext' found
No package 'xdamage' found
No package 'xfixes' found
No package 'x11-xcb' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DRIGL_CFLAGS
and DRIGL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Só complementando, os pacotes devem ser >= (maior ou igual) às versões listadas.




consegui corrigir alguns problemas com o comando abaixo:

apt install libx11-dev libxext-dev libxdamage-dev libxfixes-dev libx11-xcb-dev

mas ainda a este problema:
checking for XWUD... configure: error: Package requirements (x11 xproto >= 7.0.17) were not met:

No package 'x11' found

alguem ai sabe como resolver? qual pacote instalar etc.. Estou utilizando um live-cd do ubuntu 14.04


Voce tem que ter o pacote de protocolo do Xorg maior ou igual à versao 7.0.17. É uma biblioteca necessária pro X funcionar. Baixe-o deste link: http://ftp.x.org/pub/individual/proto/



Vou bootar pelo ubuntu novamente e tentar, obrigado pelo apoio.



11. Re: Error ao compilar mesa-10.6.6

edps
edps

(usa Slackware)

Enviado em 24/10/2015 - 13:39h

Quando num seio o que é o tal pacote, geralmente vou assim:

https://packages.debian.org/search?searchon=sourcenames&keywords=xext
ou
https://packages.debian.org/search?searchon=sourcenames&keywords=xcb

Vejo o que combina com a necessidade, e acesso sua página, exemplo:

https://packages.debian.org/sid/libxext-dev

Na lateral da página você terá algo assim:

Download Source Package libxext:

[libxext_1.3.3-1.dsc]
[libxext_1.3.3.orig.tar.gz]
[libxext_1.3.3-1.diff.gz]

* e às vezes a homepage do programa.

O arquivo *.orig.tar.gz, em tese deverá ser o mesmo disponibilizado na homepage do programa, então se você tentar compilá-lo poderá ter sucesso.

Caso negativo, aplique aquele *.diff.gz ali:

$ wget http://http.debian.net/debian/pool/main/libx/libxext/libxext_1.3.3-1.diff.gz
$ gunzip libxext_1.3.3-1.diff.gz
$ patch -p1 < libxext_1.3.3-1.diff


Apenas para título de informação, toda essa feitiçaria num sistema Debian resolveria-se assim:

$ dget -x -u --build http://http.debian.net/debian/pool/main/libx/libxext/libxext_1.3.3-1.dsc 


Baixa, descompacta, aplica o patch e empacota um .deb, MAS (sempre tem um MAS), em caso de erro entra-se no diretório do pacote e roda-se (vem mais feitiçarias por aí):

$ mk-build-deps
$ sudo dpkg -i *.deb
$ sudo apt-get -f install
$ dpkg-buildpackage -us -uc -b -tc
$ sudo dpkg -i ../*.deb


* para poder realizar os procedimentos acima descritos, são necessários: dpkg-dev, devscripts, equivs.

Falei do caso do Debian, mas às vezes vejo os sources de um PKGBUILD a fim de me orientar:

https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/boost

* observe que na pasta tem o PKGBUILD e um patch.

No PKGBUILD tem toda a rotina para o empacotamento, as dependências do pacote e etc:

https://projects.archlinux.org/svntogit/packages.git/plain/trunk/PKGBUILD?h=packages/boost

Soluções não faltam, sejam dos sources Debian, PKGBUILDS, ebuilds, SlackBuilds e por aí vai.

Boa sorte.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts