Jogar Tibia no linux [RESOLVIDO]

1. Jogar Tibia no linux [RESOLVIDO]

Danillo Dars
danillodars

(usa Ubuntu)

Enviado em 18/09/2016 - 22:12h

Olá,

Semana passada a equipe da Cipsoft (Criadora do Tibia) lançou um novo client tanto para Windows como para Linux, o problema é o novo client foi feito do zero e a forma de como executava é diferente de como era feito antigamente, aparentemente a nova forma é ir até a pasta em que os arquivos do jogo se encontra e executar o seguinte comando:

$ ./start-tibia.sh 


No momento em que executo da um erro falando que não é possível encontrar uma LIB chamada libpcre16.so.0, já tentei instalar esse pacote de LIB e não acho, sou iniciante no Linux então desculpem a minha ignorancia. Segue erro que dá ao tentar executar o jogo:
/home/danillo/Área de Trabalho/tibia-11.00.3813/bin/client: error while loading shared libraries: libpcre16.so.0: cannot open shared object file: No such file or directory 


Poderiam me ajudar?



  


2. Re: Jogar Tibia no linux [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 18/09/2016 - 22:52h

Fiz uma pesquisa na página do Debian, que é aparentado do Mint e Ubuntu, e um arquivo de nome muito parecido surgiu.

Pesquisei por libpcre16.so no Debian Unstable. Nem no apt-file ele aparece.

https://packages.debian.org/search?searchon=contents&keywords=libpcre16.so&mode=path&sui...

O resultado, conforme pode ser visto no link acima, é que parece ser necessária a instalação do pacote libpcre3-dev.

Pode dar certo. Ou não.

----------------------------------------------------------------------------------------------------------------
Nem direita, nem esquerda. Quando se trata de corrupção o Brasil é ambidestro.
(anônimo)

Encryption works. Properly implemented strong crypto systems are one of the few things that you can rely on. Unfortunately, endpoint security is so terrifically weak that NSA can frequently find ways around it. — Edward Snowden



3. Re: Jogar Tibia no linux [RESOLVIDO]

4. Re: Jogar Tibia no linux [RESOLVIDO]

Fabiano
fpires

(usa Debian)

Enviado em 18/09/2016 - 23:13h

Tem esse pacote no Debian testing e na Sid (instale por sua própria conta e risco!).
https://packages.debian.org/search?keywords=libpcre16-3



5. Re: Jogar Tibia no linux [RESOLVIDO]

Danillo Dars
danillodars

(usa Ubuntu)

Enviado em 18/09/2016 - 23:26h

listeiro_037 escreveu:

Fiz uma pesquisa na página do Debian, que é aparentado do Mint e Ubuntu, e um arquivo de nome muito parecido surgiu.

Pesquisei por libpcre16.so no Debian Unstable. Nem no apt-file ele aparece.

https://packages.debian.org/search?searchon=contents&keywords=libpcre16.so&mode=path&sui...

O resultado, conforme pode ser visto no link acima, é que parece ser necessária a instalação do pacote libpcre3-dev.

Pode dar certo. Ou não.

----------------------------------------------------------------------------------------------------------------
Nem direita, nem esquerda. Quando se trata de corrupção o Brasil é ambidestro.
(anônimo)

Encryption works. Properly implemented strong crypto systems are one of the few things that you can rely on. Unfortunately, endpoint security is so terrifically weak that NSA can frequently find ways around it. — Edward Snowden


Fiz uma busco por PCRE e me retornou o seguinte:

$ sudo apt-cache search pcre

libapache2-mod-php7.0 - linguagem de scripts imersa em HTML, roda no servidor (módulo Apache 2)
libpcre16-3 - Perl 5 Compatible Regular Expression Library - 16 bit runtime files
libpcre3 - Biblioteca de expressões regulares compatível com Perl 5
libpcre3-dbg - Perl 5 Compatible Regular Expression Library - debug symbols
libpcre3-dev - Perl 5 Compatible Regular Expression Library - development files
libpcre32-3 - Perl 5 Compatible Regular Expression Library - 32 bit runtime files
php7.0-cgi - server-side, HTML-embedded scripting language (CGI binary)
php7.0-cli - command-line interpreter for the PHP scripting language
postfix-pcre - PCRE map support for Postfix
libpcrecpp0v5 - Perl 5 Compatible Regular Expression Library - C++ runtime files
awffull - programa de análise de log de servidor web
cl-ppcre - biblioteca de expressões regulares portáveis para Common Lisp
exonerate - ferramenta genérica para comparação de pares de sequências
libghc-pcre-light-dev - Haskell library for Perl 5-compatible regular expressions
libghc-pcre-light-doc - library documentation for pcre-light; documentation
libghc-regex-base-dev - GHC library providing an API for regular expressions
libghc-regex-base-doc - GHC library providing an API for regular expressions; documentation
libghc-regex-base-prof - GHC library providing an API for regular expressions; profiling libraries
libghc-regex-pcre-doc - Perl-compatible regular expressions; documentation
libpcre++-dev - C++ wrapper class for pcre (development)
libpcre++0v5 - Classe wrapper C++ para pcre (tempo de execução)
libpcre2-dbg - New Perl Compatible Regular Expression Library - debug symbols
libre2-dev - efficient, principled regular expression library, development kit
sigil - multi-platform ebook editor
sigil-data - multi-platform ebook editor - data files
cl-abnf - Common Lisp ABNF parser generator
cl-unicode - portable Unicode library for Common Lisp
clisp-module-pcre - clisp module that adds libpcre support
gambas3-gb-pcre - Gambas regexp component
libemail-sender-transport-smtp-tls-perl - Perl module for sending email using TLS
libghc-pcre-light-prof - pcre-light library with profiling enabled; profiling libraries
libghc-regex-pcre-dev - Perl-compatible regular expressions
libghc-regex-pcre-prof - Perl-compatible regular expressions; profiling libraries
libpcre-ocaml - OCaml bindings for PCRE (runtime)
libpcre-ocaml-dev - OCaml bindings for PCRE (Perl Compatible Regular Expression)
libpcre2-16-0 - New Perl Compatible Regular Expression Library - 16 bit runtime files
libpcre2-32-0 - New Perl Compatible Regular Expression Library - 32 bit runtime files
libpcre2-8-0 - New Perl Compatible Regular Expression Library- 8 bit runtime files
libpcre2-dev - New Perl Compatible Regular Expression Library - development files
libpcre2-posix0 - New Perl Compatible Regular Expression Library - posix-compatible runtime files
libphp7.0-embed - HTML-embedded scripting language (Embedded SAPI library)
libre2-1v5 - efficient, principled regular expression library
lua-rex-pcre - Perl regular expressions library for the Lua language
lua-rex-pcre-dev - PCRE development files for the Lua language
lwatch - Simple log colorizer
pcre2-utils - New Perl Compatible Regular Expression Library - utilities
pcredz - Extracts authentication credentials from network captures
pcregrep - grep utility that uses perl 5 compatible regexes.
php7.0-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
php7.0-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary)
pike7.8-pcre - PCRE module for Pike
pike8.0-pcre - PCRE module for Pike
ruby-re2 - Ruby bindings to re2
sqlite3-pcre - Perl-compatible regular expression support for SQLite


Aparentemente está instalado, correto?


6. Re: Jogar Tibia no linux [RESOLVIDO]

Danillo Dars
danillodars

(usa Ubuntu)

Enviado em 18/09/2016 - 23:28h



Desculpe a ignorância, não entendi como executar este precedimento. Sou muito leigo no linux.


7. Re: Jogar Tibia no linux

Perfil removido
removido

(usa Nenhuma)

Enviado em 18/09/2016 - 23:31h

Tente usar opção --installed.

ou

usar dpkg -l | grep ^ii | grep libpcre

----------------------------------------------------------------------------------------------------------------
Nem direita, nem esquerda. Quando se trata de corrupção o Brasil é ambidestro.
(anônimo)

Encryption works. Properly implemented strong crypto systems are one of the few things that you can rely on. Unfortunately, endpoint security is so terrifically weak that NSA can frequently find ways around it. — Edward Snowden



8. Re: Jogar Tibia no linux [RESOLVIDO]

Danillo Dars
danillodars

(usa Ubuntu)

Enviado em 18/09/2016 - 23:37h

listeiro_037 escreveu:

Tente usar opção --installed.

----------------------------------------------------------------------------------------------------------------
Nem direita, nem esquerda. Quando se trata de corrupção o Brasil é ambidestro.
(anônimo)

Encryption works. Properly implemented strong crypto systems are one of the few things that you can rely on. Unfortunately, endpoint security is so terrifically weak that NSA can frequently find ways around it. — Edward Snowden


Poderia me dar um exemplo? Acredito que não seja

sudo apt-cache search pcre --installed 


Fico até com vergonha, não sei muito.


9. Re: Jogar Tibia no linux

Perfil removido
removido

(usa Nenhuma)

Enviado em 18/09/2016 - 23:44h

danillodars escreveu:

listeiro_037 escreveu:

Tente usar opção --installed.

----------------------------------------------------------------------------------------------------------------
Nem direita, nem esquerda. Quando se trata de corrupção o Brasil é ambidestro.
(anônimo)

Encryption works. Properly implemented strong crypto systems are one of the few things that you can rely on. Unfortunately, endpoint security is so terrifically weak that NSA can frequently find ways around it. — Edward Snowden


Poderia me dar um exemplo? Acredito que não seja

sudo apt-cache search pcre --installed 


Fico até com vergonha, não sei muito.


Eu dei uma editada no texto.
Talvez seja melhor tentar a segunda opção.
Estranho, mas --installed não funciona.


----------------------------------------------------------------------------------------------------------------
Nem direita, nem esquerda. Quando se trata de corrupção o Brasil é ambidestro.
(anônimo)

Encryption works. Properly implemented strong crypto systems are one of the few things that you can rely on. Unfortunately, endpoint security is so terrifically weak that NSA can frequently find ways around it. — Edward Snowden



10. Resolvido!

Danillo Dars
danillodars

(usa Ubuntu)

Enviado em 19/09/2016 - 14:24h

Problema resolvido, achei pela net um procedimento que acabou funcionando para mim. Segue:

Primeiro passo era instalar o pacote libpcre16-3, como eu já havia instalado anteriormente ignorei este passo e fui direto ao segundopasso.
$ sudo apt-get install libpcre16-3 

Segundo passo seria criar um Link Simbólico, pois está instalado a versão mais recente da biblioteca e ao invés de ter o o arquivo libpcre16.so.0 tem o arquivo libpcre16.so.3 e como o Tibia exige a libpcre16.so.0 foi preciso apenas criar um Link Simbólico para que o Tibia enxergasse a libpcre16.so.3 como se fosse libpcre16.so.0.
ln -s "/usr/lib/x86_64-linux-gnu/libpcre16.so.3" "<caminho_tibia_11>/bin/libpcre16.so.0" 


Após ter feito esse procedimento funcionar que é uma beleza, obrigado pela atenção de todos :)

Isso pode ter acontecido comigo em um jogo, quem sabe não pode acontecer com outro usuário em outro programa. Espero que possa ajudar mais alguém no futuro.


11. Acentos

Tito Macedo
Tito Linux

(usa Linux Mint)

Enviado em 01/10/2016 - 23:07h

Agora que você já conseguiu instalar o jogo, está funcionando os acentos aí?
Os acentos funcionam bem em todo sistema, mas no Tibia 11 não funciona.
Eu também fiz um pequeno tutorial explicando como eu consegui fazer o jogo funcionar, do meu jeito ficou bem mais simples.
http://raulnolinux.blogspot.com.br/2016/09/como-instalar-o-tibia-11-no-linux.html
Se quiser, eu te ajudo a criar um atalho para o jogo.


12. Re: Jogar Tibia no linux [RESOLVIDO]

Danillo Dars
danillodars

(usa Ubuntu)

Enviado em 02/10/2016 - 00:14h

Tito Linux escreveu:

Agora que você já conseguiu instalar o jogo, está funcionando os acentos aí?
Os acentos funcionam bem em todo sistema, mas no Tibia 11 não funciona.
Eu também fiz um pequeno tutorial explicando como eu consegui fazer o jogo funcionar, do meu jeito ficou bem mais simples.
http://raulnolinux.blogspot.com.br/2016/09/como-instalar-o-tibia-11-no-linux.html
Se quiser, eu te ajudo a criar um atalho para o jogo.



Não tinha reparado essa questão e realmente não funciona, acredito que seja por terem pego o inglês como língua padrão e no inglês não possui acentos.







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts