Maneira mais fácil de remover pacotes quebrados? [RESOLVIDO]

1. Maneira mais fácil de remover pacotes quebrados? [RESOLVIDO]

Anderson Ferreira
anderson1277

(usa Ubuntu)

Enviado em 14/12/2009 - 19:23h

Galera, eu sou iniciante em linux e não estou consiguindo desinstalar alguns pacotes quebrados do sistema. Queria saber a maneira mais fácil para remover esses pacotes?Se tem algum programa que faça isso??Ou comando que faça isso sem qualquer problam?

Vlw galera

Viva o linux!!!!!!!!!!!!!!

Eu uso ubuntu 9.10


  


2. MELHOR RESPOSTA

José Cleydson Ferreira da Silva
cleysinhonv

(usa Ubuntu)

Enviado em 15/12/2009 - 07:13h

Olá,

Para remover pacotes quebrados, de os seguintes comandos abaixo no terminal como root:

1°) apt-get update ou aptitude update
2°) dpkg --configure -a
3°) apt-get -f install

Esse são procedimentos para resolver pacotes quebrados

3. Re: Maneira mais fácil de remover pacotes quebrados? [RESOLVIDO]

Rossano Huf
millemiglia

(usa Slackware)

Enviado em 14/12/2009 - 20:45h

Anderson, faz o seguinte: entra no Synaptic e procura o pacote que você quer desinstalar. Clique com o botão direito do mouse sobre o nome do pacote e escolha remoção completa. Acho que isso deve resolver seu problema.


4. Jah tentei isso

Anderson Ferreira
anderson1277

(usa Ubuntu)

Enviado em 14/12/2009 - 22:07h

jah tentei isso mas não funcionou dá esse erro:

E: libboost-regex1.38.0: sub-processo script post-removal instalado retornou estado de saída de erro 2

vlw!!


5. Re: Maneira mais fácil de remover pacotes quebrados? [RESOLVIDO]

José Cleydson Ferreira da Silva
cleysinhonv

(usa Ubuntu)

Enviado em 17/12/2009 - 08:35h

Olá,

Resolveu o problema o tópico ainda está em aberto.


6. vlw

Anderson Ferreira
anderson1277

(usa Ubuntu)

Enviado em 23/12/2009 - 09:44h

Valeo aew galera!!!!!!!!!!!


7. Re: Maneira mais fácil de remover pacotes quebrados? [RESOLVIDO]

Regis Furquim Scaggiante
regisfsc

(usa Ubuntu)

Enviado em 25/11/2012 - 21:56h

executei o comando "apt-get -f install"
o erro persistiu.
Removendo libio-compress-base-perl ...
dpkg: erro processando libio-compress-base-perl (--remove):
não foi possível criar, em segurança, '/usr/share/doc/libio-compress-base-perl/changelog.Debian.gz': Não é um diretório
Removendo libio-compress-zlib-perl ...
dpkg: erro processando libio-compress-zlib-perl (--remove):
não foi possível criar, em segurança, '/usr/share/doc/libio-compress-zlib-perl/changelog.Debian.gz': Não é um diretório
Erros foram encontrados durante o processamento de:
libio-compress-base-perl
libio-compress-zlib-perl
E: Sub-process /usr/bin/dpkg returned an error code (1)

O que posso fazer? não consigo instalar nenhum outro pacote porque estes dois me impedem.


8. Seguinte mensagem

Leandro Bozzi
leandrobozzi

(usa Ubuntu)

Enviado em 08/03/2013 - 10:34h

[email protected]:~$ sudo apt-get install wine
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
wine : Depende: wine1.5 mas não será instalado
E: Não foi possível corrigir os problemas, você suspendeu pacotes quebrados.


9. Erro no meu sistema

Leandro Bozzi
leandrobozzi

(usa Ubuntu)

Enviado em 08/03/2013 - 10:39h

Os pacotes a seguir têm dependências desencontradas:
wine1.5 : Depende: binfmt-support (>= 1.1.2) mas não é instalável
Recomenda: fonts-droid mas não será instalado
Recomenda: ttf-mscorefonts-installer mas não é instalável
Recomenda: fonts-horai-umefont mas não será instalado
Recomenda: fonts-unfonts-core mas não é instalável
Recomenda: winbind mas não é instalável
Recomenda: winetricks mas não será instalado
E: Não foi possível corrigir os problemas, você suspendeu pacotes quebrados.

Att

Leandro Bozzi



10. Re: Maneira mais fácil de remover pacotes quebrados? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 12/04/2013 - 12:14h

leandrobozzi escreveu:

Os pacotes a seguir têm dependências desencontradas:
wine1.5 : Depende: binfmt-support (>= 1.1.2) mas não é instalável
Recomenda: fonts-droid mas não será instalado
Recomenda: ttf-mscorefonts-installer mas não é instalável
Recomenda: fonts-horai-umefont mas não será instalado
Recomenda: fonts-unfonts-core mas não é instalável
Recomenda: winbind mas não é instalável
Recomenda: winetricks mas não será instalado
E: Não foi possível corrigir os problemas, você suspendeu pacotes quebrados.

Att

Leandro Bozzi




Tô mesmo problema com o Lubuntu que tenho no netbook, mas só qua a biblioteca se refere ao Cairo-Dokc. mas a mensagem é a mesma.


11. Linux

HAbhaB Sa hsa
asdfasdfasdf

(usa Ubuntu)

Enviado em 06/05/2014 - 12:18h

Por isso que digo, LINUX é uma Bosta :D perdi 4 horas por causa desses problemas ao invés de estar trabalhando porque não há como instalar essa um workbench nessa bosta


12. Re: Maneira mais fácil de remover pacotes quebrados? [RESOLVIDO]

Giovani
gqrodrigues

(usa Ubuntu)

Enviado em 23/05/2014 - 11:49h

Estou tendo problemas na instalação do Kdenlive devido a pacotes quebrados. Já tentei de tudo, mas não consigo obter resultados favoráveis. O pacote quebrado é libjack-jackd2-0.

Este é o resultado do apt-get -f install:

Os pacotes extra a seguir serão instalados:
libjack-jackd2-0:i386
Pacotes sugeridos:
jackd2:i386
Os NOVOS pacotes a seguir serão instalados:
libjack-jackd2-0:i386
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 3 não atualizados.
É preciso baixar 0 B/202 kB de arquivos.
Depois desta operação, 493 kB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? s
(Lendo banco de dados ... 620226 ficheiros e directórios actualmente instalados.)
Desempacotando libjack-jackd2-0:i386 (de .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb) ...
dpkg: erro processando /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb (--unpack):
'./usr/share/doc/libjack-jackd2-0/buildinfo.gz' is different from the same file on the system
dpkg-deb: erro: subprocesso colar foi finalizado pelo sinal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)




01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts