não consigo atualizar parrot security

1. não consigo atualizar parrot security

Kaiky Pereira Almeida
hizer47

(usa Outra)

Enviado em 01/06/2020 - 11:33h

Eu dou o comando "sudo apt-gt update" e retorna:


Hit:1 https://deb.parrot.sh/parrot rolling InRelease
Hit:2 https://deb.parrot.sh/parrot rolling-security InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
3 packages can be upgraded. Run 'apt list --upgradable' to see them.


Daí eu digito "apt list --upgradable" e mostra os pacotes:

linux-headers-amd64/rolling 5.6.14-2parrot1 amd64 [upgradable from: 5.5.17-1parrot1]
linux-image-amd64/rolling 5.6.14-2parrot1 amd64 [upgradable from: 5.5.17-1parrot1]
python-cffi-backend/rolling 1.14.0-2kali2 amd64 [upgradable from: 1.14.0-1]


E por fim, quando eu dou um apt-get upgrade retorna infinitamente:

apt-get upgrade

apt upgrade is unsafe on rolling release distributions.

using apt full-upgrade instead

use apt upgrade --force to override



Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
linux-headers-amd64 linux-image-amd64 python-cffi-backend
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.



Uso parrot security.


  


2. Re: não consigo atualizar parrot security

Luiz Cantarino
Cantarino

(usa Debian)

Enviado em 01/06/2020 - 18:36h

Se você prestar atenção, verá que a própria saída já lhe diz o que fazer... Você deve usar o 'sudo apt update && sudo apt full-upgrade'

Uma outra dica, você acha isso na documentação dessa distribuição: https://docs.parrotlinux.org/faq/


3. Re: não consigo atualizar parrot security

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 01/06/2020 - 20:29h


hizer47 escreveu:
use apt upgrade --force to override


está escrito aí campeão
apt upgrade --force 


preste atenção tb que está escrito
apt upgrade is unsafe on rolling release distributions.


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




4. Re: não consigo atualizar parrot security

Kaiky Pereira Almeida
hizer47

(usa Outra)

Enviado em 01/06/2020 - 22:37h

Mauriciodez escreveu:


hizer47 escreveu:
use apt upgrade --force to override


está escrito aí campeão
apt upgrade --force 


preste atenção tb que está escrito
apt upgrade is unsafe on rolling release distributions.


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



Sim...Devia ter mencionado isso mas mesmo quando eu dou esse apt upgrade --force ainda retorna:

apt upgrade is unsafe on rolling release distributions.

using apt full-upgrade instead

use apt upgrade --force to override



Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
linux-headers-amd64 linux-image-amd64 python-cffi-backend
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
linux-headers-amd64 linux-image-amd64 python-cffi-backend
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts