Mudar placa de vídeo com sistema já instalado.

1. Mudar placa de vídeo com sistema já instalado.

Alexandre Martins da Cunha
alexandremc

(usa Debian)

Enviado em 06/11/2018 - 03:14h

Boa noite pessoal;

Eu tenho uma placa onboard HD 630 e uma placa offboard NVIDIA 550TI.

Bom instalei o sistema com a 550tTi e o sistema usou o driver NOVEAU, tudo ok, mas precisei trocar a placa, como estou sem grana usei a onboard.

Se eu removo a placa da NVIDIA e deixo a onboard, o servidor X não carrega.

Tentei tudo que sei, criar arquivo no xorg.conf e nada.

Existe um procedimento para isso?

Comprei uma placa nova, supondo AMD Radeon, como faço para detectar ela?

Uso o Debian 9.5

Abraços


  


2. Re: Mudar placa de vídeo com sistema já instalado.

Paulo Bonfanti
pbonfanti

(usa Debian)

Enviado em 07/11/2018 - 09:06h

alexandremc escreveu:

Boa noite pessoal;

Eu tenho uma placa onboard HD 630 e uma placa offboard NVIDIA 550TI.

Bom instalei o sistema com a 550tTi e o sistema usou o driver NOVEAU, tudo ok, mas precisei trocar a placa, como estou sem grana usei a onboard.

Se eu removo a placa da NVIDIA e deixo a onboard, o servidor X não carrega.

Tentei tudo que sei, criar arquivo no xorg.conf e nada.

Existe um procedimento para isso?

Comprei uma placa nova, supondo AMD Radeon, como faço para detectar ela?

Uso o Debian 9.5

Abraços


Possivelmente você está carregando drivers nvidia, deve bloquea-los adicionando o nome deles ao blacklist.
Pra indentificar os drivers carregados:
lsmod |grep -i ^nv

Exemplificando um bloqueio de modulo:
echo "blacklist nvidia" >> /etc/modprobe.d/blacklist.conf
Pode ser necessário desinstalar algum aplicativo da empresa se você usava o driver proprietário também, depois disso, e um reboot a radeon pode detectar corretamente ou você começa a novela de baixar um driver proprietário da empresa e instalar no seu kernel.
O que depende muito do seu modelo de placa e instruções do fabricante.



3. Re: Mudar placa de vídeo com sistema já instalado.

Alexandre Martins da Cunha
alexandremc

(usa Debian)

Enviado em 07/11/2018 - 21:16h

pbonfanti escreveu:

alexandremc escreveu:

Boa noite pessoal;

Eu tenho uma placa onboard HD 630 e uma placa offboard NVIDIA 550TI.

Bom instalei o sistema com a 550tTi e o sistema usou o driver NOVEAU, tudo ok, mas precisei trocar a placa, como estou sem grana usei a onboard.

Se eu removo a placa da NVIDIA e deixo a onboard, o servidor X não carrega.

Tentei tudo que sei, criar arquivo no xorg.conf e nada.

Existe um procedimento para isso?

Comprei uma placa nova, supondo AMD Radeon, como faço para detectar ela?

Uso o Debian 9.5

Abraços


Possivelmente você está carregando drivers nvidia, deve bloquea-los adicionando o nome deles ao blacklist.
Pra indentificar os drivers carregados:
lsmod |grep -i ^nv

Exemplificando um bloqueio de modulo:
echo "blacklist nvidia" >> /etc/modprobe.d/blacklist.conf
Pode ser necessário desinstalar algum aplicativo da empresa se você usava o driver proprietário também, depois disso, e um reboot a radeon pode detectar corretamente ou você começa a novela de baixar um driver proprietário da empresa e instalar no seu kernel.
O que depende muito do seu modelo de placa e instruções do fabricante.


Por exemplo to usando a placa onboard intel 630.

Se eu trocar e colocar a 550Ti de novo, ele não detecta o hardware automaticamente, como faço para isso acontecer?

Abraços





4. Mudar placa de vídeo com sistema já instalado.

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 08/11/2018 - 17:50h

Normalmente entra a placa onde está conectado o cabo VGA, ou HDMI, ou DVI.
Mesmo com um driver errado entra uma imagem em baixa resolução que é horrível.

O mais sensato seria desinstalar o driver da placa a ser removida, desligar, remover a placa, passar o cabo de vídeo
para a outra placa e religar.

Deveria aparecer um imagem ruim em baixa resolução.

Se não aparecer precisa entrar na configuração da BIOS. Há BIOS que tem configurações
complicadas envolvendo a On board e a off board porque elas suportam dois monitores de
forma independente.
Com configuração de BIOS inadequada não aprece imagem nenhuma, não adianta ralar o X,
nem usar o Livro Negro de reza braba.

Os drivers da minha radeon são:
xserver-xorg-video-radeon
xserver-xorg-video-ati
xserver-xorg-video-amdgpu

estão todos no repositório do ubuntu e por tabela do Debian também.



5. Re: Mudar placa de vídeo com sistema já instalado.

Alexandre Martins da Cunha
alexandremc

(usa Debian)

Enviado em 08/11/2018 - 19:16h

nicolo escreveu:

Normalmente entra a placa onde está conectado o cabo VGA, ou HDMI, ou DVI.
Mesmo com um driver errado entra uma imagem em baixa resolução que é horrível.

O mais sensato seria desinstalar o driver da placa a ser removida, desligar, remover a placa, passar o cabo de vídeo
para a outra placa e religar.

Deveria aparecer um imagem ruim em baixa resolução.

Se não aparecer precisa entrar na configuração da BIOS. Há BIOS que tem configurações
complicadas envolvendo a On board e a off board porque elas suportam dois monitores de
forma independente.
Com configuração de BIOS inadequada não aprece imagem nenhuma, não adianta ralar o X,
nem usar o Livro Negro de reza braba.

Os drivers da minha radeon são:
xserver-xorg-video-radeon
xserver-xorg-video-ati
xserver-xorg-video-amdgpu

estão todos no repositório do ubuntu e por tabela do Debian também.


Então sei que não é da BIOS, pq eu instalado do zero ele reconhece.

A pergunta seria ao remoer um placa como fazer o sistema re-detectar o driver e vídeo.



6. Re: Mudar placa de vídeo com sistema já instalado.

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 08/11/2018 - 19:21h

alexandremc escreveu:

Boa noite pessoal;

Eu tenho uma placa onboard HD 630 e uma placa offboard NVIDIA 550TI.

Bom instalei o sistema com a 550tTi e o sistema usou o driver NOVEAU, tudo ok, mas precisei trocar a placa, como estou sem grana usei a onboard.

Se eu removo a placa da NVIDIA e deixo a onboard, o servidor X não carrega.

Tentei tudo que sei, criar arquivo no xorg.conf e nada.

Existe um procedimento para isso?

Comprei uma placa nova, supondo AMD Radeon, como faço para detectar ela?

Uso o Debian 9.5

Abraços


Olha tenbho em mente que para vc usar a onboard, depois de tirar a NVIDIA offboard queimada, vc precisdaria remover o nouveau e reinstalá-lo, para que o nouveau use a onboard.

quanto à placa nova, bom vc desligou o micro, instalou a placa etc.... vc diz ela é uma ATI. remova o nouveau, senão ele vai chamar a onboard (nouveau é só para as nvidia)

para as ATI, os drivers proprietários da ATI não funcionam bem com os kerneis e xorgs mais novos. Os drivers melhores são os free.

Os pacotes dos drivers em Sabayon (esta é uma AMD ATI, neste micro) são: o xf86-video-ati , amdgpu-pro-opencl e xf86-video-amdgpu Em outros Linux, devem ter nome parecido....

quanto a ter ou não xorg.conf, eu uso.... se vc mudar a placa sua onboard para uma ATI, terá de editar o xorg.conf. Par que te sirva de base, este é o arquivo /etc/X11/xorg.conf deste micro, com sabayon linux e uma ATI off board:


sudo cat /etc/X11/xorg.conf
Senha:
# Arquivo /etc/X11/xorg.conf
# Modificado por: albfneto <albfneto@fcfrp.usp.br>
# Esta é a última versão, funcionando, para configurar a placa de vídeo
# AMD ATI, de um Phenon Bulldozer.

Section "Files"
ModulePath "/usr/lib64/xorg/modules"
ModulePath "/usr/lib64/opengl/xorg-x11/extensions/"
EndSection

Section "Module"
SubSection "extmod"
Option "omit xfree86-dga"
Option "DRI" "3"
EndSubSection
Load "i2c"
Load "ddc"
Load "vbe"
Load "dri"
Load "glx"
Load "synaptics"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
VertRefresh 43 - 60
HorizSync 28 - 80
EndSection

Section "Screen"
Identifier "Screen"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

# Driver parta AMD GPU, descomente para usar:
#Section "Device"
# Identifier "AMD"
# Driver "amdgpu"
#EndSection

# Driver free para ATI, primária, pacote é xf86-video-ati:
Section "Device"
Identifier "ATI Video"
driver "radeon"
# BusID "PCI:02:00.0"
Option "SwapbuffersWait" "false"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "ServerLayout"
Identifier "Main Layout"
EndSection

Section "Extensions"
Option "Composite" "Enable"
Option "AccelMethod" "glamor"
EndSection

# Mouse com varios botoes, driver evdev
# Section "InputDevice"
# Identifier "USB Optical Mouse"
# Driver "evdev"
# Option "Name" "USB Optical Mouse"
#EndSection

# Mouse varios botões:
Section "InputDevice"
Identifier "USB Optical Mouse"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/input/mice"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
EndSection


Note que eu tenho outras coisas como mouse de múltiplos botões.

¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.






Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts