Wifi do meu Debian 9 não funciona (firmware)

1. Wifi do meu Debian 9 não funciona (firmware)

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 27/04/2018 - 08:23h

Boas pessoal, meu primeiro tópico aqui no Viva o Linux.

Bom, vou detalhar o problema que estou enfrentando:

Já tentei instalar o Debian 9 NetInstall com firmware nom-free por diversas vezes. Não instalo nenhum ambiente gráfico, nem mesmo o ambiente do Debian (primeira opção). Só o mínimo possível. É que quero instalar o OpenBox e deixar um ambiente simples para meu uso.
Na instalação ele pede o firmware em alguma mídia, como eu não tenho eu pulo esta opção, então no firmware do CD (Pendrive) ele enxerga duas interface, com fio (realteck) e o sem fio wifi Qualcomm Atheros. Como aqui em casa eu só tenho acesso ao wifi, escolho a segunda opção (Qualcomm Atheros) e ele identifica e executa normalmente, escolho a identificação, coloco a senha e continuo a instalação. Depois ele baixa todos os pacotes necessários sem nenhum problema.
Depois do Debian instalado (só o básico), reinicio o sistema e me pede login e senha (entro logo como root).

apt-get update
aparece um monte de falhas, ou seja, não encontra a internet.

Já tentei seguir um monte de tutorial na internet e sem sucesso. Baixei os firmwares .deb, dei o comando # update-initramfs -u (reiniciei e nada)
Engraçado que pela instalação ele entra sem problema. Tentei ifconfig wlan0 up (wlan0, eth1, etc...), diz que o ifconfig não existe (não está instalado).
Fui instalar o pacote deb buildessentials.deb e ficou com um monte de dependências (falta o make, g++, gcc, e outros) Não tenho internet.

pacotes que baixei no site do Debian referente ao firmware:

firmware-atheros_20161130-3_all.deb
firmware-realtek_20161130-3_all.deb
firmware-samsung_20161130-3_all.deb (meu notebook é um samsung essentials NP300E5M-KFABR)

...e nenhum, depois de instalado, e reiniciado, funciona! MISTÉRIO isso....

Instalei o Gnome (ambiente gráfico) funcionou a internet wifi
Reinstalei novamente (agora) com o xfce e funcionou também...
Só que não quero nenhuma interface gráfica nem este monte de arquivo. Quero instalar o OpenBox e deixar ele enxuto. Se minha ifi funcionar eu tenho todo tempo do mundo para instalar e configurar cada coisa que preciso, mas sem internet o notebook não serve pra nada.

Preciso de ajuda.
Algumas configurações do computador antes que me peçam:

lspci
00:00.0 Host bridge: Intel Corporation Device 5904 (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Device 5906 (rev 02)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d50 (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

Kernel instalado: 4.9.0-6-amd64
Sistema: Debian 9

Valeu pessoal, espero que possam me ajudar com esse problema.
Agradeço.









  


2. Re: Wifi do meu Debian 9 não funciona (firmware)

LinuxWalker
Delusion

(usa Fedora)

Enviado em 27/04/2018 - 09:30h

rdaguiar escreveu:
Instalei o Gnome (ambiente gráfico) funcionou a internet wifi
Reinstalei novamente (agora) com o xfce e funcionou também...
Só que não quero nenhuma interface gráfica nem este monte de arquivo. Quero instalar o OpenBox e deixar ele enxuto. Se minha ifi funcionar eu tenho todo tempo do mundo para instalar e configurar cada coisa que preciso, mas sem internet o notebook não serve pra nada.


se vc quer ativar a sua rede wifi, após instalação do mínimo e reboot, invoque as seguintes palavras mágicas:

ip a
iwconfig
ip link set nomedasuainterfacederede up
wpa_supplicant -B -i nomedasuainterfacederede -c <(wpa-passphase nomedarede senha)
dhclient nomedasuainterfacederede

fonte: https://wiki.debian.org/WiFi/HowToUse
Existem outras formas, mas essa é a que acho mais fácil.
A propósito, não é necessário usar mídia nonfree para ter poderes de super-vaca.
tenha um bom e produtivo dia!

Linux User # 624552


3. Re: Wifi do meu Debian 9 não funciona (firmware)

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 27/04/2018 - 11:18h

Desculpe, meu conhecimento é pouco, os comandos:

# ip a:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp1s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether 98:83:89:71:71:e4 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether f8:28:19:9f:d1:59 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.10/24 brd 192.168.0.255 scope global dynamic wlp2s0
valid_lft 601091sec preferred_lft 601091sec
inet6 fe80::fa28:19ff:fe9f:d159/64 scope link
valid_lft forever preferred_lft forever

# iwconfig:

lo no wireless extensions.

enp1s0 no wireless extensions.

wlp2s0 IEEE 802.11 ESSID:"NET VIRTUA 17A"
Mode:Managed Frequency:2.462 GHz Access Point: 28:BE:9B:66:12:9C
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
Link Quality=49/70 Signal level=-61 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:26 Invalid misc:250 Missed beacon:0

...então, como faço?

ip link set nomedasuainterfacederede up
wpa_supplicant -B -i nomedasuainterfacederede -c <(wpa-passphase nome_da_rede senha)
dhclient wlp3s0


(Me dá um exemplo) Em: wpa-passphase nome_da_rede senha


Grato.




4. Re: Wifi do meu Debian 9 não funciona (firmware)

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 27/04/2018 - 12:09h

Olha só como faço aqui

depois do netinst instalado, instalo firmware, escrevo no wpa_supplicante, reinicio, chamo o wpa_supplicant e mando um dhclient.

no seu caso:

#dpkg -i /caminho/do/pacote/firmware-atheros_20161130-3_all.deb 
NOTA: em alguns casos o firmware está incluso no pacote "firmware-linux-free", nesse caso não precisa instalar nada não !!!


#echo "wpa_passphrase SSID SENHA" > /etc/wpa_supplicant/rede.cfg && reboot 


#wpa_supplicant -i wlp1s0 -D wext -c /etc/wpa_supplicant/rede.cfg -B 
NOTA: pode ser q mostre algum erro aqui, mas nada relevante !!


#dhclient wlp1s0 



------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



5. Re: Wifi do meu Debian 9 não funciona (firmware)

LinuxWalker
Delusion

(usa Fedora)

Enviado em 27/04/2018 - 23:38h

rdaguiar escreveu:
...


boa noite.
suponhamos que o nome da rede seja: malditawifi e a senha seja 1234
então no seu caso os comandos seriam:

ip link set wlp2s0 up
wpa_supplicant -B -i wpa_supplicant -B -i wlp2s0 -c <(wpa-passphase malditawifi 1234)
dhclient wlp2s0

obs.1: toda vez que vc reiniciar em modo texto vai ter de fazer os 2 últimos passos pra conectar. Quando instalar ambiente gráfico já é outra estória.
obs.2: parece complicado, mas ta lá na wiki que eu te passei.

Linux User # 624552


6. Re: Wifi do meu Debian 9 não funciona (firmware)

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 28/04/2018 - 11:49h

Pessoal, reinstalei tudo e tentei fazer e não consegui. Ontem a noite tive que reinstalar novamente com o xfce para poder acessar a web e vi esta última menagem. Grato pelas respostas. Vou estudar mais para poder executar uma nova instalação e tentar novamente... por enquanto vou ficar no xfce até segunda-feira para comprar um pendrive maior e instalar o Debian 9 live - com firmware para, caso der errado, poder acessar a internet pelo live-cd. Meu pendrive é antigo de apenas 1 GB e não cabe a imagem que é de 2.3 GB (tenho de tomar vergonha e comprar um de pelo menos 4 GB que é baratinho).
De qualquer forma, olhando este último tópico creio que vai dar certo.

valeu e agradeço pela contribuição de todos.


7. Re: Wifi do meu Debian 9 não funciona (firmware)

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 28/04/2018 - 13:00h

no meu ideapad veio uma atheros também conforme abaixo
02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 30)

aqui reconheceu apenas instalando firmware-atheros, mas usei a instalação via cabo depois reiniciei sem o cabo e apenas precisei entrar na rede wi-fi, mas estou usando xfce com debian testing/buster.


8. Re: Wifi do meu Debian 9 não funciona (firmware)

LinuxWalker
Delusion

(usa Fedora)

Enviado em 28/04/2018 - 15:25h

quando eu ainda era meio pé atrás com o ramo "testing" do Debian, eu abri uma partição de 20G e fui fazendo lambança com meu debian testing enquanto tinha meu Debian-stable na outra. Rodei por tudo que é wm, usei o repo experimental por um tempo (esse sim é hardcore :P), talvez seja um caminho que vc também queira fazer.

Linux User # 624552


9. Re: Wifi do meu Debian 9 não funciona (firmware)

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 06/06/2018 - 19:43h

Quando há um espaço como colocar?

Por exemplo:

<(wpa-passphase NET VIRTUA 17A senha)

no que você passou foi:

<(wpa-passphase malditawifi 1234)

Ok, mas é um nome só, no caso acima é "NET VIRTUA 17A" (sem as aspas), coloco como?


10. Re: Wifi do meu Debian 9 não funciona (firmware)

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 06/06/2018 - 19:52h

rdaguiar escreveu:

Quando há um espaço como colocar?

Por exemplo:

<(wpa-passphase NET VIRTUA 17A senha)

no que você passou foi:

<(wpa-passphase malditawifi 1234)

Ok, mas é um nome só, no caso acima é "NET VIRTUA 17A" (sem as aspas), coloco como?


com espaço nunca fiz não, mas é uma de vc ir pelo padrão ... coloque o nome ente aspas .. kkk ... do jeito que vc escreveu aqui !!!


------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



11. Re: Wifi do meu Debian 9 não funciona (firmware)

Gabriel Moreira
GabrielMS86

(usa Arch Linux)

Enviado em 06/06/2018 - 20:02h

No meu Ideapad só funcionou com kernel mais novo.
Debian Testing conectou tranquilo dps de instalar o firmware.
Arch também sem problemas.
Debian 9 deu ruim no wifi.
Está melhor a partir da série 4.15 de kernel.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts