[Pop!_OS] postgreSQL e pgAdmin4 no Pop!_OS, como instalar as dependencias?

1. [Pop!_OS] postgreSQL e pgAdmin4 no Pop!_OS, como instalar as dependencias?

ricardo
rxtheodoro

(usa Linux Mint)

Enviado em 02/11/2020 - 02:41h

Estou tentando instalar o postgresql e o pgAdmin4 no Pop!_OS 20.1.

Primeiro, tentei esses tutoriais, apenas copiando e colando o código no terminal:
```
https://www.postgresql.org/download/linux/ubuntu/
https://www.pgadmin.org/download/pgadmin-4-apt/
```
Mas estava dando algum erro na hora de adicionar os repositórios. Não consegui resolver.

Então, segui esse tutorial aqui: `https://wiki.postgresql.org/wiki/Apt`

Mas agora, ele diz que faltam algumas dependências. Como posso resolver?

```
[email protected]:~$ sudo apt install postgresql pgadmin4
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
pgadmin4 : Depende: libpython3.7 (>= 3.7.0) mas não é instalável
postgresql-13 : Depende: libicu63 (>= 63.1-1~) mas não é instalável
Depende: libllvm7 (>= 1:7~svn298832-1~) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
```


  


2. Re: [Pop!_OS] postgreSQL e pgAdmin4 no Pop!_OS, como instalar as dependencias?

ricardo
rxtheodoro

(usa Linux Mint)

Enviado em 02/11/2020 - 02:59h

Descobri onde está o erro!

Nos tutoriais, ele diz:
sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt $(lsb_release -cs)-pgdg main" > /etc/apt/sources.list.d/pgdg.list'
e
sudo sh -c 'echo "deb https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/$(lsb_release -cs) pgadmin4 main" > /etc/apt/sources.list.d/pgadmin4.list && apt update'

Mas $(lsb_release -cs) puxa a palavra “groovy”, quando na verdade é pra ser “focal”

Alterei isso e consegui instalar aqui.