E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

1. E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

VICTOR LUCAS SOARES FREITAS
vlucas981

(usa Linux Mint)

Enviado em 29/03/2020 - 16:48h

Boa tarde galera.

Estou com um problema no Linux Mint (Tricia) 19.3, sem solução.
Recentemente tentei instalar o Wine, somente para rodar o Winbox, entretanto me apresentou um erro na instalação.
Imagino que o problema não seja na instalação do Wine, ou dos pacotes que tento instalar, mas sim da porcaria de um pacote chamado Libidn2-0.

A saída do apt updade:
Ign:1 http://mint-packages.c3sl.ufpr.br tricia InRelease                       
Atingido:2 http://linux.teamviewer.com/deb stable InRelease
Atingido:3 http://mint-packages.c3sl.ufpr.br tricia Release
Atingido:5 http://archive.ubuntu.com/ubuntu bionic InRelease
Obter:6 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Obter:7 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Atingido:8 http://archive.canonical.com/ubuntu bionic InRelease
Obter:9 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Atingido:10 http://packages.microsoft.com/repos/vscode stable InRelease
Ign:11 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:12 http://dl.google.com/linux/chrome/deb stable Release
Atingido:14 https://packages.sury.org/php stretch InRelease
Obter:16 https://mega.nz/linux/MEGAsync/xUbuntu_18.04 ./ InRelease [1.310 B]
Atingido:15 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease
Baixados 253 kB em 14s (17,5 kB/s)
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
1 package can be upgraded. Run 'apt list --upgradable' to see it.


Ele informar que tem 1 pacote para atualizar.
Quando rodo o apt list --upgradable, a saída apresentada é a seguinte:

Listing... Pronto
libidn2-0/unknown 2.2.0-2+0~20200302.4+debian9~1.gbpf85c2e amd64 [upgradable from: 2.0.4-1.1ubuntu0.2]
N: There are 2 additional versions. Please use the '-a' switch to see them.


Rodando um apt upgrade ou dist-upgrade, não atualiza o pacote.
Já tentei diversas soluções encontradas aqui no fórum e em outros lugares, entretanto não solucionaram o problema.
Quando tento solucionar utilizando o Synaptics, ele chega a encontrar uma solução
Rodando o comando apt remove libidn2-0, ele me apresenta uma saída preocupante quanto ao funcionamento do sistema, e me faz desistir de remover o mesmo

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
apache2-data cabextract chromium-codecs-ffmpeg-extra gconf2-common
gedit-common git-man gstreamer1.0-plugins-ugly gstreamer1.0-vaapi
liba52-0.7.4 libaprutil1-dbd-sqlite3 libaribb24-0 libavcodec-extra
libbamf3-2 libbasicusageenvironment1 libcddb2 libcrypto++6 libdbusmenu-gtk4
libdca0 libde265-0 libdvbpsi10 libebml4v5 liberror-perl libfaad2
libfluidsynth1 libgconf-2-4 libgroupsock8 libgstreamer-plugins-bad1.0-0
libhal1-flash libilmbase12 libkate1 liblilv-0-0 liblivemedia62 libmad0
libmatroska6v5 libmicrodns0 libmjpegutils-2.1-0 libmms0 libmodplug1
libmpcdec6 libmpeg2-4 libmpeg2encpp-2.1-0 libmplex2-2.1-0 libmspack0
libnfs11 libofa0 libopenexr22 libopenmpt-modplug1 libplacebo4
libplank-common libprotobuf-lite10 libqt5positioning5 libqt5qml5
libqt5quick5 libqt5sensors5 libqt5webchannel5 libqt5x11extras5 libraw16
libresid-builder0c2a libsdl-image1.2 libsdl1.2debian libserd-0-0
libsidplay1v5 libsidplay2 libsord-0-0 libsoundtouch1 libspandsp2
libsratom-0-0 libsrtp2-1 libssh2-1 libtinyxml2-6 libunshield0 libupnp6
libusageenvironment3 libvlc-bin libvlc5 libvlccore9 libvo-aacenc0 libvulkan1
libwildmidi-config libwildmidi2 libwxbase3.0-0v5 libxmlb1 libzbar0 libzen0v5
qml-module-qtgraphicaleffects qml-module-qtquick-controls
qml-module-qtquick-dialogs qml-module-qtquick-layouts
qml-module-qtquick-privatewidgets qml-module-qtquick-window2
qml-module-qtquick2 unrar unshield vlc-bin vlc-data vlc-plugin-qt
vlc-plugin-video-output
Utilize 'sudo apt autoremove' para os remover.
The following additional packages will be installed:
foomatic-filters php7.2-fpm php7.4-fpm
Pacotes recomendados:
cups-client | lpr | lprng | rlpr ghostscript paps | cups | enscript | a2ps
colord
Os pacotes a seguir serão REMOVIDOS:
add-apt-key adobe-flashplugin apache2 apache2-bin apt apt-transport-https
apt-utils apturl apturl-common bamfdaemon baobab blueberry bluez-cups
ca-certificates-java caribou celluloid cinnamon cinnamon-common
cinnamon-control-center cinnamon-control-center-dbg cinnamon-dbg
cinnamon-screensaver cinnamon-session cinnamon-settings-daemon cjs code cups
cups-browsed cups-bsd cups-client cups-core-drivers cups-daemon cups-filters
cups-filters-core-drivers cups-ipp-utils cups-pk-helper cups-ppdc
default-jre default-jre-headless dirmngr drawing evolution-data-server
ffmpegthumbnailer file-roller firefox flatpak fwupd fwupd-signed fwupdate
fwupdate-signed gconf-service gconf-service-backend gconf2 gcr gdebi
gdebi-core gedit geoclue-2.0 ghostscript ghostscript-x
gir1.2-appindicator3-0.1 gir1.2-caribou-1.0 gir1.2-cinnamondesktop-3.0
gir1.2-clutter-1.0 gir1.2-clutter-gst-3.0 gir1.2-flatpak-1.0 gir1.2-gkbd-3.0
gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-gtk-3.0
gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0 gir1.2-keybinder-3.0
gir1.2-matedesktop-2.0 gir1.2-matepanelapplet-4.0 gir1.2-meta-muffin-0.0
gir1.2-nemo-3.0 gir1.2-networkmanager-1.0 gir1.2-nm-1.0 gir1.2-nma-1.0
gir1.2-peas-1.0 gir1.2-rb-3.0 gir1.2-soup-2.4 gir1.2-timezonemap-1.0
gir1.2-vte-2.91 gir1.2-webkit2-4.0 gir1.2-wnck-3.0 gir1.2-xapp-1.0 git
gkbd-capplet glib-networking gnome-bluetooth gnome-calculator gnome-calendar
gnome-disk-utility gnome-font-viewer gnome-keyring gnome-logs
gnome-online-accounts gnome-orca gnome-power-manager gnome-screenshot
gnome-session-bin gnome-session-canberra gnome-settings-daemon
gnome-system-monitor gnome-terminal gnote gnupg google-chrome-stable gparted
gpg-wks-client gstreamer1.0-clutter-3.0 gstreamer1.0-libav
gstreamer1.0-plugins-bad gstreamer1.0-plugins-good gucharmap gufw hexchat
ideviceinstaller ifuse kerneloops libapache2-mod-php libapache2-mod-php7.2
libapache2-mod-php7.4 libappindicator1 libappindicator3-1 libappstream-glib8
libaprutil1-ldap libavdevice57 libavfilter6 libavformat57
libblockdev-crypto2 libcanberra-gtk3-0 libcanberra-gtk3-module libcaribou0
libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcinnamon-control-center1
libcinnamon-desktop-dbg libcinnamon-desktop4 libcjs-dbg libcjs0f
libclutter-1.0-0 libclutter-gst-3.0-0 libclutter-gtk-1.0-0 libcmis-0.5-5v5
libcodeblocks0 libcscreensaver0 libcups2 libcupscgi1 libcupsfilters1
libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3 libcurl3-gnutls
libdazzle-1.0-0 libdmapsharing-3.0-2 libebackend-1.2-10 libebook-1.2-19
libebook-contacts-1.2-2 libecal-1.2-19 libedata-book-1.2-25
libedata-cal-1.2-28 libedataserver-1.2-23 libedataserverui-1.2-2
libffmpegthumbnailer4v5 libflatpak0 libfwupd2 libgail-3-0 libgail-common
libgail18 libgcr-ui-3-1 libgdata22 libgeoclue-2-0 libgeocode-glib0
libglade2-0 libgnome-bluetooth13 libgnome-desktop-3-17 libgnomekbd8
libgnutls30 libgoa-backend-1.0-1 libgpod-common libgpod4 libgrilo-0.3-0
libgs9 libgspell-1-1 libgssdp-1.0-3 libgtk-3-0 libgtk-3-bin libgtk2-perl
libgtk2.0-0 libgtk2.0-bin libgtk3-perl libgtkmm-2.4-1v5 libgtkmm-3.0-1v5
libgtksourceview-3.0-1 libgucharmap-2-90-7 libgupnp-1.0-4 libgupnp-igd-1.0-4
libgweather-3-15 libidn2-0 libimobiledevice-utils libimobiledevice6
libindicator3-7 libindicator7 libkeybinder-3.0-0 libldap-2.4-2 libldb1
libmate-desktop-2-17 libmate-panel-applet-4-1 libmateweather1
libmediainfo0v5 libmetacity1 libmpv1 libmuffin0 libmusicbrainz5-2
libmusicbrainz5cc2v5 libnautilus-extension1a libnemo-extension1
libneon27-gnutls libnice10 libnm-glib4 libnm-util2 libnm0 libnma0 liboauth0
libostree-1-1 libpeas-1.0-0 libpeas-1.0-python2loader libplank1 libpq5
libpsl5 libqt5printsupport5 libqt5webkit5 libraptor2-0 librasqal3 librdf0
libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
libreoffice-base-drivers libreoffice-calc libreoffice-core libreoffice-draw
libreoffice-gnome libreoffice-gtk3 libreoffice-help-de
libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-es
libreoffice-help-fr libreoffice-help-it libreoffice-help-pt
libreoffice-help-pt-br libreoffice-help-ru libreoffice-help-zh-cn
libreoffice-help-zh-tw libreoffice-impress libreoffice-math
libreoffice-ogltrans libreoffice-pdfimport libreoffice-sdbc-hsqldb
libreoffice-writer librest-0.7-0 librhythmbox-core10 librtmp1 libsane-hpaio
libsmbclient libsnapd-glib1 libsoup-gnome2.4-1 libsoup2.4-1 libspectre1
libtimezonemap1 libvolume-key1 libvte-2.91-0 libwebkit2gtk-4.0-37
libwnck-3-0 libwxgtk3.0-0v5 libxapp1 libxreaderdocument3 libxreaderview3
libyelp0 linuxmint-keyring mate-desktop mate-panel mate-polkit megasync
metacity mint-common mint-meta-cinnamon mint-meta-codecs mint-meta-core
mintbackup mintdrivers mintinstall mintlocale mintmenu mintreport
mintsources mintstick mintsystem mintupdate mintwelcome mousetweaks muffin
muffin-dbg nemo nemo-dbg nemo-emblems nemo-fileroller nemo-preview
nemo-share network-manager network-manager-config-connectivity-ubuntu
network-manager-gnome network-manager-openvpn network-manager-openvpn-gnome
network-manager-pptp network-manager-pptp-gnome ntfs-3g nvidia-prime-applet
onboard openjdk-11-jre openjdk-11-jre-headless orca php7.2-curl php7.2-pgsql
php7.4-pgsql pinentry-gnome3 pix pix-dbg plank policykit-1-gnome postgresql
postgresql-10 postgresql-client-10 printer-driver-brlaser
printer-driver-c2esp printer-driver-foo2zjs printer-driver-gutenprint
printer-driver-hpcups printer-driver-m2300w printer-driver-pnm2ppa
printer-driver-ptouch printer-driver-sag-gdi printer-driver-splix python-apt
python-glade2 python-gtk2 python-ldb python-nemo python-samba
python3-aptdaemon.gtk3widgets python3-cups python3-cupshelpers
python3-pycurl python3-uno qt5-gtk-platformtheme qt5-style-plugins
redshift-gtk rhythmbox rhythmbox-plugin-tray-icon rhythmbox-plugins
samba-common-bin samba-libs seahorse sessioninstaller slack-desktop
slick-greeter smbclient software-properties-common ssh-askpass-gnome
synaptic system-config-printer system-config-printer-common
system-config-printer-gnome system-config-printer-udev teamviewer
thunderbird thunderbird-gnome-support thunderbird-locale-en
thunderbird-locale-en-us thunderbird-locale-pt thunderbird-locale-pt-br
timeshift transmission-gtk ubuntu-minimal ubuntu-system-adjustments upower
usbmuxd vlc vlc-plugin-base wget xdg-desktop-portal-gtk xdg-user-dirs-gtk
xed xed-dbg xreader xreader-dbg xul-ext-lightning xviewer xviewer-dbg
xviewer-plugins yelp zenity
Os NOVOS pacotes a seguir serão instalados:
foomatic-filters php7.2-fpm php7.4-fpm
AVISO: Os pacotes essenciais a seguir serão removidos.
Isso NÃO deveria ser feito a menos que você saiba exatamente o que você está fazendo!
apt libgnutls30 (por causa de apt) mintsources
python3-pycurl (por causa de mintsources)
mint-common (por causa de mintsources)
gir1.2-gtk-3.0 (por causa de mintsources)
gir1.2-vte-2.91 (por causa de mintsources)
gir1.2-xapp-1.0 (por causa de mintsources)
0 pacotes atualizados, 3 pacotes novos instalados, 407 a serem removidos e 0 não atualizados.
É preciso baixar 2.887 kB de arquivos.
Depois desta operação, 2.504 MB de espaço em disco serão liberados.
Você está prestes a fazer algo potencialmente destrutivo.
Para continuar digite a frase 'Sim, faça o que eu digo!'


Já procurei possíveis causas e soluções, porém nenhuma conseguiu solucionar o problema.
Alguém com maior experiência poderia me ajudar?






  






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts