libreoffice 4.1 [RESOLVIDO]

1. libreoffice 4.1 [RESOLVIDO]

Paulo Edson
pauloedson

(usa Ubuntu)

Enviado em 20/12/2013 - 14:09h

gente,

no DEBIAN 7.3, adicionei a seguinte linha no sources.list

deb http://ftp.br.debian.org/debian wheezy-backports main

pois bem, após o "apt-get update", no terminal, digitei => apt-get -t squeeze-backports install libreoffice-writer

ocorre que, em seguida, surge a seguinte mensagem de erro:

O valor 'squeeze-backports' é inválido para APT::Default-Release porque tal lançamento não está disponível nas fontes

-------------------------

portanto, o que pode ser feito para eu instalar o writer 4.1?


  


2. MELHOR RESPOSTA

Glauber GF
mcnd2

(usa Debian)

Enviado em 20/12/2013 - 17:06h

pauloedson escreveu:

rei astro, eu prefiro nao usar os repositórios testing, e, sim, os stable mesmo!

-----------------------

mas estive analisando melhor as linhas de codigo e percebi o seguinte:

o source.list contem => deb http://ftp.br.debian.org/debian wheezy-backports main

porém, a linha para instalar o writer contem => apt-get -t squeeze-backports install libreoffice-writer

ou seja, o repositório contem "wheezy-backports" e a linha para instalação contem "squeeze-backports". nao será esse o problema de tudo?!


Isso mesmo Paulo.

Você adicionou o backports do wheezy e no comando você chamou o squeezy!

O comando seria:

apt-get -t wheezy-backports install libreoffice



Exemplo se eu fosse instalar aqui no meu sistema Debian:

[email protected]: [/home/mcnd2]
>>> # apt-get -t wheezy-backports install libreoffice
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Os pacotes extra a seguir serão instalados:
fonts-lyx fonts-opensymbol fonts-stix libboost-date-time1.49.0 libcolamd2.7.1 libexttextcat-data libexttextcat0 libhsqldb-java libhyphen0 libmythes-1.2-0 libreoffice-base
libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-impress libreoffice-java-common libreoffice-math
libreoffice-report-builder-bin libreoffice-style-galaxy libreoffice-writer libservlet2.5-java libvisio-0.0-0 libwpd-0.9-9 libwpg-0.2-2 libwps-0.2-2 lp-solve python-uno uno-libs3 ure
xfonts-mathml
Pacotes sugeridos:
libhsqldb-java-doc libhsqldb-java-gcj hunspell-dictionary hyphen-hyphenation-patterns imagemagick graphicsmagick-imagemagick-compat libreoffice-gnome libreoffice-kde
libreoffice-grammarcheck libreoffice-help-4.1 libreoffice-l10n-4.1 mythes-thesaurus openclipart-libreoffice pstoedit libreoffice-officebean libmyodbc odbc-postgresql libsqliteodbc
tdsodbc mdbtools libmysql-java libpg-java libjtds-java libreoffice-gcj libreoffice-report-builder libreoffice-style-crystal libreoffice-style-hicontrast libreoffice-style-oxygen
libreoffice-style-tango bluez
Os pacotes a seguir serão REMOVIDOS:
libreoffice-debian-menus
Os NOVOS pacotes a seguir serão instalados:
fonts-lyx fonts-opensymbol fonts-stix libboost-date-time1.49.0 libcolamd2.7.1 libexttextcat-data libexttextcat0 libhsqldb-java libhyphen0 libmythes-1.2-0 libreoffice
libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-impress libreoffice-java-common libreoffice-math
libreoffice-report-builder-bin libreoffice-style-galaxy libreoffice-writer libservlet2.5-java libvisio-0.0-0 libwpd-0.9-9 libwpg-0.2-2 libwps-0.2-2 lp-solve python-uno uno-libs3 ure
xfonts-mathml
0 pacotes atualizados, 33 pacotes novos instalados, 1 a serem removidos e 31 não atualizados.
É preciso baixar 92,2 MB de arquivos.
Depois desta operação, 276 MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]?


Como já tenho ele instalado do pacote que baixei direto do site, não fiz o uso da instalação.

...

3. Re: libreoffice 4.1 [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 20/12/2013 - 14:16h

bom tu podes baixar direto do site e instalar manualmente o Libreoffice


4. Re: libreoffice 4.1 [RESOLVIDO]

Paulo Edson
pauloedson

(usa Ubuntu)

Enviado em 20/12/2013 - 15:55h

fera, o problema de instalar manualmente são as "dependências"
eu baixei o LibreOffice_4.1.4_Linux_x86-64_deb.tar.gz
mas ele pede algumas dependências que impossibilitam a instalação

mais alguma saida?!


5. Re: libreoffice 4.1 [RESOLVIDO]

Luis R. C. Silva
luisrcs

(usa Linux Mint)

Enviado em 20/12/2013 - 15:58h

Use o repositório testing do Debian

deb http://ftp.debian.org/debian testing main contrib non-free

Atualize o apt e instale.


6. Re: libreoffice 4.1 [RESOLVIDO]

Luis R. C. Silva
luisrcs

(usa Linux Mint)

Enviado em 20/12/2013 - 15:59h

rei_astro escreveu:

Use o repositório testing do Debian

deb http://ftp.debian.org/debian testing main contrib non-free

Atualize o apt e instale.


Se quiser pode atualizar todo o sistema para testing, com:

# apt-get dist-upgrade


7. Re: libreoffice 4.1 [RESOLVIDO]

Paulo Edson
pauloedson

(usa Ubuntu)

Enviado em 20/12/2013 - 16:16h

rei astro, eu prefiro nao usar os repositórios testing, e, sim, os stable mesmo!

-----------------------

mas estive analisando melhor as linhas de codigo e percebi o seguinte:

o source.list contem => deb http://ftp.br.debian.org/debian wheezy-backports main

porém, a linha para instalar o writer contem => apt-get -t squeeze-backports install libreoffice-writer

ou seja, o repositório contem "wheezy-backports" e a linha para instalação contem "squeeze-backports". nao será esse o problema de tudo?!


8. Re: libreoffice 4.1 [RESOLVIDO]

Paulo Edson
pauloedson

(usa Ubuntu)

Enviado em 20/12/2013 - 16:22h

acerca de repositórios testing, acho que entrei em contradição. ora, basta ler o que sao os backports:

Backports are recompiled packages from testing (mostly) and unstable (in a few cases only, e.g. security updates) in a stable environment so that they will run without new libraries (whenever it is possible) on a Debian stable distribution

vejo que ainda preciso estudar muito rsrsrs


9. Re: libreoffice 4.1 [RESOLVIDO]

Matias
matiasalexsandro

(usa Fedora)

Enviado em 20/12/2013 - 16:54h

danniel-lara escreveu:

bom tu podes baixar direto do site e instalar manualmente o Libreoffice


+1

se não souber fazer isso responda. mas veja acho q o repositorio não se aplica a distro.


10. Re: libreoffice 4.1 [RESOLVIDO]

11. Re: libreoffice 4.1 [RESOLVIDO]

Luis R. C. Silva
luisrcs

(usa Linux Mint)

Enviado em 20/12/2013 - 17:40h

pauloedson escreveu:

rei astro, eu prefiro nao usar os repositórios testing, e, sim, os stable mesmo!

-----------------------

mas estive analisando melhor as linhas de codigo e percebi o seguinte:

o source.list contem => deb http://ftp.br.debian.org/debian wheezy-backports main

porém, a linha para instalar o writer contem => apt-get -t squeeze-backports install libreoffice-writer

ou seja, o repositório contem "wheezy-backports" e a linha para instalação contem "squeeze-backports". nao será esse o problema de tudo?!


Até concordo, mas a distro testing Debian é mais estável do que muitas distros estáveis por aí.


12. Re: libreoffice 4.1 [RESOLVIDO]

Paulo Edson
pauloedson

(usa Ubuntu)

Enviado em 20/12/2013 - 21:27h

mcnd2,

exatamente! era um detalhe de nada que eu estava errando.
o comando certo é o que segue abaixo, nao o do tópico inicial
deu tudo certo agora!

apt-get -t wheezy-backports install libreoffice-writer

-------------------------

no mais, obrigado a todos pela ajuda!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts