Erro ao abrir macro

1. Erro ao abrir macro

Moyses Souza
moysesouza

(usa Ubuntu)

Enviado em 27/10/2016 - 11:27h

Fiz um banco de dados no Base do Libre no Ubuntu para cadastramento de material e configurei abrir o formulário principal e em tela cheia quando clico no arquivo, entretanto neste formulário tem alguns botões que utilizo para abrir outros formulário ou relatório, mas o sistema gera a seguinte mensagem quando clico em qualquer botão: "Erro em tempo de execução do Basic, Ocorreu uma exceção, Type:com.sun.star.lang.WrappedTargetExcepsion, Message: TargetExcepsion, Type:com.sun.star.sdbc.SQLExcepition, Message: [OOoBase] Não existe conexão ao banco de dados. Contudo se eu fechar o formulário principal, com o base aberto e ir lá na aba dos formulário e abrir novamente o formulário principal aí tudo funciona ao abrir as macros dos botões que criei. Pergunto alguém pode me ajudar?


  


2. Re: Erro ao abrir macro

Bilufe
bilufe

(usa KDE Neon)

Enviado em 16/11/2016 - 15:57h

moysesouza escreveu:

Fiz um banco de dados no Base do Libre no Ubuntu para cadastramento de material e configurei abrir o formulário principal e em tela cheia quando clico no arquivo, entretanto neste formulário tem alguns botões que utilizo para abrir outros formulário ou relatório, mas o sistema gera a seguinte mensagem quando clico em qualquer botão: "Erro em tempo de execução do Basic, Ocorreu uma exceção, Type:com.sun.star.lang.WrappedTargetExcepsion, Message: TargetExcepsion, Type:com.sun.star.sdbc.SQLExcepition, Message: [OOoBase] Não existe conexão ao banco de dados. Contudo se eu fechar o formulário principal, com o base aberto e ir lá na aba dos formulário e abrir novamente o formulário principal aí tudo funciona ao abrir as macros dos botões que criei. Pergunto alguém pode me ajudar?


Verifique se a macro está chamando corretamente o arquivo do banco de dados.


3. Erro ao abrir macro

Moyses Souza
moysesouza

(usa Ubuntu)

Enviado em 16/11/2016 - 16:28h

Meu LibreOffice é 5.2.1.2 e o SO é Linux Mint 17.3

Quanto a chamada da macro está correta, o problema que quando clico no BD e abre o formulário principal automaticamente em tela cheia (opção minha), os botões das macros não funcionam, mas se eu fechar o formulário principal (não fechando o BD) e abri-lo de novo aí sim funciona a chamada dos botões para com as macros.