linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

1. linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

Leomar de Oliveira
leoCCB

(usa Slackware)

Enviado em 21/05/2022 - 18:04h

Pessoal, me kububtu não quer atualizar faz um tempinho já... achei que o problema era alguma falha da internete, mas pelo visto não.
Procedimentos já feitos:
1) troca de espelhos pelo disover (servidor local, servidor prinipal e esolher melhor);
2) todos os arquivos do apt/source.d foram renomeados para não serem vistos pelo apt;
3) todas as linhas do source.list que não são focal foram omentadas;
4) também tentei atualizar pelo live-cd usando o chroot, mas nada feito.

Não atualiza nem pelo apt, synaptic ou disover!!

essa é a saída do aptitude
dpkg: problemas com dependências impedem a configuração de linux-modules-5.13.0-39-generic:
linux-modules-5.13.0-39-generic depende de linux-image-5.13.0-39-generic | linux-image-unsigned-5.13.0-39-generic; porém:
Pacote linux-image-5.13.0-39-generic não está instalado.
Pacote linux-image-unsigned-5.13.0-39-generic não está instalado.

dpkg: erro ao processar o pacote linux-modules-5.13.0-39-generic (--configure):
problemas de dependência - deixando desconfigurado
A processar 'triggers' para linux-image-5.13.0-41-generic (5.13.0-41.46~20.04.1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.13.0-41-generic
I: The initramfs will attempt to resume from /dev/sda10
I: (UUID=0411e1f7-7380-4b2f-8d7e-c4e722d78d47)
I: Set the RESUME variable to override this.
/etc/kernel/postinst.d/zz-update-grub:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Imagem Linux encontrada: /boot/vmlinuz-5.13.0-41-generic
Imagem initrd encontrada: /boot/initrd.img-5.13.0-41-generic
Imagem Linux encontrada: /boot/vmlinuz-5.13.0-40-generic
Imagem initrd encontrada: /boot/initrd.img-5.13.0-40-generic
Encontrado Windows Boot Manager em /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi
Encontrado Slackware 15.0 x86_64 em /dev/sda6
Adding boot menu entry for UEFI Firmware Settings
Found Grml ISO image: /boot/grml/ubuntu-21.10-desktop-amd64.iso
Found memdisk: /boot/memdisk
/usr/bin/grub-mkrelpath: erro: failed to get canonical path of `/boot/images/Redcore-21024.iso'.
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
dpkg: erro ao processar o pacote linux-image-5.13.0-41-generic (--configure):
o subprocesso instalado, do pacote linux-image-5.13.0-41-generic, o script post-installation retornou erro do status de saída 1
Erros foram encontrados durante o processamento de:
linux-modules-5.13.0-39-generic
linux-image-5.13.0-41-generic
Press Return to continue, 'q' followed by Return to quit.


Alguém aí tem passado por problema semelhante?


essa é a saída completa do apt update:

linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado
E: Pacotes quebrados



  


2. MELHOR RESPOSTA

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 27/05/2022 - 20:40h


Rapz, hj eu recebi um erro parecido com o seu, mas com o pacote linux-hwe-5.13-headers-5.13.0-44. Eu não conseguia instalar nenhum pacote, não conseguia desinstalar o pacote, nem pular ele na atualização. Eu fiz o seguinte, dá uma olhada se no seu sistema funciona(sistema Xubuntu 20.04 focal):
1- ver se tem alguma coisa com problema(se estiver ok retorna vazio)
grep half-installed /var/lib;dpkg/status -A3 -B2
2- ver como está o pacote (no meu caso era linux-hwe-5.13-headers-5.13.0-44) está no gerenciador de pacotes. Se aparecer ii está ok)
dpkg -l | grep linux-hwe-5.13-headers-5.13.0-44
3 - removi no pacote na ignorância
sudo dpkg --remove --force-remove-reinstreq --force-depends linux-hwe-5.13-headers-5.13.0-44
4- marquei o pacote para não atualizar (no meu caso era linux-hwe-5.13-headers-5.13.0-44)
sudo apt-mark hold linux-hwe-5.13-headers-5.13.0-44
5 - atualizei a lista de pacotes
sudo apt update
6 instalei o ssh (que era o que eu queria fazer mas o gerenciador de pacotes não estava deixando)
sudo apt install openssh-server

No seu caso acho que o pacote seria linux-modules-5.13.0-39-generic mas confere no relatorio do apt

3. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 22/05/2022 - 14:15h


O aptitude tem uma opção de correção de problemas no menu dele. Vc já tentou consertar por ele?


4. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

Leomar de Oliveira
leoCCB

(usa Slackware)

Enviado em 22/05/2022 - 14:42h


leandropscardua escreveu:


O aptitude tem uma opção de correção de problemas no menu dele. Vc já tentou consertar por ele?

já tentei pelo aptitude...
Obs: as telas "m" e "c" estão queimadas e eu troquei por outras... mas as vezes esqueço...


saída do aptitude


A executar ações...
(Lendo banco de dados ... 428473 ficheiros e directórios actualmente instalados.)
A remover linux-image-5.13.0-39-generic (5.13.0-39.44~20.04.1) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-5.13.0-39-generic
/etc/kernel/postrm.d/zz-update-grub:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Imagem Linux encontrada: /boot/vmlinuz-5.13.0-41-generic
Imagem initrd encontrada: /boot/initrd.img-5.13.0-41-generic
Imagem Linux encontrada: /boot/vmlinuz-5.13.0-40-generic
Imagem initrd encontrada: /boot/initrd.img-5.13.0-40-generic
Encontrado Windows Boot Manager em /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi
Encontrado Slackware 15.0 x86_64 em /dev/sda6
Adding boot menu entry for UEFI Firmware Settings
Found Grml ISO image: /boot/grml/ubuntu-21.10-desktop-amd64.iso
Found memdisk: /boot/memdisk
/usr/bin/grub-mkrelpath: erro: failed to get canonical path of `/boot/images/Redcore-21024.iso'.
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: erro ao processar o pacote linux-image-5.13.0-39-generic (--remove):
o subprocesso instalado, do pacote linux-image-5.13.0-39-generic, o script post-removal retornou erro do status de saída 1
dpkg: demasiados erros, a parar
Erros foram encontrados durante o processamento de:
linux-image-5.13.0-39-generic
Processamento parou porque havia muitos erros.
W: Can not find PkgVer for 'linux-modules-5.13.0-39-generic'
E: Sub-process /usr/bin/dpkg returned an error code (1)
Configurando linux-image-5.13.0-41-generic (5.13.0-41.46~20.04.1) ...
A processar 'triggers' para linux-image-5.13.0-41-generic (5.13.0-41.46~20.04.1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.13.0-41-generic
I: The initramfs will attempt to resume from /dev/sda10
I: (UUID=0411e1f7-7380-4b2f-8d7e-c4e722d78d47)
I: Set the RESUME variable to override this.
/etc/kernel/postinst.d/zz-update-grub:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Imagem Linux encontrada: /boot/vmlinuz-5.13.0-41-generic
Imagem initrd encontrada: /boot/initrd.img-5.13.0-41-generic
Imagem Linux encontrada: /boot/vmlinuz-5.13.0-40-generic
Imagem initrd encontrada: /boot/initrd.img-5.13.0-40-generic
Encontrado Windows Boot Manager em /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi
Encontrado Slackware 15.0 x86_64 em /dev/sda6
Adding boot menu entry for UEFI Firmware Settings
Found Grml ISO image: /boot/grml/ubuntu-21.10-desktop-amd64.iso
Found memdisk: /boot/memdisk
/usr/bin/grub-mkrelpath: erro: failed to get canonical path of `/boot/images/Redcore-21024.iso'.
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
dpkg: erro ao processar o pacote linux-image-5.13.0-41-generic (--configure):
o subprocesso instalado, do pacote linux-image-5.13.0-41-generic, o script post-installation retornou erro do status de saída 1
Erros foram encontrados durante o processamento de:
linux-image-5.13.0-41-generic



5. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 22/05/2022 - 14:50h

Você está usando 20.04-lts ou 22.04-lts



6. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

Leomar de Oliveira
leoCCB

(usa Slackware)

Enviado em 22/05/2022 - 16:03h


W: Can not find PkgVer for 'linux-modules-5.13.0-39-generic'

acho q essa linha me resolve o "pobrema" tem q achar esse PkgVer aí...
eu já até reinstalei o grub çom o grub install e rodei o grub-mkonfig, mas também com resultados infrutíferos...


7. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

Leomar de Oliveira
leoCCB

(usa Slackware)

Enviado em 22/05/2022 - 16:07h


clodoaldops escreveu:

Você está usando 20.04-lts ou 22.04-lts


uname -a
inux leo 5.13.0-41-generic #46~20.04.1-Ubuntu SMP Wed Apr 20 13:16:21 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Convém atualizar para o 22?



8. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 22/05/2022 - 17:03h

Você está usando o 20.04-lts que terá suporte até abril/2025
Reinicie pelas opções avançadas, modo recuperação, corrigir pacotes quebrados, reinicie PC



9. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

Leomar de Oliveira
leoCCB

(usa Slackware)

Enviado em 22/05/2022 - 17:38h


clodoaldops escreveu:

Você está usando o 20.04-lts que terá suporte até abril/2025
Reinicie pelas opções avançadas, modo recuperação, corrigir pacotes quebrados, reinicie PC


já o fiz tomém... mas por sua palavra o farei novamente


10. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

Paulo Jr
Pebis

(usa Debian)

Enviado em 22/05/2022 - 21:16h


Tenta fazer uma atualização full:

sudo apt update && sudo apt full-upgrade

ou tenta remover o pacote com problema:

sudo apt remove inux-modules-5.13.0-39-generic


11. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 22/05/2022 - 22:42h


Faz uma tentattiva desabilitando secure boot e reiniciando a máquina e depois tenta remover o pacote. Se não funcionar, aqui tem uma thread no fórum do Ubuntu que talvez ajude
https://ubuntuforums.org/showthread.php?t=2474284


12. Re: linux-image-5.13.0-39-generic : Depende: linux-modules-5.13.0-39-generic mas não será instalado [RES

Leomar de Oliveira
leoCCB

(usa Slackware)

Enviado em 24/05/2022 - 00:08h


clodoaldops escreveu:

Você está usando o 20.04-lts que terá suporte até abril/2025
Reinicie pelas opções avançadas, modo recuperação, corrigir pacotes quebrados, reinicie PC


Não funfou, grande Clodoaldo...




01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts