Kernel 5.3 [RESOLVIDO]

1. Kernel 5.3 [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 29/09/2019 - 20:39h

Boa noite, algum dos senhores teve problemas com o kernel da série 5.3?

Aqui tive tanto no Void Linux que oferece uma pacote para essa versão, como no Slackware onde compilei.

Há o carregamento inicial e depois a tela fica preta! inserindo a opção nomodeset na tela do Grub ao mesmo consigo iniciar no modo single (recovery mode).

Ainda não é um PROBLEEEMA, porque tenho as versões anteriores funcionando, mas estranhei isso é a primeira vez que me ocorre algo parecido.


  


2. Re: Kernel 5.3

Jose Mario
zezaocapoeira

(usa Slackware)

Enviado em 30/09/2019 - 01:42h

edps escreveu:

Boa noite, algum dos senhores teve problemas com o kernel da série 5.3?

Aqui tive tanto no Void Linux que oferece uma pacote para essa versão, como no Slackware onde compilei.

Há o carregamento inicial e depois a tela fica preta! inserindo a opção nomodeset na tela do Grub ao mesmo consigo iniciar no modo single (recovery mode).

Ainda não é um PROBLEEEMA, porque tenho as versões anteriores funcionando, mas estranhei isso é a primeira vez que me ocorre algo parecido.


Salve mano.

O kernel 5.3.1 aqui tá rodando tranquilo, estou usando o zen patch correspondente a versão.

O kernel que deu problema aqui foi a versão 5.2 até a 5.2.7.

- a versão 5.2 e não detectava o devices.
- das versões 5.2.1 até a versão 5.2.7 congelava o sistema aleatoriamente, tendo que tirar o cabo de energia para desligar o sistema.

https://bugs.freedesktop.org/show_bug.cgi?id=111088

Dá uma olhada:

https://bugs.freedesktop.org/buglist.cgi?quicksearch=kernel 5.3

https://github.com/void-linux/void-packages/pull/14547

https://github.com/void-linux/void-packages/tree/master/srcpkgs/linux5.3/patches

https://github.com/foxlet/void-packages/tree/6c9605860b135776c95f26afd88d214ba9e24009/srcpkgs/linux5...

OBS:

Dependendo do caso, haverá correções nas próximas atualizações:

http://lkml.iu.edu/hypermail/linux/kernel/1909.3/03911.html
https://mirrors.edge.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.3.2-rc1.xz


Obrigado pela atenção, salve!!!


3. Re: Kernel 5.3

edps
edps

(usa Slackware)

Enviado em 30/09/2019 - 20:13h

zezaocapoeira escreveu:

Salve mano.

O kernel 5.3.1 aqui tá rodando tranquilo, estou usando o zen patch correspondente a versão.

O kernel que deu problema aqui foi a versão 5.2 até a 5.2.7.

- a versão 5.2 e não detectava o devices.
- das versões 5.2.1 até a versão 5.2.7 congelava o sistema aleatoriamente, tendo que tirar o cabo de energia para desligar o sistema.

https://bugs.freedesktop.org/show_bug.cgi?id=111088

Dá uma olhada:

https://bugs.freedesktop.org/buglist.cgi?quicksearch=kernel 5.3

https://github.com/void-linux/void-packages/pull/14547

https://github.com/void-linux/void-packages/tree/master/srcpkgs/linux5.3/patches

https://github.com/foxlet/void-packages/tree/6c9605860b135776c95f26afd88d214ba9e24009/srcpkgs/linux5...

OBS:

Dependendo do caso, haverá correções nas próximas atualizações:

http://lkml.iu.edu/hypermail/linux/kernel/1909.3/03911.html
https://mirrors.edge.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.3.2-rc1.xz

Obrigado pela atenção, salve!!!


Thanks amigo @zezao por sua resposta, vou compilar o zen kernel 5.3.1 aqui e ver no que dá.

O que me parece é que tem relação com meu driver de vídeo Intel UHD630, mal o kernel é carregado e a tela fica preta com o led do monitor piscando, já se eu edito o Grub adicionando nomodeset e removendo o parâmetro quiet, o boot prossegue e só para no não carregamento do ambiente gráfico por falta do driver de vídeo i915.


4. Re: Kernel 5.3 [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 30/09/2019 - 20:41h

Meu SSD ficou lento com o 5.3 e o fstrim relatava problemas com o sistema de arquivos, não acontece no 5.2.11 então vou ficar nele por enquanto.


5. Re: Kernel 5.3 [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 01/10/2019 - 20:27h


pylm escreveu:

Meu SSD ficou lento com o 5.3 e o fstrim relatava problemas com o sistema de arquivos, não acontece no 5.2.11 então vou ficar nele por enquanto.


No Void estou usando o 5.2.18 e no Slack o 5.2.13 compilado. Agora a pouco saiu a nova versão 5.3.2 no Void vou atualizar o sistema e instalar esse kernel para ver se rola.


6. Re: Kernel 5.3 [RESOLVIDO]

Eric
Grinder

(usa Slackware)

Enviado em 02/10/2019 - 02:00h

To usando a 5.3.2 aqui no Slack, até então tudo tranquilo.

- - - - -
www.gitlab.com/grinder
www.github.com/ericfernandesferreira
www.youtube.com/candelabrus1


7. Re: Kernel 5.3 [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 02/10/2019 - 18:03h

kernel-5.3.1 >> fedora-31-workstation-beta >> rodando sem problemas >> laptop (ci3 + 4/ram + 120/ssd + intel-hd)


8. Re: Kernel 5.3 [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 02/10/2019 - 19:48h


Pelos comentários, tudo leva a crer que é um problema no meu hardware, ontem instalei o 5.3.2 no Void e continua na mesma, ainda não tentei compilar o zen-kernel por falta de tempo, mas agora estou compilando a versão mais recente do gentoo-sources.


9. Re: Kernel 5.3 [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 02/10/2019 - 20:33h


edps escreveu:

Pelos comentários, tudo leva a crer que é um problema no meu hardware, ontem instalei o 5.3.2 no Void e continua na mesma, ainda não tentei compilar o zen-kernel por falta de tempo, mas agora estou compilando a versão mais recente do gentoo-sources.


Mesmo caso com o kernel gentoo-sources 5.3.2, o que me resta agora é baixar algum liveCD que tenha essa versão de kernel inclusa para ver se rola.

* ou então tomar vergonha na cara e comprar uma VGA um pouco decente, abandonando essa UHD630 da Intel, que acho ser a causa.

Aproveito para inserir aqui um link interessante de um blog que já tinha me deparado e que tem bom conteúdo:

https://unixuniverse.com.br/linux/kernel-53

Nele diz que essa versão não é LTS, o que pra mim não quer dizer nada já que nunca me prendi a isso, mas por enquanto vou deixar como está e continuar usando o 5.2 e vou testando as novas versões do 5.3 na medida que forem saindo.




10. Re: Kernel 5.3 [RESOLVIDO]

Wesley Henrique
BlackWhite

(usa Arch Linux)

Enviado em 02/10/2019 - 20:59h

clodoaldops escreveu:

kernel-5.3.1 >> fedora-31-workstation-beta >> rodando sem problemas >> laptop (ci3 + 4/ram + 120/ssd + intel-hd)


Eu também uso esse kernel mais no Fedora 30, e até agr não tive problemas.




11. Re: Kernel 5.3 [RESOLVIDO]

Jose Mario
zezaocapoeira

(usa Slackware)

Enviado em 03/10/2019 - 12:01h

edps escreveu:


edps escreveu:

Pelos comentários, tudo leva a crer que é um problema no meu hardware, ontem instalei o 5.3.2 no Void e continua na mesma, ainda não tentei compilar o zen-kernel por falta de tempo, mas agora estou compilando a versão mais recente do gentoo-sources.


Mesmo caso com o kernel gentoo-sources 5.3.2, o que me resta agora é baixar algum liveCD que tenha essa versão de kernel inclusa para ver se rola.

* ou então tomar vergonha na cara e comprar uma VGA um pouco decente, abandonando essa UHD630 da Intel, que acho ser a causa.

Aproveito para inserir aqui um link interessante de um blog que já tinha me deparado e que tem bom conteúdo:

https://unixuniverse.com.br/linux/kernel-53

Nele diz que essa versão não é LTS, o que pra mim não quer dizer nada já que nunca me prendi a isso, mas por enquanto vou deixar como está e continuar usando o 5.2 e vou testando as novas versões do 5.3 na medida que forem saindo.



Salve mano.

Instalou intel-microcode ?
Talvez resolva esse problema.

OBS:

Aqui coloquei para carregar o intel-microcode no arquivo initrd.gz. Aqui usei o seguinte comando para gerar initrd.gz.

# mkinitrd -c -k 5.3.2-zen1 -f xfs -r /dev/sda5 -m xfs -u -o /boot/initrd.gz -P /boot/intel-ucode.cpio


Depois é gerar uma nova configuração do grub com o grub-mkconfig -o /boot/grub/grub.cfg.

Caso tenha curiosodade.

https://www.linuxquestions.org/questions/slackware-14/how-to-load-new-intel-microcode-4175621053/
https://www.linuxquestions.org/questions/slackware-14/how-to-load-new-intel-microcode-4175621053/page11.html
https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files

Obrigado pela atenção, salve!!!


12. Re: Kernel 5.3 [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 10/10/2019 - 21:30h


zezaocapoeira escreveu:

Salve mano.

Instalou intel-microcode ?
Talvez resolva esse problema.

OBS:

Aqui coloquei para carregar o intel-microcode no arquivo initrd.gz. Aqui usei o seguinte comando para gerar initrd.gz.

# mkinitrd -c -k 5.3.2-zen1 -f xfs -r /dev/sda5 -m xfs -u -o /boot/initrd.gz -P /boot/intel-ucode.cpio


Depois é gerar uma nova configuração do grub com o grub-mkconfig -o /boot/grub/grub.cfg.

Caso tenha curiosodade.

https://www.linuxquestions.org/questions/slackware-14/how-to-load-new-intel-microcode-4175621053/
https://www.linuxquestions.org/questions/slackware-14/how-to-load-new-intel-microcode-4175621053/page11.html
https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files

Obrigado pela atenção, salve!!!


Obrigado brother pela resposta, sobre o microcode não estava instalado, instalei a partir do SlackBuilds e gerei um initrd não como explicado por você, mas basicamente o mesmo e ainda assim não obtive sucesso. Já no Void onde o microcode esta instalado, re-executei o dracut para gerar um novo initrd e também não obtive sucesso.

Fato é que por enquanto vou deixar como está porque não tenho tido tempo nem nos fins de semana para mexer no PC, assim que conseguir algo retorno aqui.

Thanks!



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts