Erro na leitura da temperatura

1. Erro na leitura da temperatura

aLEX
alexpolter

(usa Red Hat)

Enviado em 29/11/2019 - 11:32h

Bom dia!

Meu primeiro tópico aqui que acredito ser pertinente;

Estou querendo configurar um item no zabbix com a leitura de um arquivo de temperatura padrão do linux mas o arquivo não é atualizado, ou seja, não está recebendo os valores. A configuração do zabbix eu já fiz e está OK mas não adianta monitorar uma varável que não está sendo atualizada, acredito eu, pelo Kernel.

/sys/class/thermal/thermal_zone0/temp
/sys/class/hwmon/hwmon0/temp1_input

Ambos possuem os mesmos valores Cesius porém não atualizam...

Alguém poderia me ajudar? Não quero utilizar o lm_sensors.

Linux version 3.2.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP Debian 3.2.78-1








  


2. Re: Erro na leitura da temperatura

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 29/11/2019 - 13:27h

alexpolter escreveu:

/sys/class/thermal/thermal_zone0
/sys/class/hwmon/hwmon0



eu nunca mexi com zabbix, mas no shell eu mandaria atualizar o comando a cada segundo

watch -n 1 /sys/class/thermal/thermal_zone0 

watch -n 1 /sys/class/hwmon/hwmon0 


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Re: Erro na leitura da temperatura

aLEX
alexpolter

(usa Red Hat)

Enviado em 29/11/2019 - 13:58h

Mauriciodez escreveu:

alexpolter escreveu:

/sys/class/thermal/thermal_zone0
/sys/class/hwmon/hwmon0



eu nunca mexi com zabbix, mas no shell eu mandaria atualizar o comando a cada segundo

watch -n 1 /sys/class/thermal/thermal_zone0 

watch -n 1 /sys/class/hwmon/hwmon0 


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




No caso o problema não está no Zabbix, o item está configurado e já testei com outros arquivos para gerar os gráficos. O problema é que as informações desse arquivos não são atualizadas, mostrando somente 280000 (28 Ceusius) e não altera.

A verificação foi feita com cut -c 2 que seleciona os dois primeiros caracteres do arquivo que preciso mas isso é parto do que fiz no zabbix que está OK.

Alguem teria alguma luz para que esses dados do do arquivo sejam atualizados?


4. Re: Erro na leitura da temperatura

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 29/11/2019 - 14:18h


alexpolter escreveu:
A verificação foi feita com cut -c 2 que seleciona os dois primeiros caracteres do arquivo que preciso mas isso é parto do que fiz no zabbix que está OK.
Alguem teria alguma luz para que esses dados do do arquivo sejam atualizados?


acho que eu entendi ... o comando é vc quem faz ... se sim é o seguinte .... os arquivos dentro de /sys/class/hwmon/hwmon0 são de configuração, eles não se alteram em tempo real mesmo não ... se vc quer ver a temperatura, instale o lm-sensors .. depois o configure e puxe a temp com o comando "sensors".

v aí se te ajuda >>> https://br.ccm.net/faq/15768-linux-ver-a-temperatura-do-cpu


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts