Problema com grub [RESOLVIDO]

1. Problema com grub [RESOLVIDO]

Hugo Pantuzzo
ozzutnap

(usa Kali)

Enviado em 23/10/2017 - 20:48h

Pessoal como consigo resolver o problema com o grub ?
Notebook Dell Inspiron 15 5000
i15-5566-A10P
Meu notebook veio com o OS Windows 10 Home pré instalado, resolvi instalar o Kali Linux em uma partição e o Parrot em outra, apenas para testa-los e se caso me adaptasse depois removeria o Windows, porém o computador passou a apresentar um problema, sempre quando vou tentar iniciar um dos OS Linux aparece o erro grub, vi um post sobre isso aqui no site, realizo os passos com sucesso até o final, mas sempre que desligo o computador ou reinicio o problema volta a aparecer, por favor, poderiam me dar uma luz sobre isso ?
Meu HD tem 1 TB, criei uma partição de 55 GB para cada Linux, e uma de 35 para deixar vazia caso precisasse, o restante é do Windows.
Me expliquem também como faço para formatar as partições completamente pelo Windows caso seja necessário reinstalar os outros OS pois talvez eu tenha feito algo errado da última vez.
Se alguém puder me chamar no whatsapp para explicar, melhor ainda, desde já o meu muito obrigado, valeu galera, abraços !!
+55 31 9 8265-7903


  


2. Re: Problema com grub [RESOLVIDO]

skjdeecedcnfncvnrfcnrncjvnjrnfvjcnjrjvcjrvcj
Londreslondres

(usa Parabola)

Enviado em 23/10/2017 - 20:58h

Qual é o erro que aparece?
Poderia tirar um print do Gparted, para analisarmos as partições.
--------------------------------------------------------------------
#voltalisteiro


3. Re: Problema com grub [RESOLVIDO]

Hugo Pantuzzo
ozzutnap

(usa Kali)

Enviado em 23/10/2017 - 21:19h

Londreslondres escreveu:

Qual é o erro que aparece?
Poderia tirar um print do Gparted, para analisarmos as partições.
--------------------------------------------------------------------
#voltalisteiro


Acabei de tentar iniciar novamente para tirar uma foto e não consegui, ficou uma tela totalmente preta e só... O erro que aparecia dizia que não tinha sido possível encontrar o arquivo do grub em tal lugar e tinha algo escrito i386 também ai quando dava o erro era possível digitar comandos segui um tutorial que encontrei aqui no site que mandava digitar ls e tal... Dai iniciava normal o OS, continuando com os passos do tutorial eu abria um terminal e digitava os comandos, no final baixava alguns arquivos com cerca de 11 mb e tudo certo. Mas quando iniciava novamente o problema voltava.
Agora que não consegui iniciei o Windows, o fui no gerenciamento do disco pelo meu computador e exclui as partições, parece que foram formatadas sem problemas, agora, poderia me ensinar a reinstalar os outros dois OS da maneira correta ?
Provavelmente esse erro foi por conta de algum vacilo meu.
Obs: Executei o chkdsk e ele encontrou alguns erros
"Erro detectado no índice $I30 do arquivo D83
Erro detectado no índice $I30 do arquivo D83
Erro detectado no índice $I30 do arquivo 24520
Erro detectado no índice $I30 do arquivo 24520
614384 de entradas de índice processadas.
Verificação de índices concluída.
Erros encontrados. CHKDSK não pode continuar em modo somente leitura."


4. Re: Problema com grub [RESOLVIDO]

ctw6av
ctw6av

(usa Nenhuma)

Enviado em 23/10/2017 - 21:22h

Depende de como fez a instalação dos sistemas. Para começar:

A instalação foi feita em EFI?
O disco está em gpt?

Eu recentemente instalei o Windows 10 na minha máquina, reinstalei meu sistema em efi e funcionou normalmente, já no modo legacy deu erro.

Se ajudar segue como ficou meu disco depois da instalação >> https://imgur.com/PrV8YWq


5. Re: Problema com grub

skjdeecedcnfncvnrfcnrncjvnjrnfvjcnjrjvcjrvcj
Londreslondres

(usa Parabola)

Enviado em 23/10/2017 - 21:26h

Eu não recomendo o Kali e Parrot, recomendo o Ubuntu, Mint, Manjaro, Debian, Solus OS... Essas distros não vêm com ferramentas de hacking, se você precisá-las recomendo o BackBox, ele é o concorrente do Kali.
Para instalá-los é bem simples, no processo de instalação crie quatro partições: / , /home , swap , /boot
--------------------------------------------------------------------
#voltalisteiro


6. Re: Problema com grub [RESOLVIDO]

Hugo Pantuzzo
ozzutnap

(usa Kali)

Enviado em 24/10/2017 - 00:24h

ctw6av escreveu:

Depende de como fez a instalação dos sistemas. Para começar:

A instalação foi feita em EFI?
O disco está em gpt?

Eu recentemente instalei o Windows 10 na minha máquina, reinstalei meu sistema em efi e funcionou normalmente, já no modo legacy deu erro.

Se ajudar segue como ficou meu disco depois da instalação >> https://imgur.com/PrV8YWq

Cara, poderia me explicar como fez ? Só consigo fazer a instalação no meu desligando a função secure boot, e ativando as legacy roms.
Não faço nem idéia do que seja EFI sou um iniciante kkk
E sobre esse gpt (não sei o que significa também) quando apresentava o erro apareciam após eu digitar o comando ls vários "discos" ex: (hd0,gpt1) (hd0,gpt2) (hd0,gpt3)... E assim por diante até 12 se não me engano.



7. Re: Problema com grub [RESOLVIDO]

Hugo Pantuzzo
ozzutnap

(usa Kali)

Enviado em 24/10/2017 - 00:26h

Londreslondres escreveu:

Eu não recomendo o Kali e Parrot, recomendo o Ubuntu, Mint, Manjaro, Debian, Solus OS... Essas distros não vêm com ferramentas de hacking, se você precisá-las recomendo o BackBox, ele é o concorrente do Kali.
Para instalá-los é bem simples, no processo de instalação crie quatro partições: / , /home , swap , /boot
--------------------------------------------------------------------
#voltalisteiro


Bom, essa é a primeira vez que uso um OS Linux, eu estou justamente querendo aprender a usar as ferramentas desses OS voltados para hacking, acho que esses outros não me serviriam, mas de qualquer forma muito obrigado pela sugestão, futuramente irei baixa-los para ver como funcionam.


8. Re: Problema com grub [RESOLVIDO]

Hugo Pantuzzo
ozzutnap

(usa Kali)

Enviado em 24/10/2017 - 00:29h

Pessoal estou instalando novamente o Parrot, deixei uma partição de 55 gb para o sistema e uma de 29 para swap, agora está perguntando se desejo instalar o carregador de inicialização grub no registro mestre de inicialização, mas porem o Windows não foi detectado, instalo o carregador agora ou não ??


9. Re: Problema com grub

ctw6av
ctw6av

(usa Nenhuma)

Enviado em 24/10/2017 - 08:15h

ozzutnap escreveu:

Pessoal estou instalando novamente o Parrot, deixei uma partição de 55 gb para o sistema e uma de 29 para swap, agora está perguntando se desejo instalar o carregador de inicialização grub no registro mestre de inicialização, mas porem o Windows não foi detectado, instalo o carregador agora ou não ??


Não é necessário 29G para swap. Eu uso uma porcentagem (20%) da minha RAM (4G) como swap mas ela nunca é ocupada, nem sequer alguns bytes. Ex:

RAM 2048M = SWAP 409M #Arredonde para 500M pois há mais propensão a uso.
RAM 4096M = SWAP 818M #Mas só uso 500M

Pessoas diferentes, usam a swap de forma diferente e tem até os que não usam. De qualquer forma encontre a maneira que te agrada e use. Ou não.




10. Re: Problema com grub [RESOLVIDO]

Hugo Pantuzzo
ozzutnap

(usa Kali)

Enviado em 25/10/2017 - 13:33h

Pessoal, problema resolvido, valeu pela ajuda.
Abraços !






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts