CONECTA MAS NÃO NAVEGA

1. CONECTA MAS NÃO NAVEGA

James
ivmjvmes

(usa Kali)

Enviado em 18/10/2020 - 23:37h

Olá.

Estou com um probleminha, fiz a instalação do Kali e ele conecta no wifi da minha casa, mas não acessa a internet. Fiz um testo roteando o 4g do celular e ele conectou e obtive acesso. Quero saber como resolver o problema para que ele, conectado a rede wifi da casa, possa acessar a internet. O Kali é instalado em dualboot com o Ubuntu. No Ubuntu o wifi de casa conecta e acessa a internet. Se alguém poder ajudar, já agradeço de antemão.


  


2. Re: CONECTA MAS NÃO NAVEGA

Marcelo Oliver
msoliver

(usa Debian)

Enviado em 19/10/2020 - 00:47h

ivmjvmes escreveu:

Olá.

Estou com um probleminha, fiz a instalação do Kali e ele conecta no wifi da minha casa, mas não acessa a internet. Fiz um testo roteando o 4g do celular e ele conectou e obtive acesso. Quero saber como resolver o problema para que ele, conectado a rede wifi da casa, possa acessar a internet. O Kali é instalado em dualboot com o Ubuntu. No Ubuntu o wifi de casa conecta e acessa a internet. Se alguém poder ajudar, já agradeço de antemão.

Boa noite, esse problema, normalmente é "falta de DNS", segue o teste para identificar o problema:
execute no terminal:
ping -c4 google.com.br
Se a resposta for diferente de:
4 packets transmitted, 4 received, 0% packet loss, time Nms
"N" é um número
Faça:
ping -c4 172.217.30.99
A resposta deve ser:
4 packets transmitted, 4 received ......
Para "resolver":
nano /etc/resolv.conf
coloque os DNS de sua preferencia....
salve e saia do nano.
Desconecte e reconecte na rede....

______________________________________________________________________
Devido a muitas perguntas, segue esclarecimento:
O comando: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p',
faz parte da minha assinatura.
O qual, "filtra" a página: "https://www.vivaolinux.com.br/termos-de-uso/",
Mostrando o seguinte:
Se você sanou sua dúvida ou resolveu um problema a partir de um
tópico criado, é extremamente recomendável que acesse o tópico e
marque-o como "RESOLVIDO". E mais recomendável ainda que você eleja
como melhor resposta a que mais lhe ajudou.

______________________________________________________________________
Importante: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p'
Att.: Marcelo Oliver
______________________________________________________________________


3. Re: CONECTA MAS NÃO NAVEGA

James
ivmjvmes

(usa Kali)

Enviado em 20/10/2020 - 00:13h

Funcionou aqui, muito obrigado. Só uma correção, no segundo "teste de ping" a resposta esperada deveria ser o contrario do que vc escreveu, não? Já que o teste no numero DNS retornou o esperado, era para se esperar o mesmo para qualquer outro endereço. Muito obrigado!


4. Re: CONECTA MAS NÃO NAVEGA

Marcelo Oliver
msoliver

(usa Debian)

Enviado em 20/10/2020 - 02:51h


ivmjvmes escreveu:

Funcionou aqui, muito obrigado.
Só uma correção, no segundo "teste de ping" a resposta esperada deveria ser o contrario do que vc escreveu, não?
Já que o teste no numero DNS retornou o esperado, era para se esperar o mesmo para qualquer outro endereço.
Muito obrigado!

---
Não,
deve ser esperado uma resposta de sucesso, 0% packet loss
Se o ping no domínio, (ping -c4 google.com.br) falha
resposta: 4 packets transmitted, 0 received, 100% packet loss, time Nms
e o ping no endereço IP (ping -c4 172.217.30.99), não falha
resposta: 4 packets transmitted, 4 received, 0% packet loss, time Nms
Conclui-se que o DNS não está resolvendo os nomes para IP, que é a sua função.....
E é o que o teste testa......
Se a resposta foi satisfatória e esclarecedora...
Marque o Tópico como RESOLVIDO, e escolha a MELHOR Resposta.....

OBS.: Alem dos DNSs da "operadora" (Vivo/SP), uso também o
1.1.1.1
_____________________________________________________________________
Devido a muitas perguntas, segue esclarecimento:
O comando: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p',
faz parte da minha assinatura.
O qual, "filtra" a página: "https://www.vivaolinux.com.br/termos-de-uso/",
Mostrando o seguinte:
Se você sanou sua dúvida ou resolveu um problema a partir de um
tópico criado, é extremamente recomendável que acesse o tópico e
marque-o como "RESOLVIDO". E mais recomendável ainda que você eleja
como melhor resposta a que mais lhe ajudou.

______________________________________________________________________
Importante: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p'
Att.: Marcelo Oliver
______________________________________________________________________


5. Re: CONECTA MAS NÃO NAVEGA

James
ivmjvmes

(usa Kali)

Enviado em 23/10/2020 - 10:53h

Entendi. A resposta aqui foi 100% packet loss para todos os testes, google, dns e o IP que vc passou. Na primeira vez que escrevi os DNS's no resolv.conf funcionou a internet, no entanto quando o notebook foi reniciado não funcionava mais a internet e mesmo fazendo o processo de acessar o arquivo e escrever os DNS ainda assim, não funciona.


6. Re: CONECTA MAS NÃO NAVEGA

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 23/10/2020 - 16:15h

ivmjvmes escreveu:

Entendi. A resposta aqui foi 100% packet loss para todos os testes, google, dns e o IP que vc passou. Na primeira vez que escrevi os DNS's no resolv.conf funcionou a internet, no entanto quando o notebook foi reniciado não funcionava mais a internet e mesmo fazendo o processo de acessar o arquivo e escrever os DNS ainda assim, não funciona.


Tenta um traceroute 8.8.8.8 p ver até onde seus pacotes vão