Vetores [RESOLVIDO]

1. Vetores [RESOLVIDO]

Jeferson
Jefferson21

(usa Ubuntu)

Enviado em 15/10/2012 - 14:50h

Ola amigos.
Gostaria de fazer um verificador para o Sudoku.
a missão é fazer uma matriz 3x3 com números de 1 a 9 e não pode existir números repetidos
preciso fazer um código que gere a matriz e que veja se o usuário digitou números repetidos,
se tiver números repetidos o programa retorne "Configuração invalida"
caso contrário "Configuração válida"

eu fiz em PETEQS se alguém souber fazer em javascript tbm ajuda muito.

Meu código segue abaixo para melhor visualização.
Se puderem me ajudar ficarei Grato

algoritmo "Números repetidos na matriz"
// Função : Verificar se há números repetidos digitado pelo usuário
// Autor :Jeferson
var

matriz :vetor [1..3,1..3] de inteiro
linha, coluna :inteiro

inicio

para linha de 1 ate 3 faca
para coluna de 1 ate 3 faca


fimpara
fimpara
para linha de 1 ate 3 faca
para coluna de 1 ate 3 faca

escreva(matriz[linha,coluna] :8)

fimpara
escreval("")
fimpara

se (matriz[1]) = (matriz[3,1]) entao
escreval("")
escreva("invalido")
senao
escreva(" válida")

fimse

fimalgoritmo


  






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts