Erro de Eclipse no Debian 5

1. Erro de Eclipse no Debian 5

Paulo
henbran

(usa Debian)

Enviado em 06/05/2009 - 20:51h

Durante a instalação do eclipse pelo gerenciador de pacotes Synaptic no Debian 5 Lenny, ocorreram alguns errinhos. Agora tento executar o Eclipse e dá os seguintes erros:

Primeiro:

This Eclipse build doesn't have support for the integrated browser.

Depois o erro:

JVM terminated. Exit code=127
/usr/lib/jvm/java-gcj/bin/java
-Djava.library.path=/usr/lib/jni
-Dgnu.gcj.precompiled.db.path=/var/lib/gcj-4.2/classmap.db
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dosgi.locking=none
-jar /usr/lib/eclipse/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/lib/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata f0004
-install /usr/lib/eclipse
-vm /usr/lib/jvm/java-gcj/bin/java
-vmargs
-Djava.library.path=/usr/lib/jni
-Dgnu.gcj.precompiled.db.path=/var/lib/gcj-4.2/classmap.db
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dosgi.locking=none
-jar /usr/lib/eclipse/startup.jar

e não abre o Eclipse.




  


2. JDK

Nadson Cerqueira
nadsoncs

(usa Debian)

Enviado em 02/06/2009 - 12:28h

Amigão,

Vc instalou o JDK ?


3. Eclipse no Debian lenny

Marco Vinycios
marcovinycios

(usa Fedora)

Enviado em 31/08/2009 - 11:23h

Mam,

Para você resolver este problema, adicione a sua source list o repositório multimedia, instale o pacote xulrunner e pronto. Mais informações você encontra no blog http://www.brasilopencode.blogspot.com/

Espero ter ajudado.


4. Re: Erro de Eclipse no Debian 5

yurick gomes
yurick

(usa Debian)

Enviado em 31/08/2009 - 13:06h

amigo, antes de instalar o eclipse, eu recomendo instalar o JDK ou o JRE da sun! funciona melhor do que gcj!


5. Re: Erro de Eclipse no Debian 5

Jefferson Diego
Diede

(usa Debian)

Enviado em 31/08/2009 - 13:20h

"vm /usr/lib/jvm/java-gcj/bin/java" = GCJ
Ouça os amigos acima... instale o JDK da Sun...


6. Re: Erro de Eclipse no Debian 5

Helen Mae Koike Fornazier
helen.fornazier

(usa Gentoo)

Enviado em 11/09/2009 - 13:53h

Eu tive este mesmo problema, estou no debian 5 também, e já tinha instalado o jdk.
Para eu consequir abrir o eclipse sem problema, eu digito no terminal:

java -jar /usr/lib/eclipse/startup.jar &

assim o eclipse abre normalmente.




7. Re: Erro de Eclipse no Debian 5

Helen Mae Koike Fornazier
helen.fornazier

(usa Gentoo)

Enviado em 11/09/2009 - 14:38h

Agora eu fiz o que o amigo disse acima:

entrei no site: http://brasilopencode.blogspot.com/2009/08/eclipse-debian-lenny.html

e lá diz o seguinte:

"Caros colegas, após passar algumas dificuldades com o Debian lenny na instalação do eclipse consegui resolver o problema. Após a instalação(pelo apt-get versão 3.2.2), o eclipse informava um erro de incompatibilidade com o browser e após muita pesquisa, descobri que faltava um pacote de nome xulrunner. Para instalar este pacote adicione ao seu repositório com o comando vim /etc/apt/source.list a linha deb http://www.debian-multimedia.org/ lenny main e pronto problema resolvido.
Postado por Marco Vinycios às 10:17 "


Depois disso, o meu eclipse está entrando sem problemas.