não foi possivel satisfazer as dependencias (manjaro) [RESOLVIDO]

1. não foi possivel satisfazer as dependencias (manjaro) [RESOLVIDO]

abel bezerra
abelbezerra

(usa Ubuntu)

Enviado em 18/07/2019 - 19:30h

quando tento atualizar pelo gerenciador de pacotes ou instalar um programa dá esse erro:

falha ao preparar a transação, não foi possível satisfazer as dependências:
instalar dunst (1.4.1-1) quebra a dependência 'dunstify' requerida por update-notifier

isso tá acontecendo também no terminal:

[abel-pc abel]# pacman -Su
erro: não foi possível registrar a base de dados "archlinuxfr" (base de dados já registrada)
:: Iniciando atualização completa do sistema...
atenção: cryptsetup: local (2.1.0-1.1) é mais novo que core (2.1.0-1)
atenção: dbus: local (1.12.16-1.2) é mais novo que core (1.12.16-1)
atenção: glibc: local (2.29-3.1) é mais novo que core (2.29-3)
atenção: lib32-glibc: local (2.29-3.1) é mais novo que core (2.29-3)
atenção: os-prober: local (1.76-2) é mais novo que community (1.76-1)
atenção: procps-ng: local (3.3.15-1.2) é mais novo que core (3.3.15-1)
atenção: tlp: local (1.2.2-1.1) é mais novo que community (1.2.2-1)
resolvendo dependências...
procurando por pacotes conflitantes...
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: a instalação de dunst (1.4.1-1) quebra a dependência "dunstify" necessária por update-notifier

o que fazer nesse caso? quem entende de arch linux me ajuda por favor!!


  


2. Re: não foi possivel satisfazer as dependencias (manjaro)

Perfil removido
removido

(usa Nenhuma)

Enviado em 18/07/2019 - 20:08h

Você trocou o seu Manjaro para testing
e retornou para o ramo estável?
Você tem vários pacotes mais novos que os do repo que vc está agora...
Nesse caso, você precisa fazer um downgrade...

O pacote dunstify repõe o pacote dunst, você não pode ter os dois instalados...

Além disso, ArchLinuxFR é um repo para instalação do Yaourt.
Tem tantos outros ajudantes do AUR por aí, yay e tal..
O Yaourt não sei se está sendo mais atualizado?

Para você ver os pacotes instalados por esse repo:
$ paclist archlinuxfr 


Enfim, você pode tentar retirar esse repo da configuração do pacman.

Abra como root:
/etc/pacman.conf 


pode ser com o gedit, mousepad, ou qq outro editor de texto, como em:

$ sudo mousepad /etc/pacman.conf 


E delete:

[archlinuxfr]
Server = http://repo.archlinux.fr/$arch


Salve e tente fazer um downgrade no seu sistema.

https://www.reddit.com/r/ManjaroLinux/comments/b4xeh8/dunst_is_conflict_with_dunstify_in_manjaro_tes...
https://wiki.archlinux.org/index.php/Unofficial_user_repositories




3. Re: não foi possivel satisfazer as dependencias (manjaro) [RESOLVIDO]

abel bezerra
abelbezerra

(usa Ubuntu)

Enviado em 19/07/2019 - 07:31h

naufragus88 escreveu:

Você trocou o seu Manjaro para testing
e retornou para o ramo estável?
Você tem vários pacotes mais novos que os do repo que vc está agora...
Nesse caso, você precisa fazer um downgrade...

O pacote dunstify repõe o pacote dunst, você não pode ter os dois instalados...

Além disso, ArchLinuxFR é um repo para instalação do Yaourt.
Tem tantos outros ajudantes do AUR por aí, yay e tal..
O Yaourt não sei se está sendo mais atualizado?

Para você ver os pacotes instalados por esse repo:
$ paclist archlinuxfr 


Enfim, você pode tentar retirar esse repo da configuração do pacman.

Abra como root:
/etc/pacman.conf 


pode ser com o gedit, mousepad, ou qq outro editor de texto, como em:

$ sudo mousepad /etc/pacman.conf 


E delete:

[archlinuxfr]
Server = http://repo.archlinux.fr/$arch


Salve e tente fazer um downgrade no seu sistema.

https://www.reddit.com/r/ManjaroLinux/comments/b4xeh8/dunst_is_conflict_with_dunstify_in_manjaro_tes...
https://wiki.archlinux.org/index.php/Unofficial_user_repositories



ok deletei todo o seguinte:
[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/x86_64
[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/x86_64

é isso? tenho que fazer downgrade, como se faz isso?
e como deleta esse dunst, se é que precisa?



4. Re: não foi possivel satisfazer as dependencias (manjaro) [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 19/07/2019 - 09:02h


# pacman -Syyuu 



5. Re: não foi possivel satisfazer as dependencias (manjaro) [RESOLVIDO]

abel bezerra
abelbezerra

(usa Ubuntu)

Enviado em 19/07/2019 - 12:57h

naufragus88 escreveu:


# pacman -Syyuu 


ok, depois que reiniciou eu vi que tinha resolvido, obrigado, o forum aqui funciona melhor do que o da archlinux!!!




6. Re: não foi possivel satisfazer as dependencias (manjaro) [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 19/07/2019 - 13:18h


Olá,
repensando um pouco aqui, com relação ao erro do:

[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/x86_64


É por que ele estava em duplicata, e não por que não é mais válido!

Se quiser esse repo na configuração do pacman, para receber uma
eventual atualização do Yaourt, pode readicioná-lo.


7. Re: não foi possivel satisfazer as dependencias (manjaro) [RESOLVIDO]

abel bezerra
abelbezerra

(usa Ubuntu)

Enviado em 19/07/2019 - 17:52h

ok, mas ouvi dizer que o yaourt não recebe mais atualizações, até me recomendaram instalar o yay, e como tá funfando bem assim, deixa quieto






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts