instalação glib-2.10.0

1. instalação glib-2.10.0

Thiago Dias
thiago_dias

(usa CentOS)

Enviado em 04/11/2007 - 23:05h

Ola galera, sou iniciante no linux,uso o ubuntu 7.04 e tentando usar o ajunta para trabalhar com o c++ ele diz q não tem o glib instalado, algo assim, mais como todo iniciante eu passo mto aperto na hora de instalar programas no linux, afinal o glib num tem em nenhum repositórios entaum num tem como instalar via apt-get install e nem no synaptic, ja baixei o pacote do glib , ja descompactei, amis dae pra frente me preco todo, nunca consigo instalar nada...só consigo instalar via apt-get automatix e por ae vai, queria que me ajudassem a acabar com esse problema, me falam passo a passo como faço pra instalar um programa assim, ja tentei fazer isto e aparecem os devidos erros:
./configure
su
make
#*** Nenhum alvo indicado e nenhum arquivo make encontrado. Pare.
make install
# *** Sem regra para processar o alvo `install'. Pare.

estou agindo errado fazendo isso?parece q sim né, caso esteje me de a melhor solução pra esse caso, sou iniciante, procure ser bem claro.
desde já agradeço a ajuda de vocês, muito obrigado!
Abraço!


  


2. ola

jorge silva ferreira
john_connor

(usa Slackware)

Enviado em 04/11/2007 - 23:52h

bem amigo se não me engano e isso :
apt-get update
apt-get install make
apt-get instal biuld-essential ou essentials

abs
john


3. Re: instalação glib-2.10.0

Simon
simon

(usa Slackware)

Enviado em 05/11/2007 - 00:54h

Pela saida de erro que vc colocou, o que ocorre eh algum erro durante o ./configure, cola a saida do configure pra gente...


4. instalação glib-2.10.0

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 05/11/2007 - 10:16h

Os pacotes glib são esses.
libg++2.8.1.3-glibc2.2
libstdc++2.10-glibc2.2

E estão aqui
http://packages.debian.org/search?keywords=glibc&searchon=names&suite=stable&section=all

Não sei qual a distro que você está utilizando mas se tem apt é do tipo debian.(ou não é?)
O repositório deveria indicar o debian ou o ubuntu ou melhor: a distro específica.
http://ftp.br.debian.org/debian/

No synaptic há menu configurações repositório e pode verificar o que está ativo.
Para compilar tem que instalar o gcc e o g++ também.
É isso.



5. Re: instalação glib-2.10.0

Silvio Alex de Lima
silvioadl

(usa Ubuntu)

Enviado em 05/11/2007 - 11:13h

olá amigo, esse erro fala que para instalar o glib precisa antes ter essas depencdencias instladas.
e essas dependencias vão ter outras dependencias e ai vai..... Eu aconselho a você ultilizar o comando:

#apt-cache search glib /*Verifica quais as opções aparecem na tela e depois..*/

#apt-cache search opçãoescolhida /*Lembrando que por ser uma biblioteca provavelmente virar com libglib x.x, espero que tenha ajudado. Abraços...


6. uma parte resolvida, mais agora falta outras coisas

Thiago Dias
thiago_dias

(usa CentOS)

Enviado em 05/11/2007 - 13:04h

sobre o meu erro acima eu consegui resolver, estava faltando o build-essential, agora deu certo, mais estou querendo usar o ajunta para programação em c++, e depois de instalado o glib ele pede para eu instalar o gtkmm , eu baixei ele, mais na hora de configurar aparece o seguinte:
checking for ATKMM... configure: error: Package requirements (glibmm-2.4 >= 2.12.8 atk >= 1.9.0) were not met:

No package 'glibmm-2.4' found
No package 'atk' found

só coloquei a parte final q é a do erro, ae ele manda eu instalar o glibmm-2.4 procurei mais num achei esse pacote se alguem tiver o link me passa ae, e manda eu instalar o atk tb, o atk eu baixei e na hora de passar o configure ele achou mais os seguintes erros no final da saida:
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

ja esse erro num consegui intender, afinal eu tenhu instalado o pacote glib-2.14.
Por enquanto os erros são esses...
Espero respostas
Vlw


7. só para lembrar

Thiago Dias
thiago_dias

(usa CentOS)

Enviado em 05/11/2007 - 13:05h

eu uso a distribuição ubuntu 7.04
Obrigado desde já


8. instalação glib-2.10.0

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 05/11/2007 - 15:06h

Temo que esteja acontecendo uma inconsitência cronológica com as versões do ubuntu e as do programa.
Neste site(há um mecanismo de busca- Search)
http://packages.ubuntu.com/
Você encontra todos os pacotes e todas as versões
Você vai ver que o tal glibmm versão 12 é o edgy, já obsoleta.
A versão do feisty é a 13.

Sugiro utilizar o synaptic, é prático e fácil, além de sincronizar as coisas e já te indica o que está desatualizado.

Boa sorte.



9. instalação das bibliotecas

Derivaldo José dos Santos
dericjsantos

(usa Kurumin)

Enviado em 05/11/2007 - 15:40h

Eu estava tentando instalar o amsn0.96 e quando eu dava o ./configure ele dizia que faltava sempre uma arquivo, anotei o nome do arquivo fui no synaptic na opção todos os arquivos digitei o nome do arquivo e ele localizou, instalei o arquivo e dei o ./configure e enquanto ele dizia que faltava arquivo eu ia no synaptic procurava selecionava e instalava e novamente ./configure tudo isso via terminal. Até o momento que ele não solicitou a instalação de nunhum arquivo. Por fim make e make install. Se ele disse que falta o arquivo (lib01, e se por acaso vc encontrar o lib01-dev instala também e todos os arquivos seguintes.

Uma observação, muitas vezes o comando make e make install não funcionam, por motivo do instalador estar com outro nome vc tem que ler o readme antes de qualquer instalação.


10. Re: instalação glib-2.10.0

Rafael
rafagondi

(usa Ubuntu)

Enviado em 05/11/2007 - 20:43h

usa o apt..
# apt-get install libg++2.8.1.3-glibc2.2 libstdc++2.10-glibc2.2


11. aos poucos conseguindo

Thiago Dias
thiago_dias

(usa CentOS)

Enviado em 06/11/2007 - 05:23h

Galera aos poucos estou conseguindo, fui utlizando o
synaptic e fui achando mtos pacotes q precisava e fui instalando, agora estou tentando instalar o pacote gtkmm-2.11.1 e da a seguinte mensagem de erro:
checking for GDKMM... configure: error: Package requirements (glibmm-2.4 >= 2.12.8 cairomm-1.0 >= 1.1.12 gtk+-2.0 >= 2.11.0) were not met:

Requested 'gtk+-2.0 >= 2.11.0' but version of GTK+ is 2.10.11

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GDKMM_CFLAGS
and GDKMM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


mais eu ja tenho o glibmm atualizado e o glib-2.0 tb, tenhu ate versões superiores a essa e ele fala q requer atualização, num to sabendo oq fazer

e na hora de instalar o atk-1.20.0 ele tb descreve o seguinte erro, passarei ele todo desta vez:


checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether accepts -g... no
checking the maximum length of command line arguments... 98304
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC
checking if g++ PIC flag -fPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
checking for some Win32 platform... no
checking for native Win32 platform... no
checking for aclocal flags...
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.7... yes
checking for GLIB - version >= 2.5.7...
*** 'pkg-config --modversion glib-2.0' returned 2.13.5, but GLIB (2.12.11)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.7... yes
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.13.5, but GLIB (2.12.11)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.



sendo q eu ja tenho o glib-2.0, a minha versão é ate mas nova, dessa vez nem o synaptic num ta dando jeito, ajuda ae galera.
Abraço



12. Re: instalação glib-2.10.0

V.H.Borges
victorborges

(usa Outra)

Enviado em 22/05/2008 - 08:08h

tenta um ldconfig...depois compila de novo



01 02