Ubuntu não inicia sem o HD IDE [RESOLVIDO]

1. Ubuntu não inicia sem o HD IDE [RESOLVIDO]

Gabriel Leal
Leal69

(usa Ubuntu)

Enviado em 02/12/2010 - 02:22h

ola
então acontece assim
tenho um HD IDE de 80G que estava me servindo para guardar arquivos e agora peguei um SATA 160G
então iria passar esse IDE para outro pc que só tem entrada IDE

passei os arquivos do IDE para o SATA e foi formata e desmontar o IDE (que por sinal era NTFS) ele não queria desmontar injuriado com isso entrei no terminal dei um sudo umount /media/sda1 e desmontei ele formatei e desliguei o pc para retira-lo... ai veio a surpresa... após retirar o IDE o Ubuntu não subiu não deu sinal de "vida" fico em uma tela preta com uma barrinha transversal branca e não saiu disso
logo desliguei a maquina e coloquei o IDE de volta o Ubuntu inicia só que antes de iniciar realmente ele fala que o volume /media/sda1 não esta pronto se eu desejo pular a montagem ou desejo montar manualmente...

como não sou tão ingénuo assim procurei a pasta media e achei o bendito sda1 lá só que vazio... tentei desmonta-lo novamente e aparece que ele não está montado segundo o "mtab" fiz diversas coisas e não achei uma resolução então peço a vocês uma ajuda já que sem o IDE o sistema não inicia....

mais alguns detalhes
esse HD IDE (o bendito /media/sda1) estava no pc quando instalei o Ubuntu ele já estava em NTFS pois usava ele no Windows... o programa que uso para usar NTFS é o ntfs-3g

meu problema
tirar o IDE e conseguir iniciar o Sistema Operacional.


dês de já agradeço a ajuda de todos...


  


2. Re: Ubuntu não inicia sem o HD IDE [RESOLVIDO]

Néscio Ignorante
Ignorante

(usa Slackware)

Enviado em 02/12/2010 - 07:18h

Pelo que entendi, vc só quer tirar esse HD IDE e iniciar o sistema normalmente, Tire o HD IDE e coloque um CD Live do Ubuntu, e reinstale o Grub na MBR.

Espero ter ajudado


3. Ubuntu não inicia sem o HD IDE

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 02/12/2010 - 12:13h

Não existe ninguém mais ou menos ingênuo, existe o cara que está avisado (pelos amigos) ou pela própria experiência.
-O CASO É O SEGUINTE:
O computador quando liga, tem uma genética ( B.I.O.S Basic Input Output System) que leva a leitura pra a trilha zero do disco zero também conhecida como MBR master boot record.
Essa trilha manda ele para a tabela de boot (No Linux /boot/grub/menu.lst ou /boot/grub/grub.cfg- No windows \boot.ini).

A tabela de boot manda o computador para ler o kernel, ou algum arquivo que de acesso ao kernel.

Erros:
A trilha zero não contém o endereço do boot. Óbvio: você arrancou o seu disco zero e com ele a trilha zero do disco zero, onde eatava o endereço da tabela de boot. A máquina ficou perdida e não achou NADA, e parou.

Você pode reinstalar o grub a partir do live CD do Linux.
Melh0r procurar instruções sobre grub ou grub2 na busca do VOL.

2-Outro erro:
A montagem automa´tica fica anotada no /etc/fstab
Se você fizer alterações na partição precisa reenderaçar o /etc/fstab , senão a máquina não acha a partição e dá erro.
Boa sorte


4. Re: Ubuntu não inicia sem o HD IDE [RESOLVIDO]

Gabriel Leal
Leal69

(usa Ubuntu)

Enviado em 02/12/2010 - 12:14h

Adriano Winkler

tentei fazer isso que me disse do Grub na MBR mais não consegui fiz por um pendrive com live e não consegui

muito obrigado pela ajuda


5. Re: Ubuntu não inicia sem o HD IDE [RESOLVIDO]

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 02/12/2010 - 12:18h

Deopois do boot de live cd ou de penderive.

No gnome ou kde vá em adminstração, procure "usuários e grupos"
Procure root
defina uma senha para o root , se você ainda não definiu, de definiu pule para o passo seguinte:
No terminal digite
su
grub-install /dev/sda


ou
sudo grub-install /dev/sda
Boa sorte.




6. Re: Ubuntu não inicia sem o HD IDE [RESOLVIDO]

Gabriel Leal
Leal69

(usa Ubuntu)

Enviado em 02/12/2010 - 12:20h

nicolo

então o Ubuntu não estava instalado nesse HD IDE e sim em um Sata que já possuía esse IDE era somente para arquivos como músicas e seriados como ele lotou eu peguei um Sata maior e passei os arquivos para me livrar do IDE só que ao tirar ele o Ubuntu não sobe...
tentei iniciando pela live mudar o grub mas não consegui


7. Re: Ubuntu não inicia sem o HD IDE [RESOLVIDO]

Gabriel Leal
Leal69

(usa Ubuntu)

Enviado em 02/12/2010 - 12:28h

Nicolo

da o seguinte erro (estou no live agora)

"ubuntu@ubuntu:~$ sudo grub-install /dev/sda
/usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?)."



8. Re: Ubuntu não inicia sem o HD IDE [RESOLVIDO]

Gabriel Leal
Leal69

(usa Ubuntu)

Enviado em 02/12/2010 - 12:54h

bom estou postando o que tento...

root@ubuntu:/home/ubuntu# grub-install --root-directory=/media/sdb1 /dev/sda
Probing devices to guess BIOS drives. This may take a long time.
Could not find device for /media/sdb1/boot: Not found or not a block device.



9. Re: Ubuntu não inicia sem o HD IDE [RESOLVIDO]

Gabriel Leal
Leal69

(usa Ubuntu)

Enviado em 02/12/2010 - 17:39h

RESOLVIDO

fiquei de saco cheio e formatei coloquei o Ubuntu novamente agora ele acha o arquivo de boot obrigado pela ajuda de todos....






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts