Problemas ao adicionar PPA's no Linux Mint Mate!

1. Problemas ao adicionar PPA's no Linux Mint Mate!

Jeferson Duarte de Oliveira
JefinhoRedHat

(usa Linux Mint)

Enviado em 26/09/2017 - 22:39h

Sou iniciante no Linux, instalei a versão do Linux Mint Cinnamon há poucos dias, mas estava com um problema para adicionar os PPA's dos programas, e consequentemente não conseguia instalar os programas.
Quase sempre que eu ia adicionar um PPA, me aparecia um erro dizendo "Could not host name: launchpad.net".
Já tentei resolver este erro de várias maneiras, desabilitei o firewall, dei um apt-get clean && apt-get update, e todos os comandos afins.
Por fim, resolvi instalar a versão do Mate, estou usando o Kernell 4.8, e mesmo assim o problema continua, e a minha maior dificuldade é que em alguns casos eu consegui adicionar, tipo no do Java, ppa:webupd8team/java. Este eu consegui.
Alguém aqui já passou por este problema ? porque até um professor da minha faculdade disso que nunca tinha ocorrido este tipo de erro com ele!
Vou deixar aqui um print que eu tirei da minha tela relatando este erro!
https://imgur.com/a/mkUJQ


  


2. Re: Problemas ao adicionar PPA's no Linux Mint Mate!

Paulo Jr
Pebis

(usa Debian)

Enviado em 26/09/2017 - 23:15h



proxy???


3. Re: Problemas ao adicionar PPA's no Linux Mint Mate!

Klauss Krenek
klauss.krenek

(usa Debian)

Enviado em 27/09/2017 - 00:17h

Antes de adicionar um PPA, você deve verificar se o mesmo está disponível e atualizado para versão do sistema que você está usando. Por exemplo, o Linux Mint é baseado na versão 16.04 (Xenial) do Ubuntu. Então o PPA deve ter a versão para o Xenial disponível.

Esse PPA do Paolo Roloto apesar de possuir a versão para o Xenial, está defasado, conforme o github do mesmo.
https://github.com/PaoloRotolo/android-studio

E ele mesmo recomenda usar o ubuntu-make
https://github.com/ubuntu/ubuntu-make

Remova o PPA do Paolo e adicione o Ubuntu Make:
sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
sudo apt update
umake android




4. Re: Problemas ao adicionar PPA's no Linux Mint Mate!

Vinicius Araujo Lopes
viniciusalopes

(usa Ubuntu)

Enviado em 27/09/2017 - 01:38h

Opa!
Você digitou o comando errado!
Ao invés de
add-apt-repository 
você digitou
apt-add-repository 

Acesse o site do Paolo Rotolo e siga as instruções da página. Lá tem até a opção de sources.list para a versão do seu mint (Xenial 16.04)
Link: https://launchpad.net/~paolorotolo/+archive/ubuntu/android-studio

 __________________________________
/ Apresente soluções! \
| Opiniões não resolvem problemas. |
| |
\ --Viniciusalopes /
---------------------------------
\ ^__^
\ (oo)\_______
(__) )/\/
||----w |
|| ||



5. Re: Problemas ao adicionar PPA's no Linux Mint Mate!

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 27/09/2017 - 06:59h

-sugiro não usar ppa p/ instalar programas disponíveis nos repositórios oficiais
-lembre-se que ppa são mantidos por terceiros que podem deixar de atualizar os mesmos
-dessa forma vc terá problemas com atualizações do seu sistema também





6. Re: Problemas ao adicionar PPA's no Linux Mint Mate!

Jeferson Duarte de Oliveira
JefinhoRedHat

(usa Linux Mint)

Enviado em 27/09/2017 - 15:16h

klauss.krenek escreveu:

Antes de adicionar um PPA, você deve verificar se o mesmo está disponível e atualizado para versão do sistema que você está usando. Por exemplo, o Linux Mint é baseado na versão 16.04 (Xenial) do Ubuntu. Então o PPA deve ter a versão para o Xenial disponível.

Esse PPA do Paolo Roloto apesar de possuir a versão para o Xenial, está defasado, conforme o github do mesmo.
https://github.com/PaoloRotolo/android-studio

E ele mesmo recomenda usar o ubuntu-make
https://github.com/ubuntu/ubuntu-make

Remova o PPA do Paolo e adicione o Ubuntu Make:
sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
sudo apt update
umake android



Cara, tentei adicionar o PPA do ubuntu-make e deu exatamente o mesmo erro, este que é problema.
" Não foi possível adicionar o PPA: '"Error reading https://launchpad.net/api/1.0/~ubuntu-desktop/+archive/ubuntu-make: (6, 'Could not resolve host: launchpad.net')"'. "




7. Re: Problemas ao adicionar PPA's no Linux Mint Mate!

Jeferson Duarte de Oliveira
JefinhoRedHat

(usa Linux Mint)

Enviado em 27/09/2017 - 15:17h

clodoaldops escreveu:

-sugiro não usar ppa p/ instalar programas disponíveis nos repositórios oficiais
-lembre-se que ppa são mantidos por terceiros que podem deixar de atualizar os mesmos
-dessa forma vc terá problemas com atualizações do seu sistema também




Entendi, e qual seria a melhor opção para fazer a instalação de programas?




8. Re: Problemas ao adicionar PPA's no Linux Mint Mate!

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 27/09/2017 - 17:07h

-qais programas vc deseja instalar que não estão disponiveis no gerenciador/pacotes ou gerenciador/aplicativos ?


9. Re: Problemas ao adicionar PPA's no Linux Mint Mate!

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 01/10/2017 - 08:31h

Eu não adiciono PPAs. Vou direto no "site" do PPA e baixo o arquivo .deb desejado e sugerido pelo autor. O único problema seria a não atualização automática do software. Como eu sou um cara desatualizado por natureza, isso não é problema. Nem sempre uma versão mais nova funciona melhor.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts