Problema no boot!!! O que devo fazer? (Slackware 12.0)

1. Problema no boot!!! O que devo fazer? (Slackware 12.0)

Daniel Nascimento Souza
daniel1212

(usa Slackware)

Enviado em 16/01/2008 - 03:54h

Enviado em 16/01/2008 - 03:44h:
Problema com o boot!! O que fazer?

Olha eu segui 2 dicas para resolver o meu problema:

1°:Usei esses tipos de comandos:
# rm -R /boot
# mkdir /mnt/temp
# mount /dev/hdxy /mnt/temp (substitua hdxy por sua partição Linux)
# ln -s /mnt/temp/boot /
# lilo -C /mnt/temp/etc/lilo.conf

Que podem ser encontrados nesse link: http://www.vivaolinux.com.br/dicas/verDica.php?cod...

2°:usei esses comandos:
# mount /dev/hdaX /mnt/
# chroot /mnt
# lilo

Que pode ser encontrado nesse link: http://www.vivaolinux.com.br/artigos/verArtigo.php....

Na 1° dica ocorre tudo bem até a penultima linha, quando eu digito o último comando (# lilo -C /mnt/temp/etc/lilo.conf) dá esse erro: "Fatal: creat /boot/map~: Too many levels of symbolic links".

Então fui atraz de outra dica...

Na 2° dica quando eu digito o primeiro comando aparece isso:
"mount: /dev/hda1 already mounted or /mnt/ busy
mount: according to mtab, /dev/hda1 is mounted on /".
Ok.. Isso para mim não foi um erro... continuei o comando.. quando eu digitei o último (# lilo) ai ocorre o erro:
Warning: '/proc/partitions' does not exist, disk scan bypassed
Fatal: creat /boot/map~: No such file or directory

Por favor me ajudem!!! Não aguento mais dar boot pelo CD!
O que eu devo fazer para resolver eese problema?


  


2. Re: Problema no boot!!! O que devo fazer? (Slackware 12.0)

Sandro Marcell
SMarcell

(usa Slackware)

Enviado em 16/01/2008 - 11:28h

# rm -R /boot

Você removeu o diretório /boot que é necessário para a inicialização do sistema.

Reinstale o S.O. novamente.


3. pequena dica

Leandro Correa dos Santos
nukelinux

(usa Ubuntu)

Enviado em 16/01/2008 - 13:43h

use o grub como gerenciador de boot
ele tem mais recursos e detecta mais facilmente os sistemas


4. Re: Problema no boot!!! O que devo fazer? (Slackware 12.0)

Daniel Nascimento Souza
daniel1212

(usa Slackware)

Enviado em 16/01/2008 - 13:47h

como que eu instalo o grub??


5. Re: Problema no boot!!! O que devo fazer? (Slackware 12.0)

Elias Zoby
zoby

(usa Slackware)

Enviado em 20/01/2008 - 15:49h

Só pode ser piada sua ou brincadeira suja de quem o mandou remover /boot. É óbvio q o Lilo não pode registrar um negócio q não existe mais.
Não me lembro c/o é no Slack 12, mas no 10.2 o Grub está na pasta de extras. Tb pode ser baixado do próprio www.slackware.com Mas tem de reinstalar pelo menos os diretórios q vc removeu.


6. Re: Problema no boot!!! O que devo fazer? (Slackware 12.0)

Leandro Santiago
tenchi

(usa Slackware)

Enviado em 20/01/2008 - 16:10h

Ih kra. Tome cuidado com o que removes. Removendo o diretório /boot, acabou apagando o diretório que contém a imagem do kernel. Assim, não vai conseguir nem dar boot!

Provavelmente tais passos eram para ser executados a partir de um liveCD, e se cv executou a partir da instalação com problemas, já era. O jeito mais fácil para você será reinstalar o sistema, como disse o SMarcell.


7. /boot

Franklin Candido da Silva
franklincsilva

(usa Ubuntu)

Enviado em 26/01/2009 - 09:50h

Cara, o que você estava tentando fazer com o comando

rm -R /boot?

Não sabe que esta ai é a area responsável pela inicialização do teu Sistema, não é mudando do lilo pro glub que tu vai resolver teus problemas, o que tem te fazer é observar com mais atenção, okay!

Mais é isso ai mesmo, isso ocorre...






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts