Problema no Linux Mint [RESOLVIDO]

1. Problema no Linux Mint [RESOLVIDO]

Fernando Shoiti Katayama
Blackcat5570

(usa Linux Mint)

Enviado em 13/06/2021 - 09:32h

Bom dia,

Estou usando o Linux Mint a pouco tempo não consigo instalar programas pelo terminal, devido a este erro:
E: Não foi possível abrir arquivo de trava /var/lib/dpkg/lock-frontend - open (13: Permissão negada)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

Em outros fóruns sites foi sugerido estes comandos e os seguintes resultados foram obtidos
sudo kill -9 id_processo
kill: falha ao analisar argumento: 'id_processo'

sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo rm /var/lib/dpkg/lock-frontend
sudo rm /var/cache/apt/archives/lock
rm: não foi possível remover '/var/cache/apt/archives/lock': Arquivo ou diretório inexistente

sudo lsof /var/lib/dpkg/lock
sof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
lsof: status error on /var/lib/dpkg/lock: No such file or directory
lsof 4.93.2
latest revision: https://github.com/lsof-org/lsof
latest FAQ: https://github.com/lsof-org/lsof/blob/master/00FAQ
latest (non-formatted) man page: https://github.com/lsof-org/lsof/blob/master/Lsof.8
usage: [-?abhKlnNoOPRtUvVX] [+|-c c] [+|-d s] [+D D] [+|-E] [+|-e s] [+|-f[gG]]
[-F [f]] [-g [s]] [-i [i]] [+|-L [l]] [+m [m]] [+|-M] [-o [o]] [-p s]
[+|-r [t]] [-s [p:s]] [-S [t]] [-T [t]] [-u s] [+|-w] [-x [fl]] [--] [names]
Use the ``-h'' option to get more help information.

ps aux | grep apt
root 806 0.0 0.2 126260 9328 ? Ssl 08:22 0:00 /usr/sbin/thermald --systemd --dbus-enable --adaptive
1095398 0.0 0.0 9060 732 pts/0 S+ 08:48 0:00 grep --color=auto apt

Foram estas as tentativas se alguem puder ajudar ficarei muito agradecido.


  


2. Re: Problema no Linux Mint [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 13/06/2021 - 09:40h

-tente desbloquear o apt

sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo apt-get update
sudo apt-get upgrade




3. Re: Problema no Linux Mint [RESOLVIDO]

Diego Mendes Rodrigues
diegomrodrigues

(usa Ubuntu)

Enviado em 13/06/2021 - 09:47h

Primeiro execute:

$sudo rm -rf /var/lib/apt/lists/lock
$sudo apt-get update


Agora, tente voltar para a instalação que você estava fazendo, caso o problema persista, passe para o próximo passo.

$ sudo dpkg --configure -a
$ sudo apt-get -f install


Atenciosamente,
Diego M. Rodrigues


4. Re: Problema no Linux Mint [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 13/06/2021 - 10:01h


...are you root?

Está usando o sudo ou tornando-se root antes de tentar atualizar/instalar?


5. Problema no Linux Mint

Fernando Shoiti Katayama
Blackcat5570

(usa Linux Mint)

Enviado em 13/06/2021 - 10:12h


Para os Comandos foi dada as seguintes respostas

sudo rm /var/lib/apt/lists/lock
rm: não foi possível remover '/var/lib/apt/lists/lock': Arquivo ou diretório inexistente

sudo rm /var/lib/dpkg/lock
rm: não foi possível remover '/var/lib/dpkg/lock': Arquivo ou diretório inexistente

sudo apt-get update
Atingido:1 http://dl.google.com/linux/chrome/deb stable InRelease
Ign:2 http://packages.linuxmint.com ulyssa InRelease
Atingido:3 http://archive.canonical.com/ubuntu focal InRelease
Atingido:4 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal InRelease
Ign:5 http://ddebs.ubuntu.com focal InRelease
Atingido:6 http://packages.linuxmint.com ulyssa Release
Obter:7 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Ign:8 http://repo.vivaldi.com/stable/deb stable InRelease
Atingido:9 http://repo.vivaldi.com/stable/deb stable Release
Ign:13 http://ddebs.ubuntu.com focal-updates InRelease
Atingido:14 http://ddebs.ubuntu.com focal Release
Atingido:16 http://ddebs.ubuntu.com focal-updates Release
Obter:11 https://repos.codelite.org/wx3.0.2/ubuntu trusty InRelease [2.891 B]
Err:11 https://repos.codelite.org/wx3.0.2/ubuntu trusty InRelease
As seguintes assinaturas eram inválidas: 7716412FB5B50060D47CF42B6856E1DB1AC82609
Atingido:18 http://archive.linux.duke.edu/ubuntu focal InRelease
Obter:19 http://archive.linux.duke.edu/ubuntu focal-updates InRelease [114 kB]
Obter:20 http://archive.linux.duke.edu/ubuntu focal-backports InRelease [101 kB]
Obter:21 http://archive.linux.duke.edu/ubuntu focal-updates/main amd64 DEP-11 Metadata [283 kB]
Obter:22 http://archive.linux.duke.edu/ubuntu focal-updates/universe amd64 DEP-11 Metadata [330 kB]
Obter:23 http://archive.linux.duke.edu/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [2.468 B]
Obter:24 http://archive.linux.duke.edu/ubuntu focal-backports/universe amd64 DEP-11 Metadata [1.768 B]
Lendo listas de pacotes... Pronto
W: Erro GPG: https://repos.codelite.org/wx3.0.2/ubuntu trusty InRelease: As seguintes assinaturas eram inválidas: 7716412FB5B50060D47CF42B6856E1DB1AC82609
E: The repository 'http://repos.codelite.org/wx3.0.2/ubuntu trusty InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

sudo apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os pacotes a seguir serão atualizados:
google-chrome-stable vivaldi-stable
2 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso baixar 168 MB de arquivos.
Depois desta operação, 779 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Obter:1 http://dl.google.com/linux/chrome/deb stable/main amd64 google-chrome-stable amd64 91.0.4472.101-1 [83,6 MB]
Obter:2 http://repo.vivaldi.com/stable/deb stable/main amd64 vivaldi-stable amd64 4.0.2312.27-1 [84,3 MB]
Baixados 168 MB em 8min 48s (318 kB/s)
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Lendo banco de dados ... 368742 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../google-chrome-stable_91.0.4472.101-1_amd64.deb ...
A descompactar google-chrome-stable (91.0.4472.101-1) sobre (91.0.4472.77-1) ...
A preparar para desempacotar .../vivaldi-stable_4.0.2312.27-1_amd64.deb ...
A descompactar vivaldi-stable (4.0.2312.27-1) sobre (4.0.2312.24-1) ...
Configurando google-chrome-stable (91.0.4472.101-1) ...
Configurando vivaldi-stable (4.0.2312.27-1) ...
Configurando libvirt-daemon-system (6.0.0-0ubuntu8.9) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: erro ao processar o pacote libvirt-daemon-system (--configure):
o subprocesso instalado, do pacote libvirt-daemon-system, o script post-installation retornou erro do status de saída 1
A processar 'triggers' para mime-support (3.64ubuntu1) ...
A processar 'triggers' para gnome-menus (3.36.0-1ubuntu1) ...
A processar 'triggers' para man-db (2.9.1-1) ...
A processar 'triggers' para desktop-file-utils (0.24+linuxmint1) ...
Erros foram encontrados durante o processamento de:
libvirt-daemon-system
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo rm -rf /var/lib/apt/lists/lock
sudo apt-get update
Atingido:1 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal InRelease
Atingido:2 http://archive.canonical.com/ubuntu focal InRelease
Obter:3 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Ign:4 http://packages.linuxmint.com ulyssa InRelease
Atingido:5 http://packages.linuxmint.com ulyssa Release
Atingido:8 http://archive.linux.duke.edu/ubuntu focal InRelease
Atingido:9 http://archive.linux.duke.edu/ubuntu focal-updates InRelease
Atingido:10 http://archive.linux.duke.edu/ubuntu focal-backports InRelease
Obter:6 https://repos.codelite.org/wx3.0.2/ubuntu trusty InRelease [2.891 B]
Err:6 https://repos.codelite.org/wx3.0.2/ubuntu trusty InRelease
As seguintes assinaturas eram inválidas: 7716412FB5B50060D47CF42B6856E1DB1AC82609
Atingido:11 http://dl.google.com/linux/chrome/deb stable InRelease
Ign:12 http://ddebs.ubuntu.com focal InRelease
Ign:13 http://repo.vivaldi.com/stable/deb stable InRelease
Ign:14 http://ddebs.ubuntu.com focal-updates InRelease
Atingido:15 http://repo.vivaldi.com/stable/deb stable Release
Atingido:16 http://ddebs.ubuntu.com focal Release
Atingido:18 http://ddebs.ubuntu.com focal-updates Release
Lendo listas de pacotes... Pronto
W: Erro GPG: https://repos.codelite.org/wx3.0.2/ubuntu trusty InRelease: As seguintes assinaturas eram inválidas: 7716412FB5B50060D47CF42B6856E1DB1AC82609
E: The repository 'http://repos.codelite.org/wx3.0.2/ubuntu trusty InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

sudo dpkg --configure -a
Configurando libvirt-daemon-system (6.0.0-0ubuntu8.9) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: erro ao processar o pacote libvirt-daemon-system (--configure):
o subprocesso instalado, do pacote libvirt-daemon-system, o script post-installation retornou erro do status de saída 1
Erros foram encontrados durante o processamento de:
libvirt-daemon-system

sudo apt-get -f install

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Configurando libvirt-daemon-system (6.0.0-0ubuntu8.9) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: erro ao processar o pacote libvirt-daemon-system (--configure):
o subprocesso instalado, do pacote libvirt-daemon-system, o script post-installation retornou erro do status de saída 1
Erros foram encontrados durante o processamento de:
libvirt-daemon-system
E: Sub-process /usr/bin/dpkg returned an error code (1)



6. Re: Problema no Linux Mint [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 13/06/2021 - 11:50h

1- fontes de aplicativos >> ppa >> desative todos ppa problemáticos >>
2- fontes de aplicativos >> repositórios adicionais >> desmarque repositórios problemáticos
3-atualize novamente



7. Re: Problema no Linux Mint [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 13/06/2021 - 14:05h

Para descobrir qual processo está utilizando o debcon faça:

sudo fuser -v /var/cache/debconf/config.dat

quando mostrar o numero do processo (PID)

faça:

sudo kill -9 PID <<<< aonde PID é o número do processo encontrado com o comando acima.

sudo apt update && sudo apt full-upgrade