Não consigo pingar máquina virtual (vmware, virtualbox)

1. Não consigo pingar máquina virtual (vmware, virtualbox)

Warllen Emanoel Damascena Castro
warllencastro

(usa Linux Mint)

Enviado em 03/12/2020 - 08:34h

Caríssimos,
Poderiam me ajudar?
Estou com uma grande dificuldade por ser iniciante no Linux. Preciso de 3 máquinas virtuais com adaptador de rede interno, sendo:
VM1 com o IP 192.168.10.2, Sub 255.255.255.0 Gt 192.168.10.1
VM2 com o IP 192.168.20.2, Sub 255.255.255.0 Gt 192.168.20.1
VM3 (Servidor) com duas placas de rede interna o IP 192.168.10.1, Sub 255.255.255.0 Gt 192.168.10.1 e a segunda placa com o IP 192.168.20.1 Sub 255.255.255.0 Gt 192.168.20.1

O servidor (VM3) pinga ambas as máquinas (VM1 e 2) e ambas as máquinas pingam o servidor. No Entanto, eu precisaria que a VM1 pingue a VM2 e isso não acontece nem pelo PING nem pelo MTR.
Estou utilizando a distr Linux Mint MATE 64x. Seja pela Live ISO seja instalando a distr, seja pelo VMware, seja pelo Virtual box, o problema persiste. Me perdoe a ignorância.


  


2. Re: Não consigo pingar máquina virtual (vmware, virtualbox)

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 03/12/2020 - 09:47h


tem que ter um roteamento na VM pra vm 1 pingar a vm2



3. Re: Não consigo pingar máquina virtual (vmware, virtualbox)

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 03/12/2020 - 10:00h

warllencastro escreveu:

Caríssimos,
Poderiam me ajudar?
Estou com uma grande dificuldade por ser iniciante no Linux. Preciso de 3 máquinas virtuais com adaptador de rede interno, sendo:
VM1 com o IP 192.168.10.2, Sub 255.255.255.0 Gt 192.168.10.1
VM2 com o IP 192.168.20.2, Sub 255.255.255.0 Gt 192.168.20.1
VM3 (Servidor) com duas placas de rede interna o IP 192.168.10.1, Sub 255.255.255.0 Gt 192.168.10.1 e a segunda placa com o IP 192.168.20.1 Sub 255.255.255.0 Gt 192.168.20.1

O servidor (VM3) pinga ambas as máquinas (VM1 e 2) e ambas as máquinas pingam o servidor. No Entanto, eu precisaria que a VM1 pingue a VM2 e isso não acontece nem pelo PING nem pelo MTR.
Estou utilizando a distr Linux Mint MATE 64x. Seja pela Live ISO seja instalando a distr, seja pelo VMware, seja pelo Virtual box, o problema persiste. Me perdoe a ignorância.

Vc pode fazer em vm1
sudo route add -net 192.168.20.0 netmask 255.255.255.0 gw 192.168.10.1
Se der certo depois vc persiste





4. Re: Não consigo pingar máquina virtual (vmware, virtualbox)

Warllen Emanoel Damascena Castro
warllencastro

(usa Linux Mint)

Enviado em 03/12/2020 - 11:54h

danniel-lara escreveu:


tem que ter um roteamento na VM pra vm 1 pingar a vm2



Meu caro, sabe me informar qual linha de comando deve executar?


5. Re: Não consigo pingar máquina virtual (vmware, virtualbox)

Warllen Emanoel Damascena Castro
warllencastro

(usa Linux Mint)

Enviado em 03/12/2020 - 11:55h

leandropscardua escreveu:

warllencastro escreveu:

Caríssimos,
Poderiam me ajudar?
Estou com uma grande dificuldade por ser iniciante no Linux. Preciso de 3 máquinas virtuais com adaptador de rede interno, sendo:
VM1 com o IP 192.168.10.2, Sub 255.255.255.0 Gt 192.168.10.1
VM2 com o IP 192.168.20.2, Sub 255.255.255.0 Gt 192.168.20.1
VM3 (Servidor) com duas placas de rede interna o IP 192.168.10.1, Sub 255.255.255.0 Gt 192.168.10.1 e a segunda placa com o IP 192.168.20.1 Sub 255.255.255.0 Gt 192.168.20.1

O servidor (VM3) pinga ambas as máquinas (VM1 e 2) e ambas as máquinas pingam o servidor. No Entanto, eu precisaria que a VM1 pingue a VM2 e isso não acontece nem pelo PING nem pelo MTR.
Estou utilizando a distr Linux Mint MATE 64x. Seja pela Live ISO seja instalando a distr, seja pelo VMware, seja pelo Virtual box, o problema persiste. Me perdoe a ignorância.

Vc pode fazer em vm1
sudo route add -net 192.168.20.0 netmask 255.255.255.0 gw 192.168.10.1
Se der certo depois vc persiste




Leando,

Fiz conforme vossa orientação, no entanto, o problema persiste.


6. Não consigo pingar máquina virtual (vmware, virtualbox)

Warllen Emanoel Damascena Castro
warllencastro

(usa Linux Mint)

Enviado em 03/12/2020 - 12:28h

Caríssimos!

Descobri qual era o vilão do procedimento.

O arquivo IP_FORWARD (/proc/sys/net/ipv4) estava setado como 0, assim, não permitia a passagem de pacotes da VM1 para VM2 através do GW (VM3). Após setar com o valor "1" os equipamentos começaram a se comunicar.

Obrigado pelas dicas de todos.

Abraços!







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts