Nâo condsigo atualizar o java

1. Nâo condsigo atualizar o java

Rosivalda Barreto
Rosivalda

(usa KUbuntu)

Enviado em 27/03/2016 - 02:07h

Prezados(as), bom dia!
Uso o linux ubuntu de 32 bits.
Não consigo acessar a aŕea de trabalho do meu banco com problemas de configuração para atualização do java.
A mensagem que aparece é esta: dpkg: error processing package oracle-java8-set-default (--configure):
problemas de dependência - deixando desconfigurado. Isto depois de informar que o tempo esgotadopara a conexão.
Segue abaixo mensagem completa:
Configurando oracle-java8-installer (8u77+8u77arm-1~webupd8~1) ...
Downloading Oracle Java 8...
--2016-03-26 17:25:57-- http://download.oracle.com/otn-pub/java/jdk/8u77-b03/jdk-8u77-linux-i586.tar.gz
Resolvendo download.oracle.com (download.oracle.com)... falhou: Tempo esgotado para conexão.
wget: não foi possível resolver endereço de máquina “download.oracle.com”
download failed
Oracle JDK 8 is NOT installed.
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
dpkg: error processing package oracle-java8-installer (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas com dependências impedem a configuração de oracle-java8-set-default:
oracle-java8-set-default depende de oracle-java8-installer; porém:
Pacote oracle-java8-installer não está configurado ainda.

dpkg: error processing package oracle-java8-set-default (--configure):
problemas de dependência - deixando desconfigurado
E: Sub-process /usr/bin/dpkg returned an error code (1)

Se alguém puder me ajudar deste já agradeço1




  


2. Nâo condsigo atualizar o java

Fernando T. Da Silva
nandosilva

(usa Lubuntu)

Enviado em 27/03/2016 - 08:59h

Baixe o java no site oficial direto pelo navegador: http://www.java.com/pt_BR/download/linux_manual.jsp
e instale manualmente.

Faça o link para o plugin do java no seu navegador, crie um link para o comando java e jcontrol em /usr/local/bin

É o método que sempre utilizo no meu computador.


3. Re: Nâo condsigo atualizar o java

Rosivalda Barreto
Rosivalda

(usa KUbuntu)

Enviado em 28/03/2016 - 00:12h

nandosilva escreveu:

Baixe o java no site oficial direto pelo navegador: http://www.java.com/pt_BR/download/linux_manual.jsp
e instale manualmente.

Faça o link para o plugin do java no seu navegador, crie um link para o comando java e jcontrol em /usr/local/bin

É o método que sempre utilizo no meu computador.


Prezado, boa noite!
Vc poderia me dizer o passo a passo, primeiro para a instalação do java e depois para fazer o link para o plugin. So verdadeiramente iniciante.

Rosivalda!
Grata




4. Re: Nâo condsigo atualizar o java

Marcelo Oliver
msoliver

(usa Debian)

Enviado em 28/03/2016 - 13:08h

Rosivalda escreveu:

Prezados(as), bom dia!
Uso o linux ubuntu de 32 bits.
Não consigo acessar a aŕea de trabalho do meu banco com problemas de configuração para atualização do java.
A mensagem que aparece é esta: dpkg: error processing package oracle-java8-set-default (--configure):
problemas de dependência - deixando desconfigurado. Isto depois de informar que o tempo esgota do para a conexão.
Segue abaixo mensagem completa:
Configurando oracle-java8-installer (8u77+8u77arm-1~webupd8~1) ...
Downloading Oracle Java 8...
--2016-03-26 17:25:57-- http://download.oracle.com/otn-pub/java/jdk/8u77-b03/jdk-8u77-linux-i586.tar.gz
Resolvendo download.oracle.com (download.oracle.com)... falhou: Tempo esgotado para conexão.
wget: não foi possível resolver endereço de máquina “download.oracle.com”
download failed
Oracle JDK 8 is NOT installed.
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
dpkg: error processing package oracle-java8-installer (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas com dependências impedem a configuração de oracle-java8-set-default:
oracle-java8-set-default depende de oracle-java8-installer; porém:
Pacote oracle-java8-installer não está configurado ainda.

dpkg: error processing package oracle-java8-set-default (--configure):
problemas de dependência - deixando desconfigurado
E: Sub-process /usr/bin/dpkg returned an error code (1)
Se alguém puder me ajudar deste já agradeço1

----------------------------------------------------------------------------------------------------

Boa tarde Rosivalda.

O LINK da sua mensagem:
http://download.oracle.com/otn-pub/java/jdk/8u77-b03/jdk-8u77-linux-i586.tar.gz
Está "quebrado"
O link CORRETO, é:
http://javadl.oracle.com/webapps/download/AutoDL?BundleId=207219

CASO queira adicionar o repositório e fazer pelo APT,:
Segue o PASSO a PASSO:
sudo add-apt-repository ppa:webupd8team/java
#ADICIONA CHAVE
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886
sudo apt-get update
sudo apt-get install oracle-java8-installer
#CONFIGURA:
sudo apt-get install oracle-java8-set-default
#VERIFICA VERSÃO:
java -version


Se resolver, marque como resolvido, por favor.
Gostando da resposta, marque-a como MELHOR, dessa forma, ganho uns pontinhos,
o que incentiva a continuar colaborando, ajudando, participando e compartilhando conhecimentos . . . :)


Att.:
Marcelo









Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts