Erro na hora de instalar linux-headers [RESOLVIDO]

1. Erro na hora de instalar linux-headers [RESOLVIDO]

Pedro
PcPYeP

(usa Outra)

Enviado em 12/01/2017 - 02:54h

Então, primeiro Obrigado :D
Segundo, eu estou tentando configurar o (a?) kali sana (Se não me engano é esse o nome), meu kernel é

"4.6.0-kali1-amd64"

e quando eu digito o comando

"apt-get install kernel-headers-$(uname -r)"


aparece a seguinte mensagem:

"Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote kernel-headers-4.6.0-kali1-amd64
E:Couldn't find any package by glob 'kernel-headers-4.6.0-kali1-amd64'
E:Não foi possível encontrar o pacoa através da expressão regular 'kernel-headers-4.6.0-kali1-amd64'"

Meu sources.list:

"deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
deb-src http://http.kali.org/kali kali-rolling main contrib non-free

deb http://old.kali.org/kali sana main non-free contrib
# For source package access, uncomment the following line
deb-src http://old.kali.org/kali sana main non-free contrib

deb http://old.kali.org/kali moto main non-free contrib
# For source package access, uncomment the following line
deb-src http://old.kali.org/kali moto main non-free contrib

# deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 L$

#deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LI$"



Eu já usei os comandos "apt-get update" e "apt-get upgrade" e estou executando os comandos como root


  


2. Re: Erro na hora de instalar linux-headers [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 12/01/2017 - 07:40h

Kali 2 Sana já está obsoleto e sem atualizações
Instale Kali Rolling

*******************************************
Meu Blog
http://dicaslinuxmint.blogspot.com.br/


3. Re: Erro na hora de instalar linux-headers

Pedro
PcPYeP

(usa Outra)

Enviado em 13/01/2017 - 00:45h

clodoaldops escreveu:

Kali 2 Sana já está obsoleto e sem atualizações
Instale Kali Rolling

*******************************************
Meu Blog
http://dicaslinuxmint.blogspot.com.br/


Eu instalei Kali Rolling, mas continua com a mesma mensagem de erro :/

Edit:

Eu consegui arrumar o erro, pelo que eu entendi o problema era que o meu kernel era obsoleto, e eu arrumei usando o comando

"sudo apt-get -y dist-upgrade"






Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts