Erro em dpkg frontend [RESOLVIDO]

1. Erro em dpkg frontend [RESOLVIDO]

rafael
rgmprd

(usa elementary OS)

Enviado em 10/01/2021 - 01:52h

Olá!

Tenho um elementary OS Hera recém instalado e estou tentando instalar os programas.

Meu problema é semelhante ao deste tópico:
https://www.vivaolinux.com.br/topico/Iniciantes-no-Linux/dpkg-erro-dpkg-frontend-esta-bloqueado-por-...

Acho que foi após a instalação do apt-fast. Não entendo muito de linux mas ao tentar instalar o Snapd, aparece o seguinte:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
snapd is already the newest version (2.48+18.04).
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
cabextract libmspack0 python3-debconf python3-debian update-notifier-common
Utilize 'sudo apt autoremove' para os remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 1 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: erro ao processar o pacote apt-fast (--configure):
installed apt-fast package post-installation script subprocess returned error exit status 1
Erros foram encontrados durante o processamento de:
apt-fast
E: Sub-process /usr/bin/dpkg returned an error code (1)


Ao fazer "sudo apt upgrade", aparece a mensagem:

E: Não foi possível obter trava /var/lib/dpkg/lock-frontend - open (11: Recurso temporariamente indisponível)


Segui as dicas colocadas nesse tópico e tentei ver se era um problema neste tal de "dpkg". Não faço mínima ideia do que é isso.

Ao tentar "sudo dpkg --configure -a" o resultado é esse:

Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailabledpkg: erro ao processar o pacote apt-fast (--configure):installed apt-fast package post-installation script subprocess returned error exit status 1
Erros foram encontrados durante o processamento de:
apt-fast


Ao tentar "apt-get autoremove" e pelo que entendi o processo também não completa devido ao dpkg:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Os pacotes a seguir serão REMOVIDOS:
cabextract libmspack0 python3-debconf python3-debian update-notifier-common
0 pacotes atualizados, 0 pacotes novos instalados, 5 a serem removidos e 1 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 1.642 kB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Lendo banco de dados ... 189294 ficheiros e directórios actualmente instalados.)
A remover cabextract (1.6-1.1) ...
A remover libmspack0:amd64 (0.6-3ubuntu0.3) ...
A remover update-notifier-common (3.192.1.9) ...
A remover python3-debconf (1.5.66ubuntu1) ...
A remover python3-debian (0.1.32) ...
Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: erro ao processar o pacote apt-fast (--configure):
installed apt-fast package post-installation script subprocess returned error exit status 1
A processar 'triggers' para man-db (2.8.3-2ubuntu0.1) ...
A processar 'triggers' para libc-bin (2.27-3ubuntu1.4) ...
Erros foram encontrados durante o processamento de:
apt-fast
E: Sub-process /usr/bin/dpkg returned an error code (1)


EDIT: o problema persiste mesmo após reiniciar o OS

Aceito sugestões :)

Grato!


  


2. Re: Erro em dpkg frontend [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 10/01/2021 - 21:59h

Segundo a mensagem existe outro gerenciador de arquivos aberto. P ver quem é rode
sudo lsof /var/cache/debconf/config.dat


3. Re: Erro em dpkg frontend [RESOLVIDO]

rafael
rgmprd

(usa elementary OS)

Enviado em 10/01/2021 - 23:04h

Olá

leandropscardua escreveu:

Segundo a mensagem existe outro gerenciador de arquivos aberto. P ver quem é rode
sudo lsof /var/cache/debconf/config.dat


Segui sua dica e retornou o seguinte:

[email protected]:~# sudo lsof /var/cache/debconf/config.dat
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
lsof: WARNING: can't stat() fuse.portal file system /run/user/1000/doc
Output information may be incomplete.
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
frontend 17542 root 4uW REG 8,2 49240 4719212 /var/cache/debconf/config.dat


Observei que ele avisa alguns erros, que não está conseguindo acessar este "fuse.portal"...
Bom, como identificou alguma ID, tentei eliminar com o comando pra ver se era isso:

[email protected]:~# sudo kill 17542


E então voltei a tentar fazer a configuração do apt-fast, pra ver como está este programa, mas ao fazer o comando para configurar, o console fica parado na seguinte situação:

[email protected]:~# sudo dpkg --configure -a
Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...


Tentei então remover este programa, já que não consigo usar, mas deu novamente o erro de frontend.


apt-get remove apt-fast
E: Não foi possível obter trava /var/lib/dpkg/lock-frontend - open (11: Recurso temporariamente indisponível)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process u


A partir daí, ao seguir sua dica de novo, o processo que ele aponta é outro, mas como se pode ver abaixo, mesmo identificando o processo e terminando ele, não consigo remover pelo mesmo motivo, e o processo segue aparecendo novamente.

[email protected]:~# sudo lsof /var/cache/debconf/config.dat
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
lsof: WARNING: can't stat() fuse.portal file system /run/user/1000/doc
Output information may be incomplete.
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
frontend 13183 root 4uW REG 8,2 49240 4719212 /var/cache/debconf/config.dat
[email protected]:~# sudo kill 13283
[email protected]:~# apt-get remove apt-fast
E: Não foi possível obter trava /var/lib/dpkg/lock-frontend - open (11: Recurso temporariamente indisponível)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
[email protected]:~# sudo lsof /var/cache/debconf/config.dat
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
lsof: WARNING: can't stat() fuse.portal file system /run/user/1000/doc
Output information may be incomplete.
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
frontend 13183 root 4uW REG 8,2 49240 4719212 /var/cache/debconf/config.dat


Obs: não realizei nem percebi nenhuma atualização em andamento enquanto fazia estas tentativas.


4. Re: Erro em dpkg frontend [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 11/01/2021 - 18:13h

Não é necessário q haja uma atualização, apenas o aplicativo (q pode estar rodando como serviço). Tente
- matar todo mundo q gerencia pacotes
sudo killall apt apt-get
- remover arquivos de lock
sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock*
- recpnfigurar pacotes
sudo dpkg --configure -a
- atualizar
sudo apt update


5. Re: Erro em dpkg frontend [RESOLVIDO]

rafael
rgmprd

(usa elementary OS)

Enviado em 11/01/2021 - 23:19h

leandropscardua escreveu:

Não é necessário q haja uma atualização, apenas o aplicativo (q pode estar rodando como serviço). Tente
- matar todo mundo q gerencia pacotes
sudo killall apt apt-get
- remover arquivos de lock
sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock*
- recpnfigurar pacotes
sudo dpkg --configure -a
- atualizar
sudo apt update


Beleza. Fiz o recomendado, e ainda fica tudo travado depois:

[email protected]:~$ sudo killall apt apt-get
[sudo] senha para prd:
apt: nenhum processo localizado
apt-get: nenhum processo localizado
[email protected]:~$ sudo rm /var/lib/apt/lists/lock
[email protected]:~$ sudo rm /var/cache/apt/archives/lock
[email protected]:~$ sudo rm /var/lib/dpkg/lock*
[email protected]:~$ sudo dpkg --configure -a
Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...


Esperei uma hora com esse processo aberto, pra ver se tinha a ver com lentidão, parece que não.

Então abri uma segunda aba no Console, pra identificar e interromper o processo [sudo dpkg --configure -a], pra ver se aparecia uma mensagem de erro lá.


$ sudo lsof /var/cache/debconf/config.dat
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
lsof: WARNING: can't stat() fuse.portal file system /run/user/1000/doc
Output information may be incomplete.
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
frontend 28792 root 4uW REG 8,2 49240 4719212 /var/cache/debconf/config.dat
[email protected]:~$ sudo kill 28792


Aí assim que interrompi esse processo, apareceu o seguinte na primeira aba:

[email protected]:~$ sudo dpkg --configure -a
Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...
Use of uninitialized value $ret in scalar chomp at /usr/share/perl5/Debconf/Client/ConfModule.pm line 132, <STDIN> line 34189143.
Use of uninitialized value $ret in split at /usr/share/perl5/Debconf/Client/ConfModule.pm line 133, <STDIN> line 34189143.
Use of uninitialized value $ret[0] in string eq at /usr/share/perl5/Debconf/Client/ConfModule.pm line 134, <STDIN> line 34189143.
Use of uninitialized value in string eq at /var/lib/dpkg/info/apt-fast.config line 68, <STDIN> line 34189143.
dpkg: erro ao processar o pacote apt-fast (--configure):
installed apt-fast package post-installation script subprocess was killed by signal (Terminado)
Erros foram encontrados durante o processamento de:
apt-fast




6. Re: Erro em dpkg frontend [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 12/01/2021 - 09:09h

Desabilite os serviços apt
https://serverfault.com/questions/1007355/can-i-kill-apt-system-daily-to-fix-the-apt-install-command
Depois rode os comandos novamente


7. Erro sudo apt upgrade

sebastião soares martins
ssoaresmartins

(usa Ubuntu)

Enviado em 12/01/2021 - 11:18h

Olá amigo bom dia! Sou tão leigo quanto você, porém tive um problema parecido. Segui todas as ajudas nenhuma me trouxera sucesso. Depois, sem querer, descobri que o erro era um filho meu que usou o Windows 10, que é instalado em Dual Boot, ele em vês de desligar o computador só hibernou, eu não sabia que poderia ser isso, então reiniciei o windows , e desliguei-o, desapareceu toda trava de meu pc. Se tens Dual Boot tente aí.


8. Re: Erro em dpkg frontend

rafael
rgmprd

(usa elementary OS)

Enviado em 13/01/2021 - 01:42h

leandropscardua escreveu:

Desabilite os serviços apt
https://serverfault.com/questions/1007355/can-i-kill-apt-system-daily-to-fix-the-apt-install-command
Depois rode os comandos novamente


Tivemos alguns avanços. Como vi que tem pessoas com o mesmo problema, vou colocar todo o passo-a-passo do que tô fazendo, blza?

Seguindo as instruções desse tópico que vc sugeriu, primeiro eles orientam a checar quais serviços apt estão instalados:

systemctl list-units | grep apt


E o comando pra desinstalar é "sudo systemctl disable apt [inserir nome]". Por exemplo,

sudo systemctl disable apt-daily.service


Identifiquei dois processos abaixo, que eles orientam interromper:

/etc/cron.daily/update-notifier-common
/etc/cron.weekly/update-notifier-common


Os comandos recomendados lá naquele tópico foram:

sudo systemctl disable apt-daily.service
sudo systemctl disable apt-daily.timer

sudo systemctl disable apt-daily-upgrade.timer
sudo systemctl disable apt-daily-upgrade.service


Depois que interrompi eles, consegui instalar alguns programas que eu queria (basicamente drivers, spotify e outras funcionalidades que os sites indicam). Mesmo com avisos de erro sempre aparecendo.

Mas o comando [sudo dpkg --configure -a] segue reconhecido muitos erros, e o apt-fast não funciona. Segue o resultado desse comando:

[email protected]:~$ sudo su
[email protected]:/home/prd# sudo dpkg --configure -a
dpkg: problemas com dependências impedem a configuração de libedit2:i386:
libedit2:i386 depende de libc6 (>= 2.17); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libedit2:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libatomic1:i386:
libatomic1:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libatomic1:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxcb-present0:i386:
libxcb-present0:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxcb-present0:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libglvnd0:i386:
libglvnd0:i386 depende de libc6 (>= 2.8); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libglvnd0:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libtinfo5:i386:
libtinfo5:i386 depende de libc6 (>= 2.16); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libtinfo5:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxcb-dri2-0:i386:
libxcb-dri2-0:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxcb-dri2-0:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxcb-dri3-0:i386:
libxcb-dri3-0:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxcb-dri3-0:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxcb-glx0:i386:
libxcb-glx0:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxcb-glx0:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libexpat1:i386:
libexpat1:i386 depende de libc6 (>= 2.25); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libexpat1:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libnvidia-decode-450-server:i386:
libnvidia-decode-450-server:i386 depende de libc6 (>= 2.1.3); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libnvidia-decode-450-server:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libllvm10:i386:
libllvm10:i386 depende de libatomic1 (>= 4.8); porém:
Pacote libatomic1:i386 não está configurado ainda.
libllvm10:i386 depende de libc6 (>= 2.27); porém:
Pacote libc6:i386 não está instalado.
libllvm10:i386 depende de libedit2 (>= 2.11-20080614); porém:
Pacote libedit2:i386 não está configurado ainda.
libllvm10:i386 depende de libtinfo5 (>= 6); porém:
Pacote libtinfo5:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libllvm10:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando nvidia-prime (0.8.8.2) ...
dpkg: problemas com dependências impedem a configuração de libxdamage1:i386:
libxdamage1:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxdamage1:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libnvidia-ifr1-450-server:i386:
libnvidia-ifr1-450-server:i386 depende de libc6 (>= 2.3.6-6~); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libnvidia-ifr1-450-server:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxext6:i386:
libxext6:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxext6:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxfixes3:i386:
libxfixes3:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxfixes3:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libdrm-amdgpu1:i386:
libdrm-amdgpu1:i386 depende de libc6 (>= 2.17); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libdrm-amdgpu1:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de zlib1g:i386:
zlib1g:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote zlib1g:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libelf1:i386:
libelf1:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.
libelf1:i386 depende de zlib1g (>= 1:1.1.4); porém:
Pacote zlib1g:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libelf1:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxshmfence1:i386:
libxshmfence1:i386 depende de libc6 (>= 2.27); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxshmfence1:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libx11-6:i386:
libx11-6:i386 depende de libc6 (>= 2.15); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libx11-6:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libgl1-mesa-dri:i386:
libgl1-mesa-dri:i386 depende de libc6 (>= 2.27); porém:
Pacote libc6:i386 não está instalado.
libgl1-mesa-dri:i386 depende de libdrm-amdgpu1 (>= 2.4.100); porém:
Pacote libdrm-amdgpu1:i386 não está configurado ainda.
libgl1-mesa-dri:i386 depende de libelf1 (>= 0.142); porém:
Pacote libelf1:i386 não está configurado ainda.
libgl1-mesa-dri:i386 depende de libexpat1 (>= 2.0.1); porém:
Pacote libexpat1:i386 não está configurado ainda.
libgl1-mesa-dri:i386 depende de libllvm10 (>= 1:9~svn298832-1~); porém:
Pacote libllvm10:i386 não está configurado ainda.
libgl1-mesa-dri:i386 depende de zlib1g (>= 1:1.1.4); porém:
Pacote zlib1g:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libgl1-mesa-dri:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libzstd1:i386:
libzstd1:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libzstd1:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando libnvidia-compute-450-server:amd64 (450.80.02-0ubuntu0.18.04.3) ...
dpkg: problemas com dependências impedem a configuração de libnvidia-compute-450-server:i386:
libnvidia-compute-450-server:i386 depende de libc6 (>= 2.7); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libnvidia-compute-450-server:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libglapi-mesa:i386:
libglapi-mesa:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libglapi-mesa:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libnvidia-gl-450-server:i386:
libnvidia-gl-450-server:i386 depende de libc6 (>= 2.3.6-6~); porém:
Pacote libc6:i386 não está instalado.
libnvidia-gl-450-server:i386 depende de libx11-6; porém:
Pacote libx11-6:i386 não está configurado ainda.
libnvidia-gl-450-server:i386 depende de libxext6; porém:
Pacote libxext6:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libnvidia-gl-450-server:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libbsd0:i386:
libbsd0:i386 depende de libc6 (>= 2.25); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libbsd0:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libdrm2:i386:
libdrm2:i386 depende de libc6 (>= 2.17); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libdrm2:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxcb-sync1:i386:
libxcb-sync1:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxcb-sync1:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando nvidia-kernel-source-450-server (450.80.02-0ubuntu0.18.04.3) ...
dpkg: problemas com dependências impedem a configuração de libdrm-intel1:i386:
libdrm-intel1:i386 depende de libc6 (>= 2.17); porém:
Pacote libc6:i386 não está instalado.
libdrm-intel1:i386 depende de libdrm2 (>= 2.4.38); porém:
Pacote libdrm2:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libdrm-intel1:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando libx11-xcb1:i386 (2:1.6.4-3ubuntu0.3) ...
Configurando dkms (2.3-3ubuntu9.7+elementary11~ubuntu5.0.1) ...
Configurando libnvidia-cfg1-450-server:amd64 (450.80.02-0ubuntu0.18.04.3) ...
Configurando libnvidia-common-450-server (450.80.02-0ubuntu0.18.04.3) ...
Configurando screen-resolution-extra (0.17.3) ...
Configurando gcc-8-base:i386 (8.4.0-1ubuntu1~18.04) ...
Configurando nvidia-compute-utils-450-server (450.80.02-0ubuntu0.18.04.3) ...
Alerta: o diretório pessoal /nonexistent que você especificou não pode ser acessado: No such file or directory
Adicionando usuário de sistema 'nvidia-persistenced' (UID 122) ...
Adicionando novo grupo `nvidia-persistenced' (GID 129) ...
Adicionando novo usuário `nvidia-persistenced' (UID 122) ao grupo `nvidia-persistenced' ...
Sem criar diretório pessoal `/nonexistent'.
dpkg: problemas com dependências impedem a configuração de libnvidia-encode-450-server:i386:
libnvidia-encode-450-server:i386 depende de libc6 (>= 2.1.3); porém:
Pacote libc6:i386 não está instalado.
libnvidia-encode-450-server:i386 depende de libnvidia-decode-450-server; porém:
Pacote libnvidia-decode-450-server:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libnvidia-encode-450-server:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libgl1:i386:
libgl1:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.
libgl1:i386 depende de libglvnd0 (= 1.0.0-2ubuntu2.3); porém:
Pacote libglvnd0:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libgl1:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libpciaccess0:i386:
libpciaccess0:i386 depende de libc6 (>= 2.7); porém:
Pacote libc6:i386 não está instalado.
libpciaccess0:i386 depende de zlib1g (>= 1:1.2.3.3); porém:
Pacote zlib1g:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libpciaccess0:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libsensors4:i386:
libsensors4:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libsensors4:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libstdc++6:i386:
libstdc++6:i386 depende de libc6 (>= 2.18); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libstdc++6:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...


Nessa última linha, o terminal ainda ficou aguardando o apt-fast, da mesma maneira de antes.

Tentei repetir o que fiz antes: abri uma nova aba do terminal pra identificar a ID do processo com o "sudo lsof /var/cache/debconf/config.dat" e usar o "sudo kill" para terminar o processo que tinha lá, que foi esse: [frontend 12411 root 4uW REG 8,2 49240 4719212 /var/cache/debconf/config.dat].

Dessa vez, ao invés da aba do terminal anterior só encerrar o processo, ele abriu uma janela vermelha com um quadro no meio, com a seguinte mensagem:

Configurando libdvd-pkg
Este pacote automatiza o processo de lançar downloads de ficheiros fonte para libdvdcss2 a partir de videolan.org, compilando-os, e instalando os pacotes binários (libdvdcss2 libdvdcss-dev).
Por favor corra "sudo dpkg-reconfigure libdvd-pkg" para lançar este processo pela primeira vez

<Ok>



Escolhi "OK". Abriu um outro quadro perguntando se eu queria tornar as atualizações automáticas ou não. Como lá afirmava também que a atualização automática dependia do apt-fast não dar problemas, eu preferi deixar pra atualizar manualmente (sudo dpkg-reconfigure libdvd-pkg), já que é justo esse o problema.

Depois que escolhi essas opções, o processo parece ter seguido adiante:

dpkg: erro ao processar o pacote libstdc++6:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...
Use of uninitialized value $ret in scalar chomp at /usr/share/perl5/Debconf/Client/ConfModule.pm line 132, <STDIN> line 16074211.
Use of uninitialized value $ret in split at /usr/share/perl5/Debconf/Client/ConfModule.pm line 133, <STDIN> line 16074211.
Use of uninitialized value $ret[0] in string eq at /usr/share/perl5/Debconf/Client/ConfModule.pm line 134, <STDIN> line 16074211.
dpkg: erro ao processar o pacote apt-fast (--configure):
installed apt-fast package post-installation script subprocess was killed by signal (Terminado)
dpkg: problemas com dependências impedem a configuração de libffi6:i386:
libffi6:i386 depende de libc6 (>= 2.7); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libffi6:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libdrm-radeon1:i386:
libdrm-radeon1:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.
libdrm-radeon1:i386 depende de libdrm2 (>= 2.4.38); porém:
Pacote libdrm2:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libdrm-radeon1:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando libdvd-pkg (1.4.2-1-1) ...
libdvd-pkg: dpkg database is locked. You may need to use command "sudo dpkg-reconfigure libdvd-pkg".
dpkg: problemas com dependências impedem a configuração de libnvidia-fbc1-450-server:i386:
libnvidia-fbc1-450-server:i386 depende de libc6 (>= 2.3.6-6~); porém:
Pacote libc6:i386 não está instalado.
libnvidia-fbc1-450-server:i386 depende de libgl1; porém:
Pacote libgl1:i386 não está configurado ainda.
libnvidia-fbc1-450-server:i386 depende de libx11-6; porém:
Pacote libx11-6:i386 não está configurado ainda.
libnvidia-fbc1-450-server:i386 depende de libxext6; porém:
Pacote libxext6:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libnvidia-fbc1-450-server:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando libnvidia-fbc1-450-server:amd64 (450.80.02-0ubuntu0.18.04.3) ...
dpkg: problemas com dependências impedem a configuração de libxdmcp6:i386:
libxdmcp6:i386 depende de libbsd0 (>= 0.2.0); porém:
Pacote libbsd0:i386 não está configurado ainda.
libxdmcp6:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxdmcp6:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxxf86vm1:i386:
libxxf86vm1:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.
libxxf86vm1:i386 depende de libx11-6 (>= 2:1.6.0); porém:
Pacote libx11-6:i386 não está configurado ainda.
libxxf86vm1:i386 depende de libxext6; porém:
Pacote libxext6:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libxxf86vm1:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libdrm-nouveau2:i386:
libdrm-nouveau2:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.
libdrm-nouveau2:i386 depende de libdrm2 (>= 2.4.38); porém:
Pacote libdrm2:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libdrm-nouveau2:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando nvidia-kernel-common-450-server (450.80.02-0ubuntu0.18.04.3) ...
update-initramfs: deferring update (trigger activated)
dpkg: problemas com dependências impedem a configuração de libglx0:i386:
libglx0:i386 depende de libc6 (>= 2.8); porém:
Pacote libc6:i386 não está instalado.
libglx0:i386 depende de libglvnd0 (= 1.0.0-2ubuntu2.3); porém:
Pacote libglvnd0:i386 não está configurado ainda.
libglx0:i386 depende de libx11-6 (>= 2:1.4.99.1); porém:
Pacote libx11-6:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libglx0:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libxcb1:i386:
libxcb1:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.
libxcb1:i386 depende de libxdmcp6; porém:
Pacote libxdmcp6:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libxcb1:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando libxnvctrl0:amd64 (440.82-0ubuntu0.18.04.1) ...
Configurando libnvidia-extra-450-server:amd64 (450.80.02-0ubuntu0.18.04.3) ...
dpkg: problemas com dependências impedem a configuração de libxau6:i386:
libxau6:i386 depende de libc6 (>= 2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libxau6:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libgcc1:i386:
libgcc1:i386 depende de libc6 (>= 2.2.4); porém:
Pacote libc6:i386 não está instalado.

dpkg: erro ao processar o pacote libgcc1:i386 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libglx-mesa0:i386:
libglx-mesa0:i386 depende de libc6 (>= 2.8); porém:
Pacote libc6:i386 não está instalado.
libglx-mesa0:i386 depende de libdrm2 (>= 2.4.75); porém:
Pacote libdrm2:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libexpat1 (>= 2.0.1); porém:
Pacote libexpat1:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libglapi-mesa (= 20.0.8-0ubuntu1~18.04.1); porém:
Pacote libglapi-mesa:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libx11-6 (>= 2:1.4.99.1); porém:
Pacote libx11-6:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxcb-dri2-0 (>= 1.8); porém:
Pacote libxcb-dri2-0:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxcb-dri3-0 (>= 1.13); porém:
Pacote libxcb-dri3-0:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxcb-glx0 (>= 1.8); porém:
Pacote libxcb-glx0:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxcb-present0; porém:
Pacote libxcb-present0:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxcb-sync1; porém:
Pacote libxcb-sync1:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxcb1 (>= 1.9.2); porém:
Pacote libxcb1:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxdamage1 (>= 1:1.1); porém:
Pacote libxdamage1:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxext6; porém:
Pacote libxext6:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxfixes3; porém:
Pacote libxfixes3:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxshmfence1; porém:
Pacote libxshmfence1:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libxxf86vm1; porém:
Pacote libxxf86vm1:i386 não está configurado ainda.
libglx-mesa0:i386 depende de libgl1-mesa-dri; porém:
Pacote libgl1-mesa-dri:i386 não está configurado ainda.

dpkg: erro ao processar o pacote libglx-mesa0:i386 (--configure):
problemas de dependência - deixando desconfigurado
Configurando nvidia-utils-450-server (450.80.02-0ubuntu0.18.04.3) ...
Configurando xserver-xorg-video-nvidia-450-server (450.80.02-0ubuntu0.18.04.3) ...
Configurando libnvidia-decode-450-server:amd64 (450.80.02-0ubuntu0.18.04.3) ...
Configurando libnvidia-gl-450-server:amd64 (450.80.02-0ubuntu0.18.04.3) ...
Configurando nvidia-settings (440.82-0ubuntu0.18.04.1) ...
Configurando libnvidia-encode-450-server:amd64 (450.80.02-0ubuntu0.18.04.3) ...
Configurando nvidia-dkms-450-server (450.80.02-0ubuntu0.18.04.3) ...
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-srv
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
Loading new nvidia-srv-450.80.02 DKMS files...
Building for 5.4.0-60-generic
Building for architecture x86_64
Building initial module for 5.4.0-60-generic
Done.

nvidia:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/5.4.0-60-generic/extra/

nvidia-modeset.ko:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/5.4.0-60-generic/extra/

nvidia-drm.ko:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/5.4.0-60-generic/extra/

nvidia-uvm.ko:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/5.4.0-60-generic/extra/

depmod........

DKMS: install completed.
Configurando libnvidia-ifr1-450-server:amd64 (450.80.02-0ubuntu0.18.04.3) ...
Configurando nvidia-driver-450-server (450.80.02-0ubuntu0.18.04.3) ...
A processar 'triggers' para desktop-file-utils (0.23-1ubuntu3.18.04.2+elementary2~ubuntu5.0.1) ...
A processar 'triggers' para bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
A processar 'triggers' para libc-bin (2.27-3ubuntu1.4) ...
A processar 'triggers' para man-db (2.8.3-2ubuntu0.1) ...
A processar 'triggers' para gnome-menus (3.13.3-11ubuntu1.1) ...
A processar 'triggers' para dbus (1.12.2-1ubuntu1.2) ...
A processar 'triggers' para mime-support (3.60ubuntu1) ...
A processar 'triggers' para initramfs-tools (0.130ubuntu3.11) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-60-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8125a-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168fp-3.fw for module r8169
W: Possible missing firmware /lib/firmware/i915/tgl_dmc_ver2_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/icl_guc_33.0.0.bin for module i915
I: The initramfs will attempt to resume from /dev/sda5
I: (UUID=64880d37-e5e0-4416-92e1-fff1f3086bb8)
I: Set the RESUME variable to override this.
Erros foram encontrados durante o processamento de:
libedit2:i386
libatomic1:i386
libxcb-present0:i386
libglvnd0:i386
libtinfo5:i386
libxcb-dri2-0:i386
libxcb-dri3-0:i386
libxcb-glx0:i386
libexpat1:i386
libnvidia-decode-450-server:i386
libllvm10:i386
libxdamage1:i386
libnvidia-ifr1-450-server:i386
libxext6:i386
libxfixes3:i386
libdrm-amdgpu1:i386
zlib1g:i386
libelf1:i386
libxshmfence1:i386
libx11-6:i386
libgl1-mesa-dri:i386
libzstd1:i386
libnvidia-compute-450-server:i386
libglapi-mesa:i386
libnvidia-gl-450-server:i386
libbsd0:i386
libdrm2:i386
libxcb-sync1:i386
libdrm-intel1:i386
libnvidia-encode-450-server:i386
libgl1:i386
libpciaccess0:i386
libsensors4:i386
libstdc++6:i386
apt-fast
libffi6:i386
libdrm-radeon1:i386
libnvidia-fbc1-450-server:i386
libxdmcp6:i386
libxxf86vm1:i386
libdrm-nouveau2:i386
libglx0:i386
libxcb1:i386
libxau6:i386
libgcc1:i386
libglx-mesa0:i386


Tentei remover o apt-fast problemático [apt-fast remove] e o Terminal listou vários pacotes que precisam de outros pra rodar,mas que não estavam instalados, e sugeriu o comando [apt --fix-broken install] pra corrigir isso:

[email protected]:~$ apt-fast remove
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
libatomic1:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libbsd0:i386 : Depende: libc6:i386 (>= 2.25) mas não está instalado
libdrm-amdgpu1:i386 : Depende: libc6:i386 (>= 2.17) mas não está instalado
libdrm-intel1:i386 : Depende: libc6:i386 (>= 2.17) mas não está instalado
libdrm-nouveau2:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libdrm-radeon1:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libdrm2:i386 : Depende: libc6:i386 (>= 2.17) mas não está instalado
libedit2:i386 : Depende: libc6:i386 (>= 2.17) mas não está instalado
libelf1:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libexpat1:i386 : Depende: libc6:i386 (>= 2.25) mas não está instalado
libffi6:i386 : Depende: libc6:i386 (>= 2.7) mas não está instalado
libgcc1:i386 : Depende: libc6:i386 (>= 2.2.4) mas não está instalado
libgl1:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libgl1-mesa-dri:i386 : Depende: libc6:i386 (>= 2.27) mas não está instalado
libglapi-mesa:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libglvnd0:i386 : Depende: libc6:i386 (>= 2.8) mas não está instalado
libglx-mesa0:i386 : Depende: libc6:i386 (>= 2.8) mas não está instalado
libglx0:i386 : Depende: libc6:i386 (>= 2.8) mas não está instalado
libllvm10:i386 : Depende: libc6:i386 (>= 2.27) mas não está instalado
libnvidia-compute-450-server:i386 : Depende: libc6:i386 (>= 2.7) mas não está instalado
libnvidia-decode-450-server:i386 : Depende: libc6:i386 (>= 2.1.3) mas não está instalado
libnvidia-encode-450-server:i386 : Depende: libc6:i386 (>= 2.1.3) mas não está instalado
libnvidia-fbc1-450-server:i386 : Depende: libc6:i386 (>= 2.3.6-6~) mas não está instalado
libnvidia-gl-450-server:i386 : Depende: libc6:i386 (>= 2.3.6-6~) mas não está instalado
libnvidia-ifr1-450-server:i386 : Depende: libc6:i386 (>= 2.3.6-6~) mas não está instalado
libpciaccess0:i386 : Depende: libc6:i386 (>= 2.7) mas não está instalado
libsensors4:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libstdc++6:i386 : Depende: libc6:i386 (>= 2.18) mas não está instalado
libtinfo5:i386 : Depende: libc6:i386 (>= 2.16) mas não está instalado
libx11-6:i386 : Depende: libc6:i386 (>= 2.15) mas não está instalado
libxau6:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxcb-dri2-0:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxcb-dri3-0:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxcb-glx0:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxcb-present0:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxcb-sync1:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxcb1:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxdamage1:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxdmcp6:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxext6:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxfixes3:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libxshmfence1:i386 : Depende: libc6:i386 (>= 2.27) mas não está instalado
libxxf86vm1:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
libzstd1:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
zlib1g:i386 : Depende: libc6:i386 (>= 2.4) mas não está instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).


Tentei então, como sugeria ali, o [sudo apt --fix-broken install] pra corrigir, mas a atualização e instalação desses pacotes faltantes ficou paralizada nos 2%:

[email protected]:~# apt --fix-broken install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
The following additional packages will be installed:
libc6:i386
Pacotes sugeridos:
glibc-doc:i386 locales:i386
Os NOVOS pacotes a seguir serão instalados:
libc6:i386
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.
46 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/2.551 kB de arquivos.
Depois desta operação, 10,8 MB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Pré-configurando pacotes ...
dpkg: aviso: falta ficheiro de lista de ficheiros 'libmspack0:amd64'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'cabextract'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de fichsudo lsof /var/cache/debconf/config.dateiros 'python3-debconf'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'python3-debian'; assumindo que o pacote não tem actualmente ficheiros instalados
(Lendo banco de dados ... 190159 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libc6_2.27-3ubuntu1.4_i386.deb ...
A descompactar libc6:i386 (2.27-3ubuntu1.4) ...
Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...

Progress: [ 2%] [#..........


Outra vez fiz a função: abri outra aba do Terminal, rodei o comando [sudo lsof /var/cache/debconf/config.dat] pra ver qual processo estava interrompendo, e usei o "sudo kill" pra encerrar o processo.

Só depois disso que a coisa andou:

Configurando apt-fast (1.9.10-1~ubuntu18.04.1) ...

Use of uninitialized value $ret in scalar chomp at /usr/share/perl5/Debconf/Client/ConfModule.pm line 132, <STDIN> line 5984227.
Use of uninitialized value $ret in split at /usr/share/perl5/Debconf/Client/ConfModule.pm line 133, <STDIN> line 5984227.
Use of uninitialized value $ret[0] in string eq at /usr/share/perl5/Debconf/Client/ConfModule.pm line 134, <STDIN> line 5984227.
dpkg: erro ao processar o pacote apt-fast (--configure):
installed apt-fast package post-installation script subprocess was killed by signal (Terminado)
Configurando libc6:i386 (2.27-3ubuntu1.4) ...
Configurando libnvidia-compute-450-server:i386 (450.80.02-0ubuntu0.18.04.3) ...
Configurando libglapi-mesa:i386 (20.0.8-0ubuntu1~18.04.1) ...
Configurando libbsd0:i386 (0.8.7-1ubuntu0.1) ...
Configurando libdrm2:i386 (2.4.101-2~18.04.1) ...
Configurando libsensors4:i386 (1:3.4.0-4) ...
Configurando libffi6:i386 (3.2.1-8) ...
Configurando libdrm-radeon1:i386 (2.4.101-2~18.04.1) ...
Configurando libxdmcp6:i386 (1:1.1.2-3) ...
Configurando libdrm-nouveau2:i386 (2.4.101-2~18.04.1) ...
Configurando libxau6:i386 (1:1.0.8-1ubuntu1) ...
Configurando libgcc1:i386 (1:8.4.0-1ubuntu1~18.04) ...
Configurando libatomic1:i386 (8.4.0-1ubuntu1~18.04) ...
Configurando libglvnd0:i386 (1.0.0-2ubuntu2.3) ...
Configurando libtinfo5:i386 (6.1-1ubuntu1.18.04) ...
Configurando libexpat1:i386 (2.2.5-3ubuntu0.2) ...
Configurando libdrm-amdgpu1:i386 (2.4.101-2~18.04.1) ...
Configurando zlib1g:i386 (1:1.2.11.dfsg-0ubuntu2) ...
Configurando libelf1:i386 (0.170-0.4ubuntu0.1) ...
Configurando libxshmfence1:i386 (1.3-1) ...
Configurando libzstd1:i386 (1.3.3+dfsg-2ubuntu1.1) ...
Configurando libpciaccess0:i386 (0.14-1) ...
Configurando libstdc++6:i386 (8.4.0-1ubuntu1~18.04) ...
Configurando libxcb1:i386 (1.13-2~ubuntu18.04) ...
Configurando libedit2:i386 (3.1-20170329-1) ...
Configurando libxcb-present0:i386 (1.13-2~ubuntu18.04) ...
Configurando libxcb-dri2-0:i386 (1.13-2~ubuntu18.04) ...
Configurando libxcb-dri3-0:i386 (1.13-2~ubuntu18.04) ...
Configurando libxcb-glx0:i386 (1.13-2~ubuntu18.04) ...
Configurando libllvm10:i386 (1:10.0.0-4ubuntu1~18.04.2) ...
Configurando libx11-6:i386 (2:1.6.4-3ubuntu0.3) ...
Configurando libxcb-sync1:i386 (1.13-2~ubuntu18.04) ...
Configurando libdrm-intel1:i386 (2.4.101-2~18.04.1) ...
Configurando libxdamage1:i386 (1:1.1.4-3) ...
Configurando libxext6:i386 (2:1.3.3-1) ...
Configurando libxfixes3:i386 (1:5.0.3-1) ...
Configurando libgl1-mesa-dri:i386 (20.0.8-0ubuntu1~18.04.1) ...
Configurando libnvidia-gl-450-server:i386 (450.80.02-0ubuntu0.18.04.3) ...
Configurando libxxf86vm1:i386 (1:1.1.4-1) ...
Configurando libglx-mesa0:i386 (20.0.8-0ubuntu1~18.04.1) ...
Configurando libnvidia-decode-450-server:i386 (450.80.02-0ubuntu0.18.04.3) ...
Configurando libnvidia-encode-450-server:i386 (450.80.02-0ubuntu0.18.04.3) ...
Configurando libglx0:i386 (1.0.0-2ubuntu2.3) ...
Configurando libgl1:i386 (1.0.0-2ubuntu2.3) ...
Configurando libnvidia-fbc1-450-server:i386 (450.80.02-0ubuntu0.18.04.3) ...
Configurando libnvidia-ifr1-450-server:i386 (450.80.02-0ubuntu0.18.04.3) ...
A processar 'triggers' para libc-bin (2.27-3ubuntu1.4) ...
Erros foram encontrados durante o processamento de:
apt-fast
E: Sub-process /usr/bin/dpkg returned an error code (1)


Ou seja, parece que consegui andar com várias atualizações, mas o apt-fast ainda segue trazendo problemas. Acho que seria melhor se eu conseguisse desinstalar ele, mas isso não tô conseguindo também...



9. Re: Erro em dpkg frontend [RESOLVIDO]

rafael
rgmprd

(usa elementary OS)

Enviado em 13/01/2021 - 01:44h

ssoaresmartins escreveu:

Olá amigo bom dia! Sou tão leigo quanto você, porém tive um problema parecido. Segui todas as ajudas nenhuma me trouxera sucesso. Depois, sem querer, descobri que o erro era um filho meu que usou o Windows 10, que é instalado em Dual Boot, ele em vês de desligar o computador só hibernou, eu não sabia que poderia ser isso, então reiniciei o windows , e desliguei-o, desapareceu toda trava de meu pc. Se tens Dual Boot tente aí.


Valeu, amigo, mas não tenho dual boot não, só o Elementary OS Hera e uma outra partição Swap. Direto uso a função Suspender, e não uso a função Hibernar. De qualquer forma, eu já havia desligado e ligado antes também. Vamos ver se encontramos a solução... abraço!




10. Re: Erro em dpkg frontend [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 13/01/2021 - 08:58h

Desabilite todos os repositórios exceto main e tente o
sudo apt-get update
sudo apt-get install -f
https://linuxhint.com/apt_get_fix_missing_broken_packages/


11. Re: Erro em dpkg frontend

rafael
rgmprd

(usa elementary OS)

Enviado em 13/01/2021 - 12:08h

leandropscardua escreveu:

Desabilite todos os repositórios exceto main e tente o
sudo apt-get update
sudo apt-get install -f
https://linuxhint.com/apt_get_fix_missing_broken_packages/


Desculpe amigo, sou iniciante, infelizmente não faço ideia de como "desabilitar repositórios exceto main". Mas segui as orientações no outro tópico que vc indicou, acho que consegui finalmente desabilitar o apt-fast.

Primeiro sugerem fazer update pra ver se não existem pacotes desatualizados e rodar o comando que vc sugeriu

sudo apt-get update --fix-missing
sudo apt-get install -f


Isso não resolveu meu problema, além de o apt-fast trancar e eu ter que repetir o procedimento de matar o processo em outra aba do Terminal.

Mas as opções seguintes que dão lá deram certo:

1. Fazer o update do index do repositório

$ sudo apt-get update


2. Limpar o repositório local:

$ sudo apt-get clean


3. Remover pacotes desnecessários ou que não tem mais utilidade:

$ sudo apt-get autoremove


Aqui o apt-fast seguiu impedindo o processo de continuar, e 'matei' ele em outra aba novamente. Mas depois disso, consegui remover ele:

[email protected]:~# apt-get remove apt-fast
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
aria2 libc-ares2
Utilize 'apt autoremove' para os remover.
Os pacotes a seguir serão REMOVIDOS:
apt-fast
0 pacotes atualizados, 0 pacotes novos instalados, 1 a serem removidos e 5 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 128 kB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
dpkg: aviso: falta ficheiro de lista de ficheiros 'libmspack0:amd64'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'cabextract'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'python3-debconf'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'python3-debian'; assumindo que o pacote não tem actualmente ficheiros instalados
(Lendo banco de dados ... 191354 ficheiros e directórios actualmente instalados.)
A remover apt-fast (1.9.10-1~ubuntu18.04.1) ...
A processar 'triggers' para man-db (2.8.3-2ubuntu0.1) ...


Depois disso tentei reconfigurar os pacotes que não tenham sido instalados direito

$ sudo dpkg --configure -a


Não retornou nenhum problema. No meu caso não precisou, mas se tivesse apontado para um problema, a sugestão lá seria executar o
$ apt-get remove <nome_do_pacote>
pra remover o pacote com problema.

Limpeza do repositório local:

$ sudo apt-get clean


Update pra certificar que tá tudo ok e os pacotes incompletos foram removidos ou consertados:

$ sudo apt-get update


Grato pela ajuda!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts