ERRO [RESOLVIDO]

1. ERRO [RESOLVIDO]

Adilson
zolhodegato

(usa Linux Mint)

Enviado em 01/09/2010 - 19:49h

Olá pessooal, aqui estou com mais uma dúvida, é que quando eu atualizo o sistema ou instalo algum programa, está aparecendo a seguinte mensagem de erro: E: tex-common: sub-processo script post-installation instalado retornou estado de saída de erro 1
E: texlive-binaries: problemas de dependência - deixando desconfigurado
Alguém sabe como resolver? Eu vi alguns comandos para procurar e corrigir erros e não consegui resultado, desde já agradeço alguma ajuda, obrigado.
Abrçs!


  


2. MELHOR RESPOSTA

Perfil removido
removido

(usa Nenhuma)

Enviado em 02/09/2010 - 19:44h

De nada cara, com esforço todos aprendemos e nos ajudamos.

O sources.list é importante porque se você não estiver com o certo pra sua distro e misturar repositórios de releases diferentes, acontece muitas vezes problemas de dependências não satisfeitas e por conseguência pacotes quebrados.

Para saber quais são seus repositórios no sources.list:

$ sudo gedit /etc/apt/sources.list

* se quiser copia e cola o resultado aqui.

#

Seria interessante começar do zero, quer tentar?


Remova esses pacotes:

$ sudo apt-get --purge remove tex-common texlive-base texlive texlive-binaries
$ sudo apt-get autoremove --purge


Atualize seu sistema:

$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get dist-upgrade


Tente instalar os benditos pacotes:

$ sudo apt-get install texlive


Olha o quanto de download será baixado no Debian:

$ sudo apt-get install texlive
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Os seguintes pacotes foram automaticamente instalados e não são mais requeridos:
gs-common
Use 'apt-get autoremove' para removê-los.
Os pacotes extra a seguir serão instalados:
cl-asdf clisp common-lisp-controller feynmf lacheck latex-beamer
latex-xcolor libffcall1 libmagick++3 libplot2c2 libpstoedit0c2a libsigsegv0
lmodern luatex pgf prosper ps2eps pstoedit purifyeps realpath tex-common
texlive-base texlive-binaries texlive-common texlive-doc-base
texlive-extra-utils texlive-font-utils texlive-fonts-recommended
texlive-fonts-recommended-doc texlive-generic-recommended texlive-latex-base
texlive-latex-base-doc texlive-latex-recommended
texlive-latex-recommended-doc texlive-luatex texlive-metapost
texlive-metapost-doc texlive-pstricks texlive-pstricks-doc tipa xindy
xindy-rules
Pacotes sugeridos:
gdb clisp-doc clisp-dev slime auctex xfig ivtools-bin tgif transfig
texlive-doc-en perl-tk dvidvi fragmaster latexmk psutils t1utils
Pacotes recomendados:
sbcl lisp-compiler
Os NOVOS pacotes a seguir serão instalados:
cl-asdf clisp common-lisp-controller feynmf lacheck latex-beamer
latex-xcolor libffcall1 libmagick++3 libplot2c2 libpstoedit0c2a libsigsegv0
lmodern luatex pgf prosper ps2eps pstoedit purifyeps realpath tex-common
texlive texlive-base texlive-binaries texlive-common texlive-doc-base
texlive-extra-utils texlive-font-utils texlive-fonts-recommended
texlive-fonts-recommended-doc texlive-generic-recommended texlive-latex-base
texlive-latex-base-doc texlive-latex-recommended
texlive-latex-recommended-doc texlive-luatex texlive-metapost
texlive-metapost-doc texlive-pstricks texlive-pstricks-doc tipa xindy
xindy-rules
0 pacotes atualizados, 43 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.
É preciso baixar 208MB/238MB de arquivos.
Depois desta operação, 432MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]?


Pra que você precisa disso?


3. Re: ERRO [RESOLVIDO]

Diego Langer
dlanger

(usa Debian)

Enviado em 01/09/2010 - 20:36h

Estas usando qual distro?
Os erros surgem após quais comandos?
Que comandos já utilizou para tentar reparar os erros?


4. Re: ERRO [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 01/09/2010 - 20:45h

tenta isso:

$ sudo dpkg --configure -a
$ sudo apt-get -f install

ou

$ sudo apt-get update
$ sudo apt-get -f install
$ sudo apt-get install nome-do-programa

Se puder postar as mensagens fica mais fácil!


5. Re: ERRO [RESOLVIDO]

Adilson
zolhodegato

(usa Linux Mint)

Enviado em 01/09/2010 - 20:46h

Olá, estou usando o Mint 9, os erros dão quando abro o gerênciador de pacotes synaptic e clico para carregar ou baixar algo usar o terminal também.
Os comandos que utilizei foram: sudo apt-get update,sudo apt-get -f install e sudo dpkg --configure -a


6. Re: ERRO [RESOLVIDO]

Adilson
zolhodegato

(usa Linux Mint)

Enviado em 01/09/2010 - 20:56h

Então pessoal, selecionei o totem, para instalar, ele baixou e apareceu a mesma mensagem acima, mais instalou e está funcionando, e esses comandos acima foram os que eu usei mesmo, sei lá o que é isso!


7. Re: ERRO [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 01/09/2010 - 22:37h


Pela sua mensagem parece que o erro está no pacote: tex-common , então tente isso:

$ sudo dpkg -i --force- /var/cache/apt/archives/tex-common-<TECLE TAB PRA AUTOCOMPLETAR>
$ sudo dpkg --configure -a
$ sudo apt-get -f install

Caso seja no texlive-binaries, o mesmo passo acima.

Isso se deve a alguns fatos típicos: mistura de repositórios, interrupção do processo de instalação, pacote danificado, etc.

Da próxima vez, informe seu sources.list e posta a mensagem, OK?


8. sources.list

Perfil removido
removido

(usa Nenhuma)

Enviado em 01/09/2010 - 22:41h


segue uma sources.list básica pro Mint 9, algumas entradas estão desativadas: Mint LXDE, Backports, Proposed Updates, etc


##############################################################
################# Linux Mint 9 Isadora LTS ###################
##############################################################

### Linux Mint 9 Isadora
deb http://packages.linuxmint.com/ isadora main upstream import

### Linux Mint 9 Isadora LXDE
### deb http://packages.linuxmint.com/ isadora-lxde main upstream import

### Linux Mint 9 Isadora Backports
### deb http://packages.linuxmint.com/ isadora backport

### Ubuntu Lucid Lynx Main
deb http://br.archive.ubuntu.com/ubuntu/ lucid main restricted universe multiverse

### Ubuntu Lucid Lynx Updates
deb http://br.archive.ubuntu.com/ubuntu/ lucid-security main restricted universe multiverse
deb http://br.archive.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse

### Ubuntu Lucid Lynx Proposed Updates
### deb http://br.archive.ubuntu.com/ubuntu/ lucid-proposed main restricted universe multiverse

### Ubuntu Lucid Lynx Backports
### deb http://br.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

### Ubuntu Lucid Lynx Partner
deb http://archive.canonical.com/ubuntu lucid partner

### Medibuntu
deb http://packages.medibuntu.org/ lucid free non-free

#

Instalação das Chaves GPG:

$ sudo apt-get update
$ sudo apt-get install medibuntu-keyring
$ sudo apt-get upgrade
$ sudo apt-get dist-upgrade



9. Re: ERRO [RESOLVIDO]

Adilson
zolhodegato

(usa Linux Mint)

Enviado em 02/09/2010 - 19:25h

Então EDPS, tentei os comandos e deu isso: _________________________________________
( I think we are in Rats' Alley where the )
( dead men lost their bones. )
( )
( -- T.S. Eliot )
-----------------------------------------
o
o \_\_ _/_/
o \__/
(oo)\_______
(__)\ )\/\
||----w |
|| ||

[email protected] ~ $ sudo dpkg -i --force- /var/cache/apt/archives/tex-common_2.06_all.deb
[sudo] password for adilson:
(Lendo banco de dados ... 229946 arquivos e diretórios atualmente instalados).
Preparando para substituir tex-common 2.06 (usando .../tex-common_2.06_all.deb) ...
Desempacotando substituto tex-common ...
Configurando tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
Nenhum pacote encontrado casando com texlive-base.
dpkg: erro processando tex-common (--install):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Processando gatilhos para doc-base ...
Processing 2 changed doc-base file(s)...
Registering documents with scrollkeeper...
Processando gatilhos para man-db ...
Erros foram encontrados durante o processamento de:
tex-common
[email protected] ~ $ sudo dpkg --configure -a
Configurando tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
Nenhum pacote encontrado casando com texlive-base.
dpkg: erro processando tex-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas de dependência impedem a configuração de texlive-binaries:
texlive-binaries depende de tex-common (>= 2.00); porém:
Pacote tex-common não está configurado ainda.
dpkg: erro processando texlive-binaries (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
tex-common
texlive-binaries
[email protected] ~ $ sudo apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 7 não atualizados.
2 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Configurando tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
Nenhum pacote encontrado casando com texlive-base.
dpkg: erro processando tex-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas de dependência impedem a configuração de texlive-binaries:
texlive-binaries depende de tex-common (>= 2.00); porém:
Pacote tex-common não está configurado ainda.
dpkg: erro processando texlive-binaries (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório do apport gravado porque a mensagem de erro indica é o seguimento de um erro de uma falha anterior.
Erros foram encontrados durante o processamento de:
tex-common
texlive-binaries
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected] ~ $ sudo dpkg -i --force- /var/cache/apt/archives/texlive-binaries_2009-5ubuntu0.2_i386.deb
(Lendo banco de dados ... 229946 arquivos e diretórios atualmente instalados).
Preparando para substituir texlive-binaries 2009-5ubuntu0.2 (usando .../texlive-binaries_2009-5ubuntu0.2_i386.deb) ...
Desempacotando substituto texlive-binaries ...
dpkg: texlive-binaries: problemas de dependência, mas configurando assim mesmo como pedido:
texlive-binaries depende de tex-common (>= 2.00); porém:
Pacote tex-common não está configurado ainda.
Configurando texlive-binaries (2009-5ubuntu0.2) ...
update-alternatives: usando /usr/bin/xdvi-xaw para fornecer /usr/bin/xdvi.bin (xdvi.bin) em modo automático.
update-alternatives: usando /usr/bin/bibtex.original para fornecer /usr/bin/bibtex (bibtex) em modo automático.
mktexlsr: /usr/share/texmf-texlive not a directory.
mktexlsr: Updating /var/lib/texmf/ls-R-TEXMFMAIN...
mktexlsr: Updating /var/lib/texmf/ls-R...
mktexlsr: Done.

Processando gatilhos para man-db ...
[email protected] ~ $ sudo dpkg --configure -a
Configurando tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
Nenhum pacote encontrado casando com texlive-base.
dpkg: erro processando tex-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
tex-common
[email protected] ~ $ sudo apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 7 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Configurando tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
Nenhum pacote encontrado casando com texlive-base.
dpkg: erro processando tex-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
tex-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected] ~ $ sudo dpkg -i --force- /var/cache/apt/archives/tex-common_2.06_all.deb
(Lendo banco de dados ... 229946 arquivos e diretórios atualmente instalados).
Preparando para substituir tex-common 2.06 (usando .../tex-common_2.06_all.deb) ...
Desempacotando substituto tex-common ...
Configurando tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
Nenhum pacote encontrado casando com texlive-base.
dpkg: erro processando tex-common (--install):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Processando gatilhos para doc-base ...
Processing 2 changed doc-base file(s)...
Registering documents with scrollkeeper...
Processando gatilhos para man-db ...
Erros foram encontrados durante o processamento de:
tex-common
[email protected] ~ $ sudo dpkg --configure -a
Configurando tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
Nenhum pacote encontrado casando com texlive-base.
dpkg: erro processando tex-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
tex-common
[email protected] ~ $ sudo apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 7 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Configurando tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
Nenhum pacote encontrado casando com texlive-base.
dpkg: erro processando tex-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
tex-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected] ~ $ sudo dpkg --configure -a
Configurando tex-common (2.06) ...
Running mktexlsr. This may take some time... done.
Nenhum pacote encontrado casando com texlive-base.
dpkg: erro processando tex-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
tex-common
[email protected] ~ $
E você falou para eu informar minha sources list, desculpe minha ignorância, pois é agora que estou ouvindo falar sobre isso, ainda estou aprendendo então fiquei meio que boiando, e muito obrigado por você está me ajudando, sem falar que curte rock,bom gosto!


10. Re: ERRO [RESOLVIDO]

Adilson
zolhodegato

(usa Linux Mint)

Enviado em 02/09/2010 - 19:57h

Na verdade, por eu não ter o conhecimento bom ainda, fiquei com medo de ser um erro que prejudique alguma coisa, mais isso começou agora, pois baixei e instalei esta distro desde quando ela saiu junto com o ubuntu Lucid, e ela nunca deu problema sempre baixei e instalei vários pacotes e não dava este erro, mais este erro não interfere em nada?
E vou começar do zero agora como você falou.


11. Re: ERRO [RESOLVIDO]

Joao
stack_of

(usa Slackware)

Enviado em 02/09/2010 - 20:01h

Ja aconteceu comigo pacotes corrompidos ou quebrados e nenhum comando resolveu. Parti para a ignorância e removi na mão os arquivos correspondentes em /var/cache/apt/archives/ e /var/lib/dpkg/info/. Feito isso executei os comandos e deu certo.


12. Re: ERRO [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 02/09/2010 - 20:04h

Não! basta que você remova os pacotes com problemas e como teste atualize seu sistema, se nenhuma mensagem aparecer é sinal que está tudo bem.

* os passos pra remover os pacotes e atualizar seu sistema já passei no post anterior.



01 02