Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

1. Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

david
zephyr91

(usa Debian)

Enviado em 29/09/2010 - 21:50h

Olá, Boa noite pessoal
eu estou precisando de ajuda, eu estou tentando colocar o compiz aqui, mas as bordas dele somem, eu tentei instalar ele por apt-get install compiz compizconfig-settings-manager compiz-fusion-plugins-main compiz-gnome compiz-gtk

e tambem por apt-get source -b compiz compizconfig-settings-manager compiz-fusion-plugins-main compiz-gnome compiz-gtk

mas pelo apt-get source ele pede dependencias do kdebase-dev,
so que no meu desktop nao tem nada do kde, e no meu xorg tambem.
o meu xorg do note ta igualzinho o do desktop. entao nao sei oque poderia ser... será que alguem sabe ??

ahh e quando eu instalo o compiz pelo apt-get install ele instala tudo mas na hora de olhar o gerenciador de config ele, o icone dele está apagado nao sei se ajuda em pensar em algo...


  


2. Re: Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 29/09/2010 - 22:04h

vc tem instalador gráfico?
procure todos os pacotes de compiz, instale também fusion-icon, emerald, ccsm, simple-ccsm, todos os plugins, e se achar uma biblioteca auxiliar chamada sexy-python e o cairo-dock, se não for usar o cairo dock, instale pelo menos a biblioteca cairo.
compiz funciona melhor quando está todo completo.
e dá uma busca aqui no vol. pq tem muitas dicas disso aqui.
as bordas sumirem é um problema comum em compiz, e é por causa da memoria de video.

tem vários jeitos de resolver, a mais nova dica é esta:

http://www.vivaolinux.com.br/dica/Bordas-de-janelas-sumiram-com-o-CompizFusion

mas olha também a busca doVOL,pq tem vários jeitos. por. ex. intslando emerald, ativando loose binding e rendering indireto etc...


3. Re: Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 29/09/2010 - 22:08h


no Debian às coisas não são tão fáceis quanto no Ubuntu. Primeiramente sua placa de vídeo deve estar configurada corretamente (supondo que esteja);


Solução caseira do colega edps (funciona no Debian Squeeze :: método das cavernas):

$ sudo apt-get install compiz compiz-fusion-plugins-extra compizconfig-backend-gconf compiz-fusion-plugins-main compiz-fusion-plugins-unsupported compizconfig-settings-manager compiz-gnome compiz-core compiz-gtk fusion-icon


Script em /usr/local/bin:

$ sudo nano /usr/local/bin/compiz-cpp

cola isso:

#!/bin/sh
/usr/bin/compiz ccp

Salve e saia com CTRL+O e CTRL+X

$ sudo chmod +x /usr/local/bin/compiz-cpp

#

Arquivo de configuração em ~/

$ nano ~/.gnomerc

cola isso aqui:

export WINDOW_MANAGER=/usr/local/bin/compiz-ccp

Salve e saia com CTRL+O e CTRL+X


Abra o fucion-icon: Sistema > Compiz Fusion Icon (botão direito: Settings Manager), marque as opções necessárias, pro caso da borda é Redimensionar | Mover Janelas e outras, daí reinicie o ambiente gráfico:

AltGr+PrintScrn+K

Espero que funcione.


4. Re: Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

david
zephyr91

(usa Debian)

Enviado em 29/09/2010 - 22:27h

mas assim eu queria que estivesse igual no meu desk,
tipo nao tem nada a mais que oque eu havia dito, teria alguma maneira de saber o pq ta acontecendo isso ?

edit: eu uso o lenny edps


5. Re: Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 29/09/2010 - 22:55h

Olha no Lenny não sei se isso que passei vai funcionar, só testando. Nem coloquei nos comandos pra instalar o emerald e o emerald-themes porque não existe pro Squeeze.

Sobre a questão do ícone estar apagado, talvez seja porque o composite está desabilitado para a sua placa de vídeo (que placa é), no xorg costuma-se usar as seguintes opções:

Section "Extensions"
Option "Composite" "Enable"
EndSection


6. Re: Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

david
zephyr91

(usa Debian)

Enviado em 29/09/2010 - 23:05h

é uma Nvidia 310m
mas no meu desk é uma nvidia 7600 gt e num tem o composite x.X
oque será ?

edit: eu adicionei o compostie e nao mudou nada,
assim tem como eu remover tudo absolutamente tudo do compiz que foi instalado, pq eu dou um purge nos pacotes que eu instalo ele remove,
so que os arquivos de config continuam la ..

edit: resolvi com oque voce falou edps mas tirando o pacote "compiz".. o resto foi ja certinho


7. Re: Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

Rodrigo Neves Laranjeira Braga
RodrigoNeves

(usa Debian)

Enviado em 29/01/2013 - 18:38h

oi pessoal.

eu fiz o passo a passo deste tópico, mas não funcionou e quando eu dou o comando:

compiz -replace

volta está mensagem de erro:

[1] 2660
[email protected]:/home/rodrigo# compiz (core) - Warn: Unknown option '-replace'

compiz (core) - Warn: SmcOpenConnection failed: None of the authentication protocols specified are supported
compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager


alguém pode me ajudar?


8. Re: Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 30/01/2013 - 10:01h

Não é -replace, é:

compiz --replace

Mas não use comando de replace, pq se ele não conseguir desligar o gerenciador de janelas anterior (ex. metacity) vai conflitar.
prefira instalar fusion-icon, e usa-lo para trocar para compiz.

Outra coisa, lembre que em GNOME-Shell, GNOME3 ou Cinammon, Compiz funciona muito mal.

funciona legal em MATE, XFCE ou LXDE.


9. Re: Compiz no debian nao esta funcionando ajude por favor [RESOLVIDO]

Rodrigo Neves Laranjeira Braga
RodrigoNeves

(usa Debian)

Enviado em 05/02/2013 - 11:10h

oi parceiros,

Eu consegui resolver o problema colocando o compiz-fusion para iniciar ao ligar a maquina em "sistemas - preferência - aplicativos de sessão". então fiz o comando que encontrei na net, que não me lembro agora, e está funcionando belezinha as janelas gelatinosas, o cubo e todas as outras opção.

obrigado por responder.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts