Comando sudo não esta funcionando mais [RESOLVIDO]

1. Comando sudo não esta funcionando mais [RESOLVIDO]

Rogério Chaves
Rogerrc

(usa Ubuntu)

Enviado em 21/07/2021 - 14:19h

Estou usando Ubuntu ha 2 dias e bem, eu instalei o xampp nele hoje e não conseguia achar o executavel do app como existe no vsCode ou até mesmo o fire fox, então desinstalei... Ao utilizar novamente o comando ja dentro da pasta onde estaria o instalador do xampp (sudo ./xampp...) o terminal me dava a resposta de comando não encontrado.
Obs: instalei varias coisas com o comando hoje. Alguém consegue alguma solução pra isso ?


  


2. Re: Comando sudo não esta funcionando mais [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 21/07/2021 - 15:06h


Rogerrc escreveu:

Estou usando Ubuntu ha 2 dias e bem, eu instalei o xampp nele hoje e não conseguia achar o executavel do app como existe no vsCode ou até mesmo o fire fox, então desinstalei... Ao utilizar novamente o comando ja dentro da pasta onde estaria o instalador do xampp (sudo ./xampp...) o terminal me dava a resposta de comando não encontrado.
Obs: instalei varias coisas com o comando hoje. Alguém consegue alguma solução pra isso ?


campeão, se ajuda aí ... copie tudo do terminal ( incluindo o comando dado ) e cole aqui no fórum ( entre as tags 'code' ou 'quote' ) , não adianta explicar o problema com meias palavras pq no terminal um simples '.' no lugar errado faz uma diferença gigantesca !!!

mas a principio o que parece aí é que vc se equivocou, o que o erro quer dizer é que o comando não encontrado é o comando que vc deu depois do sudo !!!

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Re: Comando sudo não esta funcionando mais [RESOLVIDO]

Thiago Boeira
tcboeira

(usa Debian)

Enviado em 21/07/2021 - 15:14h


Não compreendi nada...
MAnda o comando e a saida;;;


4. Descupe-me

Rogério Chaves
Rogerrc

(usa Ubuntu)

Enviado em 21/07/2021 - 15:49h


perdão pessoal eu postei pelo celular amanhã consigo postar o código


5. Re: Comando sudo não esta funcionando mais [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 22/07/2021 - 00:20h


cat ~/.bash_history deve explicar o q aconteceu


6. Re: Comando sudo não esta funcionando mais

Rogério Chaves
Rogerrc

(usa Ubuntu)

Enviado em 22/07/2021 - 08:20h

Olá galera perdão por enviar uma duvida tão confusa e mal explicada mas vai aqui uma imagem do que eu fiz para resolver.
vi hoje em um vídeo...
primeiro eu dei o comando:

$ chmod +X xampp-linux-x64-7.4.21-0-installer.run

para ativar o instalador e depois eu dei o sudo

$ sudo ./xampp-linux-x64-7.4.21-0-installer.run

eu não compreendi por o sudo ja não estava iniciando a aplicação direto



7. Re: Comando sudo não esta funcionando mais [RESOLVIDO]

Thiago Boeira
tcboeira

(usa Debian)

Enviado em 22/07/2021 - 09:26h

Não sei se é isso... Segue confuso - ao menos para mim - tua questão...
Do que tu coloca...É o seguinte...

Comando:
chmod +X xampp-linux-x64-7.4.21-0-installer.run 

É para tornar o arquivo executavel...

sudo ./xampp-linux-x64-7.4.21-0-installer.run 

Para instalar o programa como sudo.


8. Então

Rogério Chaves
Rogerrc

(usa Ubuntu)

Enviado em 22/07/2021 - 16:02h


então parece que eu tinha que habilitar ainda pro arquivo ser executado, acabei esquecendo de habilitar.
Conforme dava o comando sudo sem antes habilitar o arquivo o mesmo não executava.
Pelo que entendi era isso