Audio HDMI não funciona [RESOLVIDO]

1. Audio HDMI não funciona [RESOLVIDO]

fernando uvinha
FerAeroespacial

(usa Debian)

Enviado em 13/01/2013 - 18:08h

Fala galera, queria ver um filminho aqui mas meu cabo HDMI não está passando o audio para a TV, apenas o video...Já tentei algumas coisas como adicionar linhas em /etc/asound.conf mas não deu certo...Em preferências -> som não tem a opção para escolher saída para HDMI =/

Para ver na a imagem na TV estou usando o Arandr, não sei se precisa configurar alguma coisa nele...
Ah, uso Debian Squeeze


  


2. MELHOR RESPOSTA

Raimundo Alves Portela
rai3mb

(usa Outra)

Enviado em 14/01/2013 - 00:16h

Talvez vc já tenha feito, mas no meu caso bastou criar o arquivo asound.conf com o conteúdo pcm.!default hdmi:intel:

sudo echo "pcm.!default hdmi:intel" > /etc/asound.conf



3. Re: Audio HDMI não funciona [RESOLVIDO]

fernando uvinha
FerAeroespacial

(usa Debian)

Enviado em 14/01/2013 - 00:39h

rai3mb escreveu:

Talvez vc já tenha feito, mas no meu caso bastou criar o arquivo asound.conf com o conteúdo pcm.!default hdmi:intel:

sudo echo "pcm.!default hdmi:intel" > /etc/asound.conf



Sim, já fiz isso =/, editei até com algumas outras coisas mas não adiantou =/


4. Re: Audio HDMI não funciona [RESOLVIDO]

Cicero A V Melo
infocav

(usa Slackware)

Enviado em 02/03/2013 - 12:21h

Vei, não sei qual é o modelo da sua placa de som, com a minha que é uma RADEON resolveu da seguinte maneira.

Acrescente a opção radeon.audio=1 nos parametros do kernel

No caso do grub2, edite o arquivo /etc/default/grub, acrescente a opção acima em GRUB_CMDLINE_LINUX e confirme a alteração executando o comando
GRUB_CMDLINE_LINUX="radeon.audio=1"


# grub2-mkconfig -o /boot/grub2/grub.cfg

Dica retirada de: http://avbalves.blogspot.com.br/2012/03/saida-de-audio-hdmi-no-mplayer.html


5. Re: Audio HDMI não funciona [RESOLVIDO]

Rodrigo Namba Dake
shundake

(usa Arch Linux)

Enviado em 26/03/2013 - 17:40h

Poderia postar a saída do comando ?
$ lspci -v

A uns tempos atrás, no meu último emprego, eu estava com um problema com uma placa Radeon. Que não tinha suporte a áudio HDMI.
Talvez possa ser o ser o seu problema.


6. Re: Audio HDMI não funciona [RESOLVIDO]

fernando uvinha
FerAeroespacial

(usa Debian)

Enviado em 26/03/2013 - 17:45h

opa, olha aí a saída!

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
Subsystem: Dell Device 022f
Flags: bus master, fast devsel, latency 0
Capabilities: <access denied>
Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])
Subsystem: Dell Device 022f
Flags: bus master, fast devsel, latency 0, IRQ 45
Memory at fea00000 (64-bit, non-prefetchable) [size=1M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at eff8 [size=8]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
Subsystem: Dell Device 022f
Flags: bus master, fast devsel, latency 0
Memory at feb00000 (64-bit, non-prefetchable) [size=1M]
Capabilities: <access denied>

00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02) (prog-if 00 [UHCI])
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 0, IRQ 20
I/O ports at 6f20 [size=32]
Kernel driver in use: uhci_hcd

00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02) (prog-if 00 [UHCI])
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 0, IRQ 21
I/O ports at 6f00 [size=32]
Kernel driver in use: uhci_hcd

00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02) (prog-if 20 [EHCI])
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 0, IRQ 22
Memory at fed1c400 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci_hcd

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
Subsystem: Dell Device 022f
Flags: bus master, fast devsel, latency 0, IRQ 46
Memory at fe9fc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=09, subordinate=09, sec-latency=0
I/O behind bridge: 0000d000-0000dfff
Memory behind bridge: fe800000-fe8fffff
Prefetchable memory behind bridge: 0000000080200000-00000000803fffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=0b, subordinate=0b, sec-latency=0
I/O behind bridge: 00002000-00002fff
Memory behind bridge: fe700000-fe7fffff
Prefetchable memory behind bridge: 0000000080000000-00000000801fffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 02) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=0c, subordinate=0d, sec-latency=0
I/O behind bridge: 0000c000-0000cfff
Memory behind bridge: fe400000-fe6fffff
Prefetchable memory behind bridge: 00000000f0000000-00000000f01fffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02) (prog-if 00 [UHCI])
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 0, IRQ 20
I/O ports at 6f80 [size=32]
Kernel driver in use: uhci_hcd

00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02) (prog-if 00 [UHCI])
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 0, IRQ 21
I/O ports at 6f60 [size=32]
Kernel driver in use: uhci_hcd

00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02) (prog-if 00 [UHCI])
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 0, IRQ 22
I/O ports at 6f40 [size=32]
Kernel driver in use: uhci_hcd

00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02) (prog-if 20 [EHCI])
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 0, IRQ 20
Memory at fed1c000 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2) (prog-if 01 [Subtractive decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
Memory behind bridge: fe300000-fe3fffff
Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 02)
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 0
Capabilities: <access denied>

00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02) (prog-if 8a [Master SecP PriP])
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 0, IRQ 16
I/O ports at 01f0 [size=8]
I/O ports at 03f4 [size=1]
I/O ports at 0170 [size=8]
I/O ports at 0374 [size=1]
I/O ports at 6fa0 [size=16]
Kernel driver in use: ata_piix

00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 02) (prog-if 01 [AHCI 1.0])
Subsystem: Dell Device 022f
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 44
I/O ports at 6eb0 [size=8]
I/O ports at 6eb8 [size=4]
I/O ports at 6ec0 [size=8]
I/O ports at 6ec8 [size=4]
I/O ports at 6ee0 [size=32]
Memory at fe9fb800 (32-bit, non-prefetchable) [size=2K]
Capabilities: <access denied>
Kernel driver in use: ahci

00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
Subsystem: Dell Device 022f
Flags: medium devsel, IRQ 17
Memory at fe9fb700 (32-bit, non-prefetchable) [size=256]
I/O ports at 10c0 [size=32]
Kernel driver in use: i801_smbus

02:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05) (prog-if 10 [OHCI])
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 64, IRQ 16
Memory at fe3ff800 (32-bit, non-prefetchable) [size=2K]
Capabilities: <access denied>
Kernel driver in use: firewire_ohci

02:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22) (prog-if 01)
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 64, IRQ 18
Memory at fe3ff400 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: sdhci-pci

02:09.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 64, IRQ 18
Memory at fe3ff600 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: r592

02:09.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
Subsystem: Dell Device 022f
Flags: bus master, medium devsel, latency 64, IRQ 18
Memory at fe3ff700 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: r852

09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 12)
Subsystem: Dell Device 022f
Flags: bus master, fast devsel, latency 0, IRQ 43
Memory at fe8fc000 (64-bit, non-prefetchable) [size=16K]
I/O ports at de00 [size=256]
Capabilities: <access denied>
Kernel driver in use: sky2

0b:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
Subsystem: Dell Wireless 1395 WLAN Mini-Card
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at fe7fc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: b43-pci-bridge

[email protected]:~$



7. Re: Audio HDMI não funciona [RESOLVIDO]

Rodrigo Namba Dake
shundake

(usa Arch Linux)

Enviado em 26/03/2013 - 17:55h

Apenas para constar... Já tentou as opções de sons do gnome? (creio que seja gnome que está usando)

gnome-volume-control -> alterar os dispositivos.


8. Re: Audio HDMI não funciona [RESOLVIDO]

fernando uvinha
FerAeroespacial

(usa Debian)

Enviado em 26/03/2013 - 17:59h

As opções de som que você diz não são aquelas que eu citei no primeiro post?

sim, estou usando o Gnome mesmo!


9. Re: Audio HDMI não funciona [RESOLVIDO]

Rodrigo Namba Dake
shundake

(usa Arch Linux)

Enviado em 26/03/2013 - 18:05h

FerAeroespacial escreveu:

As opções de som que você diz não são aquelas que eu citei no primeiro post?

sim, estou usando o Gnome mesmo!


Perdão, falha minha.
Já testou, deixando o hdmi conectado e reiniciando a máquina?


10. Re: Audio HDMI não funciona [RESOLVIDO]

fernando uvinha
FerAeroespacial

(usa Debian)

Enviado em 26/03/2013 - 18:07h

também já testei isso, mas não deu certo =(


11. Re: Audio HDMI não funciona [RESOLVIDO]

Rodrigo Namba Dake
shundake

(usa Arch Linux)

Enviado em 26/03/2013 - 18:14h

FerAeroespacial escreveu:

também já testei isso, mas não deu certo =(


o ' aplay -l ' mostrou a saída HDMI de áudio?
Vou ver se encontro minhas outras anotações e depois retorno.


12. Re: Audio HDMI não funciona [RESOLVIDO]

fernando uvinha
FerAeroespacial

(usa Debian)

Enviado em 28/03/2013 - 14:42h

Shundake, consegui consertar aqui. Se eu falar pra vc o que estava dando pau você não vai acreditar rsrs

eu editei o arquivo /etc/asound.conf, antes estava assim:
pcm.!default hdmi:intel


daí troquei para :
pcm.!default hdmi:Intel


rsrs, acredita que o Intel tinha que ser escrito em letra maiúscula, não em minúscula como estava antes rs!

Obrigado pela atenção!

Abraços!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts